Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.

See also: Hydrogenaudio Terms of Service.

Reply to this topicStart new topic
Error When Switching or Skipping Song Using Wasapi Plugin
post Mar 5 2013, 08:38
Post #1

Group: Members
Posts: 1
Joined: 5-March 13
Member No.: 107025


I am having a problem when using the wasapi plugin with foobar. When I switch the song I am playing to a different song, the song does not play and foobar freezes up for a few seconds than displays the error: Unrecoverable playback error: Timeout. After this, foobar is unusable- when I try to play any more songs I get the error: Unrecoverable playback error: Device in use. I have to unplug and plug back in or restart my DAC for audio to work again. If I enqueue a song to play after the initial song, it plays smoothly once the first song is finished. If I try to use the skip button to go to the next song in the playlist, the same error occurs.

I am using an E-MU 0202 USB as a DAC on Windows 7 64-bit. My Playback > Output settings are Buffer length: 1030 ms, output data format: 24- bit. I have tried modifying these two settings- the buffer length doesn't change the error at all and songs only work on 24-bit. If I change to any other option for output data format no songs work and I get an error: Unrecoverable playback error: Unsupported stream format: 44100 Hz / [8/16/32]-bit / 2 channels. I have tried playing many different mp3s and flacs, the error remains consistent. I have also tried both event and push, but this has no effect on the error.
I am sorry if this is in the wrong place, I wasn't sure if the wasapi component is 3rd party since it is developed by the creator of foobar but it is not bundled with foobar. I have no other components besides wasapi output support that didn't come with foobar.


This post has been edited by pequod: Mar 5 2013, 08:47
Go to the top of the page
+Quote Post
post Apr 16 2013, 17:20
Post #2

Group: Members
Posts: 1
Joined: 16-April 13
Member No.: 107698

Hello everyone,

I have a similar problem. When I use the Wasapi plugin, I get the same error from time to time: "Unrecoverable playback error: Timeout".
Usually it occurs when I start foobar, set the output to Wasapi and try to play the first song. Also it may occur without any visible pre-conditions: the music is playing for about an hour, but then it stops in the middle of a song and I get the "Timeout" error message in a short time.

My environment: Windows 7 32-bit, external usb sound card (Creative XMod).

Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 29th November 2015 - 17:41