Welcome Guest ( Log In | Register )

MB COMAND: large AAC file playback problem, large AAC files cannot be played
post Sep 17 2012, 18:04
Post #1

Group: Members
Posts: 21
Joined: 5-January 12
Member No.: 96263

The wife's car is a 2008 Mercedes C300 with the COMAND multimedia/navigation system. According to the owner's manual, it'll play MP3 and AAC/M4A files.

However, when trying to play AAC files, I noticed that larger files will not play. For example, a 10 MB AAC file will play, but a 25 MB file will not. Such limitation does not exist for MP3 files.

I've got 1-2 hour long mixes that I often convert to AAC for portable players since even down at about 128 kbps AAC files sound very good but take up significantly less space. Alas, the COMAND will not read these.

When I contacted MB about it, they stated that the reason why these larger AAC files will not play is because of a small internal cache. While this does sound like a believable explanation, I wonder why this "small internal cache" is still big enough to play very large MP3 files, but not big enough to play large AAC files? I'm guessing it has to do with the way the COMAND reads AAC files... maybe it tries to load the entire file into cache before playing it as opposed to loading it a few frames at a time like may be the case with MP3 files? Even the cheapest smartphones out there will properly play large AAC files these days, so this is a bit weird.

FYI, I am using the Nero AAC encoder, but I also tried FhG with the same result.

Anyway, this is just an FYI more than anything else, but if someone can provide some insight into how an AAC file is typically read/processed by a player that might explain the above issue, I'd be thankful.

This post has been edited by Pete7874: Sep 17 2012, 18:05
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 29th November 2015 - 13:02