Welcome Guest ( Log In | Register )

WavPack Hybrid broken on (Arch?) Linux, non lossless and heavily distorted
post Jul 5 2012, 18:47
Post #1

Group: Developer
Posts: 1455
Joined: 4-May 04
From: France
Member No.: 13875

I tried to encode and decode several different WAV files from CD rips with WavPack (version 4.60.1) in hybrid mode, on Arch Linux, on two different machines (Intel Core i7 and Xeon, x86_64). I always got the same result: the files are heavily distorted (groups of samples repeating themselves), and obviously non lossless. See samples.

I ran the following commands:
wavpack -b400 -c -m hybrid.wav
wvunpack -m hybrid.wv

wvunpack outputs the following:
WVUNPACK  Hybrid Lossless Audio Decompressor  Linux Version 4.60.1
Copyright (c) 1998 - 2009 Conifer Software.  All Rights Reserved.

original md5:  e180f2ec2c4c65fd214bc6c4f70c7988        
unpacked md5:  2d5edeb0d3d7ba971282428b77fd41c6        
MD5 signatures should match, but do not!

I tried the win32 binary, which worked fine (lossless result). I don't have another Linux distro installed anywhere to see if this problem is distribution-specific. I also tried three different builds (including one built from source by myself), always with the same result.

This post has been edited by skamp: Jul 5 2012, 18:59

See my profile for measurements, tools and recommendations.
Go to the top of the page
+Quote Post
Start new topic
post Dec 8 2012, 22:12
Post #2

Group: Members
Posts: 167
Joined: 18-May 10
From: Montana, USA
Member No.: 80732


Thanks for asking. It happens when using command line tools using both the package compiled from the gentoo repos and the package i compiled manually from svn. If i take a wav file and encode it using wavpack -b400 -c -m hybrid.wav (to use skamp's example for testing purposes) and then play the resulting file in any media player i get the stuttering and distortion. I've tried mplayer, mpc, and gstreamer just to try different libraries with it.

If i then decode the wv+wvc back to wav and play the wav in any of those it displays the same behavior. Sometimes the stuttering starts right away and sometimes it's seconds into the track but the stuttering is exactly the same in both the wv+wvc and the decompressed wav. I don't know that mplayer is actually utilizing the wvc file but mpd is and the same things happen in all 3 players.

What confuses me is that i've been using wavpack-4.60.1 since June 5th and this problem only started occurring on November 28th. The only thing that i'd updated on my system when it stopped working was virtual/libiconv-0. That's a virtual package for gnu charset conversion for libc. What that would have to do with it, i've no clue. It possible that i rebooted the pc and something that was updated a while ago got read into memory (i don't reboot for months at a time usually). The previous kernel i was using was 3.4.9 from august 27th, though on nov 21st i did go from linux-headers-3.4.r2 to linux-headers-3.6. I have recompiled the repo's wavpack package a few times and done a revdep-rebuild which checks for packages that need to be recompiled due to changed libraries and headers to no avail.

sudo uname -a:
Linux jaguarundi 3.5.7-gentoo #1 SMP PREEMPT Tue Nov 13 13:03:54 MST 2012 x86_64 Intel® Core™2 Quad CPU Q9300 @ 2.50GHz GenuineIntel GNU/Linux
(it's a preempt kernel but jack is not running)

If there's any more testing i can do or info i can provide, i'd gladly provide it. If there is a bug list that i can copy this post over to, i'd be glad to.

Thanks Bryant!


Music lover and recovering high end audiophile
Go to the top of the page
+Quote Post

Posts in this topic
- skamp   WavPack Hybrid broken on (Arch?) Linux   Jul 5 2012, 18:47
- - plus   I can confirm this bug exists on Debian Wheezy amd...   Jul 5 2012, 19:21
- - 2012   Fellow Archer here. I confirm the bug. I got non-...   Jul 5 2012, 20:28
- - Angenial   The bug itself appears not to be architecture-rela...   Jul 5 2012, 21:08
- - 2012   Good catch Angenial. Using memmove() instead of m...   Jul 5 2012, 21:46
- - lvqcl   Links about memcpy() behaviour: https://bugzilla....   Jul 5 2012, 21:59
|- - Kohlrabi   QUOTE (lvqcl @ Jul 5 2012, 22:59) Links a...   Jul 6 2012, 00:55
- - bryant   Thanks guys! I have checked Angenial's pat...   Jul 5 2012, 22:19
- - bryant   I knew this sounded familiar! http://www.hy...   Jul 5 2012, 23:22
- - skamp   Any ETA on a bugfix release?   Sep 6 2012, 18:03
- - bryant   I guess Iíve sort of dropped the ball on this. I a...   Sep 7 2012, 07:25
|- - Destroid   QUOTE (bryant @ Sep 7 2012, 07:25) ...ití...   Dec 2 2012, 12:57
- - BearcatSandor   I'm a bit stymied as i've been using wavpa...   Dec 2 2012, 10:51
|- - Mr_Rabid_Teddybear   QUOTE (BearcatSandor @ Dec 2 2012, 02:51)...   Dec 5 2012, 01:33
- - BearcatSandor   Thanks for the link to the SVN and instructions. I...   Dec 7 2012, 01:26
|- - bryant   QUOTE (BearcatSandor @ Dec 6 2012, 16:26)...   Dec 8 2012, 19:48
- - BearcatSandor   Bryant, Thanks for asking. It happens when using ...   Dec 8 2012, 22:12
- - bryant   Well, the first thing is do you get the same MD5 m...   Dec 8 2012, 23:03
- - BearcatSandor   Got it! Thanks Bryant and Mr_rabid_teddybear f...   Dec 9 2012, 21:28
- - skamp   I found another bug (still with version 4.60.1, Li...   May 15 2013, 15:06
- - bryant   Thanks, Skamp! Yeah, the 64-bit Linux memcpy(...   May 15 2013, 17:24
- - skamp   OK, cool!   May 15 2013, 18:28
- - skamp   By the way, this kind of bug calls for generating ...   May 25 2013, 10:09
- - bryant   Yeah, the problem with this bug is that the issue ...   May 26 2013, 01:51
- - skamp   Another shameless plug: caudec SVN (upcoming versi...   May 26 2013, 08:28
|- - bryant   QUOTE (skamp @ May 26 2013, 00:28) Since ...   May 29 2013, 07:01
- - skamp   Moreover, when asked to compute MD5 hashes, caudec...   May 29 2013, 11:15

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 28th November 2015 - 14:41