Welcome Guest ( Log In | Register )

Winamp doesn't play wv playlist w/ rel path
post Jan 20 2010, 06:24
Post #1

Group: Members
Posts: 3
Joined: 20-January 10
Member No.: 77325

A folder with wv files, drag them into Winamp's playlist, save the playlist into the same folder: Winamp won't play the files.
This works with mp3, flac etc., but not with Wavpack files.
When saving a playlist into the same folder that holds the music files, Winamp doesn't write the full path, it reads relatively.
If you save the playlist in a different folder, Winamp writes the full path and the playlist works.
In the former case, when you right click a file's playlist entry and have Winamp show the file info, it even correctly shows the full path, but it won't play the file.

So I cannot rip an album and put the playlist file in the same folder - which sux.

I tried to register for the Winamp bug reporting forum several times, but proofed to have an incompatible mindset for the process. So that's how I landed here.
Does anyone have had this experience, is it reproducable on other systems, or is it something with my constellation?

thanks for your time

XPSp3, P4 D805 2.66 GHz, 2GB RAM, Winamp 5.541
Go to the top of the page
+Quote Post
Start new topic
post Jan 20 2010, 07:17
Post #2

WavPack Developer

Group: Developer (Donating)
Posts: 1351
Joined: 3-January 02
From: San Francisco CA
Member No.: 900

I admit that I have never played around with playlists before, but I was not able to reproduce your problem with winamp 5.571 and WavPack plugin 2.8a, trying both .m3u and .pls playlists. I looked in the playlists with an editor and saw that the filenames were relative, so when the playlist was in the same folder as the files there was no path information at all (and the files played fine). I even played the playlist successfully with VLC (although that doesn't really relate to your question).

Perhaps someone else knows what might be going on here... sad.gif

Go to the top of the page
+Quote Post
post Jan 21 2010, 01:30
Post #3

Group: Members
Posts: 3
Joined: 20-January 10
Member No.: 77325

Thanks for the input.

well, after more experimenting, I don't think this forum is quite the right place to address this. I found an album folder with wavpack files, where everything worked normally.
And I found another one with FLAC files, that showed the described faulty behavior.
Should I find out about the cause of things I'll report it here.

Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 1st December 2015 - 14:09