Welcome Guest ( Log In | Register )

2 Pages V  < 1 2  
Reply to this topicStart new topic
Optimized vorbis encoder for Linux (SSE instructions), I have built the binary - any interest ?
post Nov 19 2009, 20:32
Post #26

Group: Members
Posts: 16
Joined: 13-November 04
Member No.: 18120

That's great smile.gif
Thank you very much.
Go to the top of the page
+Quote Post
post Jun 10 2010, 08:20
Post #27

Group: Members
Posts: 53
Joined: 13-October 06
Member No.: 36310

I was listening to some songs which go into another, and to my surprise gapless playback was not gapless. I found that about 0,03 s silence was added to the end of the song, whereas in the following song for about the same lenght the right channel was missing.
Could this be fixed?
Go to the top of the page
+Quote Post
post Oct 1 2011, 00:33
Post #28

Group: Members
Posts: 18
Joined: 9-October 08
Member No.: 59840

Hi I just tried your build and it works perfectly. Thx for your work The_Sven! (btw it's amazing to think that all this is possible thanks to you and BlackSword and Aoyumi and Xiph!)

But doing my tests some weird things happened and I have some questions.
I wanted to test Lancer SSE3MT optimizations so I went get the files on BlackSword's website. I didn't pay attention to the fact the oggenc file I got had .exe as extension and I just replaced /usr/bin/oggenc with this one and tried. And it worked! And I also remarked a sensible speed-up (about 20% better) compared to the simple SSE optimization.
Then I realized what I did and I don't understand why it worked. I checked the properties of the file /usr/bin/oggenc and the type was indeed DOS/Windows executable (application/x-ms-dos-executable).

So I'm wondering how was it possible to work? I thought maybe because of Wine but I didn't ask in the terminal to run this program via Wine, or maybe would it be possible my system (I'm using Ubuntu 11.04) recognized type of the program and run it via Wine?
Also is there some cons / known problems for using thus the .exe in my Linux system?
Anyway I think I'm gonna use the version compiled by The_Sven but I'm curious about this strange thing "using a Windows program under Linux working so good I could have never suspected there was something wrong".
Go to the top of the page
+Quote Post
post Sep 2 2012, 23:10
Post #29

Group: Members
Posts: 308
Joined: 21-February 05
Member No.: 20022

Are the latest aoTuV available to compile? Regards.
Go to the top of the page
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 1st December 2015 - 15:56