Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
Decoding Issues With Speex 1.2rc1, Foobar2000 is not decoding files coded by the binary for speex 1.2rc1
post Jun 1 2009, 02:17
Post #1

Group: Members
Posts: 1
Joined: 16-April 09
From: Edmonds, WA
Member No.: 69006

Ok guys, I've been a lurker wink.gif for awhile, so I'll give you as much info as I possibly can.

I downloaded the windows binary for speex 1.2rc1 from mingw for testing.

The source audio I used for testing is an mp3 at 192kbps 44.1khz 16bit stereo.

I created a .wav in dBPoweramp:
Channels 1 (mono)
Sample Rate 16 KHz{CR}
Sample Size 16 bit
Bit Rate 256 kbps
Type WAV

The settings string I used for speex was:
speexenc -w --quality 7 --comp 6 --vbr --vad --dtx --denoise -V "test.wav" "test.spx"

The CLI chugged away, spitting out a nicely sized speex file, and everything.

When I tried to test it for playback in Foobar2000 I get this error:
Decoding failure at 0:01.280 (Unsupported format or corrupted file): "test.spx"

The funny thing is: it works fine in the latest version of MPlayer when I use that to play it.

Unfortunately, MPUI is not ever going to be my media player of choice, Foobar2000 is just far superior (pardon my ranting. tongue.gif )
Anyway, if anybody has any ideas for how I should modify my encoding settings, or any way of updating foobar2000's speex decoder, that would be great.

Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 4th October 2015 - 05:15