Welcome Guest ( Log In | Register )

No lossy codec is perfectly gapless, Here is the killer sample
post Feb 1 2004, 20:42
Post #1


Group: Super Moderator
Posts: 3936
Joined: 29-September 01
Member No.: 73

I found a problem sample for gapless encoding. Whatever I do, there is an audible click between the tracks. I've analyzed its cause, and found that it comes from edge effects. The termination of the waveform far from zero causes ringing, that manifests itself as an audible click, even when the files are played gapless.

I saw the problem with MP3 and MusePack.

MP3 : Lame 3.90.3 --alt-preset standard ; Foobar2000 disc writer
MPC : Mppenc 1.14 --xlevel ; Mppdec

You can get the file here : http://www.hydrogenaudio.org/forums/index....35&t=18207&st=0

Look at the attached picture to see the problem in the waveform.
Attached thumbnail(s)
Attached Image
Go to the top of the page
+Quote Post
Start new topic
post Feb 1 2004, 22:58
Post #2

Musepack Project Coordinator

Group: Developer
Posts: 161
Joined: 24-June 02
Member No.: 2385

Since the problem exists with FAAC all the way until the higest setting, I wouldn't suggest to start passing phone numbers around just yet smile.gif The problem should be studied carefully and only then conclusions should be reached.

With Vorbis, there is a soft click up to around -q 3. At -q 3.20 it's gone. LAME sounds pretty bad with all presets, although the click is slightly weaker with --alt-preset--insane.

This post has been edited by Seed: Feb 1 2004, 23:21

And if Warhol's a genius, what am I? A speck of lint on the ***** of an alien
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 25th November 2015 - 14:08