Welcome Guest ( Log In | Register )

2 Pages V  < 1 2  
Reply to this topicStart new topic
FFmpeg 0.5 "Bike Shed", half-way to world domination A.K.A. the belligerent blue bike shed
post Mar 22 2009, 21:25
Post #26

xcLame and OggDropXPd Developer

Group: Developer
Posts: 3798
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111

QUOTE (ZinCh @ Mar 21 2009, 01:41) *
I think its better to use shared mode, so we can update dll's without recompiling it.

@ john - did you apply mp3 patch from my previous post? I dont see sources...

@ aradzish - why not to use only all inclusive version?

Forgive me if I'm being a bit dense, but I don't see a patch there other than the one to libavcodec.c that confirms the 'bug'? If someone has a fix for this, I'm more than happy to apply it.

I note and agree with the comments regarding the shared mode, I was just happy to put a full build together that seemed to work as expected! laugh.gif If I receive the lame patch, I'll try a full shared mode build.

My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
post Mar 23 2009, 20:56
Post #27

Group: Developer
Posts: 83
Joined: 15-November 02
Member No.: 3785

Could someone please share the latest ffmpeg precompiled for linux with static libs?
Go to the top of the page
+Quote Post
post Mar 24 2009, 02:12
Post #28

Group: Members
Posts: 57
Joined: 11-July 06
Member No.: 32807

- Seems work fine the new parameter -drc_scale <float>. Remember use -drc_scale 0.0 when you need ac3 audio to transcode.

- The multichannel audio (ac3, aac, ogg, mlp) still have problems with the wrong channelmapping.

This post has been edited by tebasuna51: Mar 24 2009, 02:18
Go to the top of the page
+Quote Post
post Mar 28 2009, 23:09
Post #29

Group: Developer
Posts: 200
Joined: 8-July 03
Member No.: 7653

It's worth pointing out that ffmpeg still maintains the property that if you request vorbis via -acodec vorbis you get the "ffmpeg internal" vorbis encoder while -acodec libvorbis is required to get the external encoder.

This is relevant because the internal encoder is very simplistic and clearly underperforms the reference implementation (and AoTUV, of course). I can say this on purely objective grounds— it frequently misses bitrate targets and produces streams with bad granpos values which wedge some decoders, but the encoder is also artifact prone enough that it has caused quality related complaints where users have unwittingly used it (and you can compare for yourself, I threw up some examples notice the significant birdie artifacts), so it even fails a simple unintentional blind test. smile.gif

It's impressive and laudable work that the FFMpeg has implemented their own independent encoder that works at all. As far as I'm aware it's the only publicly available encoder not derived from libvorbis. But at the same time the quality is very low so the decision to place that encoder where users will use it without a conscious decision to do so is very unfortunate. I hope that a future version either improves the internal encoder to match libvorbis, replaces it with libvorbis (which is BSD licensed for a reason…), or at least stops giving the internal codec to users without a stern warning.
Go to the top of the page
+Quote Post
post Apr 7 2009, 01:50
Post #30

Group: Members
Posts: 65
Joined: 16-June 07
Member No.: 44412

QUOTE (ZinCh @ Mar 10 2009, 09:35) *
It has been a very long time since we last made a release and many did not think we would make one again but, back by popular demand, we are proud to announce a new release: FFmpeg 0.5

COOL smile.gif

Check out the release notes and changelog

Both links are broken sad.gif

[*] Significant work to support at least decoding of all widespread mainstream proprietary codecs, such as:
[*] RealAudio Cooker and fixes for 14.4 and 28.8
[*] RealVideo RV30/40

Real support became real shock1.gif

[*] Theora (and encoding via libtheora)
[*] Ogg (FLAC, Theora and Vorbis only)

Any BUGzilla around ? It's buggy sad.gif

Anyone can encode this one: http://freefile.kristopherw.us/uploads/temp/ffx3yuv.zi7 into Theora: FFW2 -i g.yuv g.ogv BTW, using AVI as output format doesn't have this problem.

Tried both executables advertised here, same result: Page Fault :-( The EIP's do differ but the offending code is very same, some huge and boring MMX'ed code (sorry I didn't upload the full disassembly, as this probably would crash the HA server biggrin.gif , also the addresses are resolved poorly) :
Used FFMPEG binary (but all do crash) mirrored here: http://freefile.kristopherw.us/uploads/temp/ffw2.zi7

PS: the files are 7-ZIP's wink.gif

Crash report (apparently ineligible for inline posting here): http://freefile.kristopherw.us/uploads/temp/ffmpeg.txt


This post has been edited by DOS386: Apr 12 2009, 10:38

Go to the top of the page
+Quote Post
Justin Ruggles
post Apr 16 2009, 04:36
Post #31

Group: Developer
Posts: 165
Joined: 3-June 06
From: Raleigh, NC
Member No.: 31393

QUOTE (DOS386 @ Apr 6 2009, 20:50) *
Check out the release notes and changelog

Both links are broken sad.gif

mplayerhq/ffmpeg svnweb is temporarily offline for security reasons. Here are the mirrored copies of the 0.5 release notes and changelog.
Go to the top of the page
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 25th November 2015 - 14:31