Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
Voice Synthesis and MP3 Conversion, Use of Flite or Festival to create wavs
post Jul 5 2004, 20:49
Post #1

Group: Members
Posts: 1
Joined: 5-July 04
Member No.: 15083

I just came across flite a couple of days ago having read about it on the Linux iPod forums, so I downloaded/compiled it and was so pleased with myself when
echo "My name is Stephen Hawking" | flite

worked immediately, that I decided to pull a story from Project Gutenberg and have a bit of a go at encoding a story to stick on my iPod. I picked Nietzsche's 'Beyond Good and Evil' because I'm a pretentious bastard. Anyway. So I tried this;
flite -f bygdv10.txt -o beyond.wav && lame --alt-preset standard beyond.wav beyond.mp3 && rm beyond.wav

and it worked fine although the MP3 ended up being 373MB (the WAV was 750MB). Obviously I should've split it up into chapters but that can all be ironed out later. It would've been tidier to have flite output to stdout and pipe it to lame but I couldn't seem to get flite to output like that sad.gif

I'd like to hear from anyone that has played about with speech synthesis software, specifically I'd like to know your thoughts on flite and its parent festival perhaps with pointers on using different voices. What about my encoding? I guess that VBR encoding of a simple voice is overkill but I just picked the setting I use for everything (yes, I'm a newbie) - would 64kbps be sufficient for voice only stuff? Should I be doing things differently? Different programs? Bear in mind the end result should be played on my iPod so voice specific codecs are of no interest to me right now smile.gif

I generally run Linux (Gentoo) but I have WinXP installed too, so any solution employing either OS is appreciated, though Linux is preferable.

PS. Flite did spit out some warnings while producing a wav;
flite: udb failed to find entry for: y-th
flite: udb failed to find entry for: hh-r
flite: udb failed to find entry for: w-z
flite: udb failed to find entry for: hh-r
flite: udb failed to find entry for: hh-r

I couldn't work out what they meant.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 25th November 2015 - 03:17