IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
I canít associate files w/ fb2k, canít open files except via File menu, [TOS #5/split from ďI have to launch foobar2000 as adminĒ/topic 99666]
bullinchinashop
post Mar 6 2013, 22:18
Post #1





Group: Members
Posts: 11
Joined: 25-August 06
Member No.: 34439



I had a big problem with foobar on Windows 8 also.
No matter how many times I associated my music files with foobar it would not open them.
When I double clicked on the files nothing would happen. If I opened foobar and dragged and dropped the files into the app I would get the forbidden symbol on my cursor and Windows would not let me drop the file into foobar.
The only was I was able to use foobar was to open the app and use foobar's open file dialog.
vlc worked fine though...
Go to the top of the page
+Quote Post
marc2003
post Mar 6 2013, 23:46
Post #2





Group: Members
Posts: 4777
Joined: 27-January 05
From: England
Member No.: 19379



what version of foobar2000 are you running? this appears to have been an issue fixed in 1.1.15.

QUOTE (http://www.foobar2000.org/changelog)
Worked-around shell integration incompatibility with Windows 8.

Go to the top of the page
+Quote Post
bullinchinashop
post Mar 9 2013, 03:20
Post #3





Group: Members
Posts: 11
Joined: 25-August 06
Member No.: 34439



QUOTE (marc2003 @ Mar 6 2013, 17:46) *
what version of foobar2000 are you running? this appears to have been an issue fixed in 1.1.15.

QUOTE (http://www.foobar2000.org/changelog)
Worked-around shell integration incompatibility with Windows 8.



1.2.3
Go to the top of the page
+Quote Post
Apesbrain
post Mar 9 2013, 03:29
Post #4





Group: Members
Posts: 491
Joined: 3-January 04
Member No.: 10915



Easy there, big fellow. Re-run the installer and select "Standard Mode". Portable Mode does not support shell integration.
Go to the top of the page
+Quote Post
bullinchinashop
post Mar 9 2013, 11:31
Post #5





Group: Members
Posts: 11
Joined: 25-August 06
Member No.: 34439



QUOTE (Apesbrain @ Mar 8 2013, 21:29) *
Easy there, big fellow. Re-run the installer and select "Standard Mode". Portable Mode does not support shell integration.


???
I'm not using portable mode.
I used standard mode every time I installed it.

Go to the top of the page
+Quote Post
marc2003
post Mar 9 2013, 11:39
Post #6





Group: Members
Posts: 4777
Joined: 27-January 05
From: England
Member No.: 19379



QUOTE
If I opened foobar and dragged and dropped the files into the app I would get the forbidden symbol on my cursor and Windows would not let me drop the file into foobar.


shell integration shouldn't even affect this. drag/drop works fine from portable mode. have a look here.

http://www.hydrogenaudio.org/forums/index....st&p=821278
Go to the top of the page
+Quote Post
bullinchinashop
post Mar 9 2013, 11:41
Post #7





Group: Members
Posts: 11
Joined: 25-August 06
Member No.: 34439



You guys want to hear something really strange?
Just for the heck of it I reinstalled foobar in portable mode and guess what?
Now it DOES work.
Once I tell Windows that I want foobar to be used for music files they open with foobar with no problem.
Weird........
Go to the top of the page
+Quote Post
Kohlrabi
post Mar 10 2013, 12:18
Post #8





Group: Super Moderator
Posts: 1115
Joined: 12-March 05
From: Kiel, Germany
Member No.: 20561



QUOTE (bullinchinashop @ Mar 6 2013, 22:18) *
No matter how many times I associated my music files with foobar it would not open them.
When I double clicked on the files nothing would happen. If I opened foobar and dragged and dropped the files into the app I would get the forbidden symbol on my cursor and Windows would not let me drop the file into foobar.
The only was I was able to use foobar was to open the app and use foobar's open file dialog.
You're probably running foobar2000 as administrator, which prevents drag-and-drop or file open requests from non-elevated Explorer instances.

This post has been edited by Kohlrabi: Mar 10 2013, 12:18


--------------------
It's only audiophile if it's inconvenient.
Go to the top of the page
+Quote Post
bullinchinashop
post Mar 11 2013, 00:38
Post #9





Group: Members
Posts: 11
Joined: 25-August 06
Member No.: 34439



QUOTE (Kohlrabi @ Mar 10 2013, 05:18) *
QUOTE (bullinchinashop @ Mar 6 2013, 22:18) *
No matter how many times I associated my music files with foobar it would not open them.
When I double clicked on the files nothing would happen. If I opened foobar and dragged and dropped the files into the app I would get the forbidden symbol on my cursor and Windows would not let me drop the file into foobar.
The only was I was able to use foobar was to open the app and use foobar's open file dialog.
You're probably running foobar2000 as administrator, which prevents drag-and-drop or file open requests from non-elevated Explorer instances.



I tried running it in administrator mode and regular mode. It acted the same both ways.
Go to the top of the page
+Quote Post
Marpee
post May 16 2013, 09:27
Post #10





Group: Members
Posts: 1
Joined: 16-May 13
Member No.: 108159



Hi there,
I have the same problem. I attempted many modes but I can't solved the problem. Running Foobar2000 v.1.2.6 as administrator, installed in regular mode on Windows 8 64bit. In shell all file are selected. In system files icons are associated with Foobar2000 but clicking on file nothing appens. The file only opens clicking right button on mouse and choosing "open with".
Help to solve the problem please!!!

This post has been edited by Marpee: May 16 2013, 09:29
Go to the top of the page
+Quote Post
Case
post May 16 2013, 10:04
Post #11





Group: Developer (Donating)
Posts: 2270
Joined: 19-October 01
From: Finland
Member No.: 322



Do not mark the program to run with administrator rights. If you have files in a location only admin can access, fix the permissions of the folders/drive.
Go to the top of the page
+Quote Post
djchristian
post Jun 3 2013, 23:49
Post #12





Group: Members
Posts: 43
Joined: 22-December 09
Member No.: 76233



QUOTE (Marpee @ May 16 2013, 09:27) *
Hi there,
I have the same problem. I attempted many modes but I can't solved the problem. Running Foobar2000 v.1.2.6 as administrator, installed in regular mode on Windows 8 64bit. In shell all file are selected. In system files icons are associated with Foobar2000 but clicking on file nothing appens. The file only opens clicking right button on mouse and choosing "open with".
Help to solve the problem please!!!


Have exactly the same problem. Ran the installer as administrator, choosed standard installation and let foobar use all it's defaults but still i can't doubleclick to open or enqeue mp3's, nor flacs nothing.
Go to the top of the page
+Quote Post
db1989
post Jun 4 2013, 00:00
Post #13





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Is there a reason that you ran the installer as an administrator despite the directly previous warning against doing so? Should we assume that you resorted to that after experiencing the same lack of functionality from an installation created as a normal user?
Go to the top of the page
+Quote Post
djchristian
post Jun 4 2013, 00:04
Post #14





Group: Members
Posts: 43
Joined: 22-December 09
Member No.: 76233



QUOTE (db1989 @ Jun 4 2013, 00:00) *
Is there a reason that you ran the installer as an administrator despite the directly previous warning against doing so? Should we assume that you resorted to that after experiencing the same lack of functionality from an installation created as a normal user?


No i tried without running it as administrator and it won't work neither way. I uninstalled it completely between the installations. I am running Windows 8 64-bit.

I have ran it using administrator rights before and it worked. The filestypes have the foobar logo on them but i can't do anything with the left mouse button, it doesn't register at all. It's tiresome having to right click to get to the context menu and choose foobar as default program all the time.




edit: Ok i found the problem. Right click on the foobar2000 icon --> Properties --> Compatibility --> Unclick the "Run this program as an Administrator" box.

This post has been edited by djchristian: Jun 4 2013, 00:18
Go to the top of the page
+Quote Post
db1989
post Jun 4 2013, 00:35
Post #15





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Said checkbox is exactly what Case was advising against.

The lesson from this thread is clear: Do not run foobar2000 and/or its installer as an administrator. What reason is there to do so, anyway?
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th November 2014 - 22:52