IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
FLAC button in Total Commander
hlloyge
post Feb 13 2013, 11:18
Post #1





Group: Members
Posts: 698
Joined: 10-January 06
From: Zagreb
Member No.: 27018



Hello all.

If anyone could help me, that would be great, because I don't know what I am doing wrong.

I am trying to make FLAC button in Total Commander for converting selected wav files to FLACs. I've found an example for wavpack, and I started from that:

COMMAND "c:\Program Files (x86)\Encoders\wavpack.exe"
PARAMETERS -h -l @%L
START PATH c:\Program Files (x86)\Encoders\

but when I exchange command to flac.exe (it's in the same folder) and remove in parameters everything left of @ and place just -6 for compression mode, nothing happens. I can, however, drag'n'drop single file to that button, and it will work, but I want to make a selection of few files and pressing button, to convert them into same folder.

Can anyone help?
Go to the top of the page
+Quote Post
deus-ex
post Feb 13 2013, 12:05
Post #2





Group: Members
Posts: 284
Joined: 9-September 04
From: Earth
Member No.: 16882



Total Commander online help: Dialog box: Change Start Menu (TC main menu - Start - Change Start menu, press F1)

%S insert the names of all selected files into the command line. Names containing spaces will be surrounded by double quotes. Please note the maximum command line length of 32767 characters.
%S10 insert the names of the first 10 selected files (max.) into the command line. Allows to limit the number of file names passed to the program. You can use any other number.

FLAC does not support input lists defined via @listname. But it does accept multiple input files at once.

CODE
COMMAND "c:\Program Files (x86)\Encoders\flac.exe"
PARAMETERS -6 %S
START PATH (no entry required - leave blank)


--------------------
Best regards
deus-ex (MODLAND admin: ftp://modland.ziphoid.com)
Go to the top of the page
+Quote Post
hlloyge
post Feb 13 2013, 13:38
Post #3





Group: Members
Posts: 698
Joined: 10-January 06
From: Zagreb
Member No.: 27018



Thank you very much - I didn't realise it doesn't accept input files like wavpack does. Shame on me.
If added --delete-input-file in fornt of parameter, it does exactly what I want.
Thank you again, deus-ex.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st September 2014 - 13:49