IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Pauses During Playback of Wavpack Files
SoldierAnt76
post Jan 20 2013, 23:13
Post #1





Group: Members
Posts: 5
Joined: 20-January 13
Member No.: 106036



I'm running foobar2000 on Windows 7 Home 64-bit, with no additional components installed. My entire library consists of lossless Wavpack files.

Ever since I upgraded from 1.2 to 1.2.1, I've consistently noticed 3-4 second pauses at the beginning of tracks. Playback starts for an instant (i.e., the bars in the visualization box start to move), then the program freezes for several seconds.

The glitch only seems to surface when the program has been sitting undisturbed for a while. That is, a track has been playing for several minutes, or several tracks have played in sequence (I have both "playback follows cursor" and "cursor follows playback" enabled), or nothing has been playing, and I then go and double-click on another track.

However, when I try to reproduce the problem immediately afterwards (e.g., by rapidly switching from track to track), the program behaves normally. It has to sit undisturbed for a few minutes before the issue appears.

I tried using Process Explorer, but no thread appears to go above 1-2% CPU usage. Upgrading to 1.2.2 has had no effect.

I noticed that the "deadlock detection feature" was disabled in 1.1.18 - could this issue be related? Any thoughts?
Go to the top of the page
+Quote Post
shakey_snake
post Jan 21 2013, 01:58
Post #2





Group: FB2K Moderator
Posts: 4322
Joined: 1-November 06
From: Cincinnati
Member No.: 37036



Output method?

Have you tried increasing the output buffer length?

Is the disk your files are on very busy?


--------------------
elevatorladylevitateme
Go to the top of the page
+Quote Post
SoldierAnt76
post Jan 21 2013, 09:39
Post #3





Group: Members
Posts: 5
Joined: 20-January 13
Member No.: 106036



I'm using all the original defaults under Playback/Output (buffer set to 1000 ms). I'm not doing much else with the machine, beyond surfing the web.

I just tried increasing the buffer all the way up to 30000 ms - no effect.

This post has been edited by db1989: Jan 21 2013, 20:19
Reason for edit: Please do not quote unnecessarily or top-post.
Go to the top of the page
+Quote Post
Case
post Jan 21 2013, 10:22
Post #4





Group: Developer (Donating)
Posts: 2296
Joined: 19-October 01
From: Finland
Member No.: 322



Verify that full file buffering is not enabled. The option can be found under playback section in advanced preferences.
Go to the top of the page
+Quote Post
SoldierAnt76
post Jan 21 2013, 20:14
Post #5





Group: Members
Posts: 5
Joined: 20-January 13
Member No.: 106036



Full file buffering is set to 0 KB.

This post has been edited by db1989: Jan 21 2013, 20:19
Reason for edit: as in post #3
Go to the top of the page
+Quote Post
rain22
post Jan 22 2013, 09:30
Post #6





Group: Members
Posts: 3
Joined: 19-January 13
Member No.: 106016



With flac-files I also got those gaps between tracks, only a bit shorter (0.05 sec, which gives a nice "plop", if music continues from one track to the next), as reported here:

Gapless flac playback broken after v1.1.9 until current v1.2.2
http://www.hydrogenaudio.org/forums/index....showtopic=98970

Seems to be related to all file formats. (?)

Since I keep all foobar2000 versions as separate portable install, it is easy to switch between all versions according to their working features.
So I went back to v1.1.9 for listening purposes.
Go to the top of the page
+Quote Post
Dandruff
post Jan 29 2013, 19:42
Post #7





Group: Members
Posts: 497
Joined: 20-April 04
Member No.: 13618



Don't have any issues with WavPack gapless playback in foobar2000 1.2.2.
Go to the top of the page
+Quote Post
WilB
post Jan 29 2013, 21:51
Post #8





Group: Members
Posts: 319
Joined: 20-July 06
Member No.: 33113



QUOTE (SoldierAnt76 @ Jan 20 2013, 23:13) *
Ever since I upgraded from 1.2 to 1.2.1, I've consistently noticed 3-4 second pauses at the beginning of tracks. Playback starts for an instant (i.e., the bars in the visualization box start to move), then the program freezes for several seconds.

The glitch only seems to surface when the program has been sitting undisturbed for a while. That is, a track has been playing for several minutes, or several tracks have played in sequence (I have both "playback follows cursor" and "cursor follows playback" enabled), or nothing has been playing, and I then go and double-click on another track.

However, when I try to reproduce the problem immediately afterwards (e.g., by rapidly switching from track to track), the program behaves normally. It has to sit undisturbed for a few minutes before the issue appears.

This is an exact description of a problem I have with foobar20001.2.2 and various file formats including flac with foobar2000 failing to respond for up to 30 seconds. This is with a windows 8 64 bit machine. The problem can occur at the start of track playback or part-way through. Although the display locks up, music playback is not interrupted. The extent of the problem seems to be related to the number of third party components installed especially those displaying images. Removing components individually failed to identify a specific one as the cause. Rather it seems to be general load causing a deadlock. One of the components that contributes to the problem is WSH panel mod 1.5.6, which is not on the problematical components list. With simple default UI or columns UI set-ups there is no problem. I also did not notice any problems when the problematical configurations were previously used on a much slower XP SP3 machine.

Increasing the output buffer size, using full file buffering and changing the thread priority made no difference to the issue. I could not see anything useful in process explorer with cpu usage remaining low. The problem still occurs if foobar2000 is the only program running. The output method is directsound and the issue occurs with both USB audio out and optical out. The disk is not busy and the pc passed a range of hardware tests. Drivers are up to date.

Perhaps a mod could change the title of this thread to reflect a more general issue.

This post has been edited by WilB: Jan 29 2013, 22:00
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th December 2014 - 10:45