IPB

Welcome Guest ( Log In | Register )

7 Pages V  « < 4 5 6 7 >  
Reply to this topicStart new topic
m-TAGS component (foo_tags), Support for m-TAGS metadata separation
luigimercurio
post Sep 4 2013, 04:14
Post #126





Group: Developer
Posts: 53
Joined: 23-January 11
Member No.: 87562



QUOTE (foosion @ Sep 3 2013, 21:10) *
QUOTE (db1989 @ Sep 3 2013, 15:51) *
OK, so the method used to invoke the dynamic titling seems to effectively cause the stream itself to be reloaded in place of the m-TAGS reference.
Dynamic metadata is provided by the decoder of the stream. If the decoder wants to expose the static tags as part of the dynamic tags, it has to explicitly do that.
QUOTE (db1989 @ Sep 3 2013, 15:51) *
I wonder if there is a way for the respective first- and third-party developers to work around this, at least as an option.
It should be possible. I think the m-tags component wraps the decoder of the referenced file/stream inside its own decoder. Thus it could enrich the dynamic metadata returned by the stream decoder with static tags.


It does indeed. I will have to look at how dynamic stream tags are implemented in the SDK and see if there is a way to do this "integration"
Go to the top of the page
+Quote Post
foosion
post Sep 4 2013, 07:22
Post #127





Group: FB2K Moderator (Donating)
Posts: 4474
Joined: 24-February 03
Member No.: 5153



Check input_decoder::get_dynamic_info_track().


--------------------
http://foosion.foobar2000.org/ - my components for foobar2000
Go to the top of the page
+Quote Post
sokeking
post Sep 4 2013, 11:54
Post #128





Group: Members
Posts: 24
Joined: 18-November 07
Member No.: 48849



Awesome!!!! Thank you so much :-)

Please let me know, if there's anything I can do (but I rather doubt it, since I have no experience in Foobar Dev).
Go to the top of the page
+Quote Post
db1989
post Sep 4 2013, 12:43
Post #129





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



I love it when a plan comes together! biggrin.gif
Go to the top of the page
+Quote Post
kariol
post Sep 4 2013, 17:22
Post #130





Group: Members
Posts: 16
Joined: 22-November 11
Member No.: 95339



QUOTE (luigimercurio @ Sep 3 2013, 14:14) *
I apologize, but I do not understand your first comment.

I am afraid that I cannot improve my English skills in a short time. For me the essential aspect is, that m-TAGS searches for media files independent of the foobar settings (like excluded files). So that comment was something like a summary, not a question.

QUOTE (luigimercurio @ Sep 3 2013, 14:14) *
As for the second one, can you send me some trace? "Does not work" is not too specific. What happens? It does not load at all? Or are some tags broken? I have both XP and W7 computers at home and they all read/write from the same shared hard drive. I have never experienced a problem with the files. Are you editing them manually?

This screenshot shows the problem.
The questionmarks (duration at playlist) are wrong and the properties (lower part of the image, "other") are shown without general.

I have a new album folder with some media files on a W7 computer. I let fb2k/foo-tags create the m-TAGS files on W7. (In this case one tag file for each media file but a single !.tags file has similar effects too later on the XP computer). On that first W7 computer everthing looks fine. Next I copy or move the whole new directory/album-folder (using the W7- PC) to an accessable network directory on a XP computer. Next I copy or move ( using the target XP-PC) the new directory from that place to another place on the same XP PC, where all the media files are stored for fb2k. f2bk is monitoring and finds the new music, but I have the problems like you can see at the screenshot (same image as above). Some of the new entries are shown wrong, but all media are playable.

This post has been edited by kariol: Sep 4 2013, 17:34
Go to the top of the page
+Quote Post
luigimercurio
post Sep 4 2013, 18:39
Post #131





Group: Developer
Posts: 53
Joined: 23-January 11
Member No.: 87562



QUOTE (db1989 @ Sep 4 2013, 13:43) *
I love it when a plan comes together! biggrin.gif



OK, done. Load the new DLL: http://m-tags.org/foo_tags.dll

Now m-TAGS merges its tags with the dynamic info. Please note that m-TAGS takes precedence, i.e. the dynamic tag is shown if the m-TAGS file does NOT contain that tag.

Let me know if it works.
Go to the top of the page
+Quote Post
luigimercurio
post Sep 4 2013, 18:54
Post #132





Group: Developer
Posts: 53
Joined: 23-January 11
Member No.: 87562



QUOTE (kariol @ Sep 4 2013, 18:22) *
QUOTE (luigimercurio @ Sep 3 2013, 14:14) *
I apologize, but I do not understand your first comment.

I am afraid that I cannot improve my English skills in a short time. For me the essential aspect is, that m-TAGS searches for media files independent of the foobar settings (like excluded files). So that comment was something like a summary, not a question.


I got it. Yes, m-TAGS ignores the foobar settings, because when you use m-TAGS the foobar settings may very well restrict the allowed files to *.tags, so m-TAGS would not see anything but its own files!

QUOTE
QUOTE (luigimercurio @ Sep 3 2013, 14:14) *
As for the second one, can you send me some trace? "Does not work" is not too specific. What happens? It does not load at all? Or are some tags broken? I have both XP and W7 computers at home and they all read/write from the same shared hard drive. I have never experienced a problem with the files. Are you editing them manually?

This screenshot shows the problem.
The questionmarks (duration at playlist) are wrong and the properties (lower part of the image, "other") are shown without general.

I have a new album folder with some media files on a W7 computer. I let fb2k/foo-tags create the m-TAGS files on W7. (In this case one tag file for each media file but a single !.tags file has similar effects too later on the XP computer). On that first W7 computer everthing looks fine. Next I copy or move the whole new directory/album-folder (using the W7- PC) to an accessable network directory on a XP computer. Next I copy or move ( using the target XP-PC) the new directory from that place to another place on the same XP PC, where all the media files are stored for fb2k. f2bk is monitoring and finds the new music, but I have the problems like you can see at the screenshot (same image as above). Some of the new entries are shown wrong, but all media are playable.


I think I know what's happening. The hint is that you say that all files play anyway. The key is how the monitor works. When files are moved, the monitor catches the new files as they are added. This means that if the "!.tags" file is copied before some of the media files, then the library will load the "!.tags" file, but it cannot properly resolve all locators within it (becuase the media files are just not there yet). Hence, the "?"'s that you see. There are three solutions:

1) Make sure that the "!.tags" file is the last one copied (not very practical);
2) Touch (i.e. change the date or rewrite) the "!.tags" file after copying all files, so that the monitor re-loads it (still not too practical);
3) Explicitly reload the "!.tags" file, by running "Tagging / Reload info from file(s)" from the context menu, after all files are moved (most practical).

Go to the top of the page
+Quote Post
luigimercurio
post Sep 4 2013, 20:37
Post #133





Group: Developer
Posts: 53
Joined: 23-January 11
Member No.: 87562



QUOTE (kariol @ Sep 4 2013, 18:22) *
QUOTE (luigimercurio @ Sep 3 2013, 14:14) *
I apologize, but I do not understand your first comment.

I am afraid that I cannot improve my English skills in a short time. For me the essential aspect is, that m-TAGS searches for media files independent of the foobar settings (like excluded files). So that comment was something like a summary, not a question.



I forgot to mention that, as of last month's build, m-TAGS has its own exclusion list, configurable in the advanced preferences.
Go to the top of the page
+Quote Post
sokeking
post Sep 5 2013, 12:31
Post #134





Group: Members
Posts: 24
Joined: 18-November 07
Member No.: 48849



QUOTE (luigimercurio @ Sep 4 2013, 11:39) *
OK, done. Load the new DLL: http://m-tags.org/foo_tags.dll

Now m-TAGS merges its tags with the dynamic info. Please note that m-TAGS takes precedence, i.e. the dynamic tag is shown if the m-TAGS file does NOT contain that tag.

Let me know if it works.


Works perfect!!!!! Thank you so much!!!! This is just incredible - finally I got my webradio's listed the way I want. tongue.gif
Go to the top of the page
+Quote Post
luigimercurio
post Sep 5 2013, 14:11
Post #135





Group: Developer
Posts: 53
Joined: 23-January 11
Member No.: 87562



QUOTE (sokeking @ Sep 5 2013, 13:31) *
QUOTE (luigimercurio @ Sep 4 2013, 11:39) *
OK, done. Load the new DLL: http://m-tags.org/foo_tags.dll

Now m-TAGS merges its tags with the dynamic info. Please note that m-TAGS takes precedence, i.e. the dynamic tag is shown if the m-TAGS file does NOT contain that tag.

Let me know if it works.


Works perfect!!!!! Thank you so much!!!! This is just incredible - finally I got my webradio's listed the way I want. tongue.gif


You are welcome, and thanks for pointing out a behavior that I had totally overlooked.
Go to the top of the page
+Quote Post
kariol
post Sep 5 2013, 16:57
Post #136





Group: Members
Posts: 16
Joined: 22-November 11
Member No.: 95339



QUOTE (luigimercurio @ Sep 4 2013, 18:54) *
I think I know what's happening. The hint is that you say that all files play anyway. The key is how the monitor works. When files are moved, the monitor catches the new files as they are added. This means that if the "!.tags" file is copied before some of the media files, then the library will load the "!.tags" file, but it cannot properly resolve all locators within it (becuase the media files are just not there yet). Hence, the "?"'s that you see. There are three solutions:

1) Make sure that the "!.tags" file is the last one copied (not very practical);
2) Touch (i.e. change the date or rewrite) the "!.tags" file after copying all files, so that the monitor re-loads it (still not too practical);
3) Explicitly reload the "!.tags" file, by running "Tagging / Reload info from file(s)" from the context menu, after all files are moved (most practical).

Thank you very much, that seems to be the right analysis!

When I close fb2k before copying and run again after copying everything is fine.

Solution Nr. 3 is more comfortable. The context menu shows Tagging / create m-TGAS file, I guess you mean Properties / Tools / Reload info.

Go to the top of the page
+Quote Post
marc2003
post Sep 5 2013, 17:20
Post #137





Group: Members
Posts: 4764
Joined: 27-January 05
From: England
Member No.: 19379



if you hold shift when you right click, you will see reload info under the tagging context menu.

you can customise the context menu so it appears without having to hold down shift under file>preferences>display>context menu.

and you've already discovered the properties dialog>tools button does the same thing as well.
Go to the top of the page
+Quote Post
NoahTheDuke
post Sep 5 2013, 20:36
Post #138





Group: Members
Posts: 1
Joined: 5-September 13
Member No.: 109967



I think m-tags.org is down again. :-(
Go to the top of the page
+Quote Post
emte
post Sep 6 2013, 10:29
Post #139





Group: Members
Posts: 97
Joined: 11-February 10
Member No.: 78081



QUOTE
OK, done. Load the new DLL: http://m-tags.org/foo_tags.dll

Now m-TAGS merges its tags with the dynamic info. Please note that m-TAGS takes precedence, i.e. the dynamic tag is shown if the m-TAGS file does NOT contain that tag.

Let me know if it works.


I'd prefer just the opposite. I want dynamic title to be displayed if it's available and m-tag title if the former is missing.

This post has been edited by emte: Sep 6 2013, 10:29
Go to the top of the page
+Quote Post
luigimercurio
post Sep 8 2013, 13:29
Post #140





Group: Developer
Posts: 53
Joined: 23-January 11
Member No.: 87562



QUOTE (emte @ Sep 6 2013, 11:29) *
QUOTE
OK, done. Load the new DLL: http://m-tags.org/foo_tags.dll

Now m-TAGS merges its tags with the dynamic info. Please note that m-TAGS takes precedence, i.e. the dynamic tag is shown if the m-TAGS file does NOT contain that tag.

Let me know if it works.


I'd prefer just the opposite. I want dynamic title to be displayed if it's available and m-tag title if the former is missing.


I won't do that, because then a "hard-headed" input module could "force its own will", practically making m-TAGS useless. You can, however, use $if2(%<dynamic tag>%,%<m-TAGS tag>%) to achieve that, as long as the tags have different names (say "Title" and "M_Title").
Go to the top of the page
+Quote Post
rykiff
post Sep 11 2013, 22:58
Post #141





Group: Members
Posts: 8
Joined: 11-September 13
Member No.: 110039



Awesome plugin, I was really excited to find something like this.

Does m-TAGS work with masstagger, as long as I don't use XP and run into the utf-8 header issue? I'd like to use it to keep the formatting tagging capabilities of masstagger, but without editing any of my my music files directly.

Thanks!
Go to the top of the page
+Quote Post
kode54
post Sep 11 2013, 23:27
Post #142





Group: Admin
Posts: 4664
Joined: 15-December 02
Member No.: 4082



It certainly should work with masstagger, or any other tag editing utility which uses the player's input specific internal tag reading and writing interfaces.
Go to the top of the page
+Quote Post
rykiff
post Sep 12 2013, 09:47
Post #143





Group: Members
Posts: 8
Joined: 11-September 13
Member No.: 110039



Ah thank you for the confirmation, so far it's working perfectly! Although I did run into the problem referenced (and fixed) here:

QUOTE (luigimercurio @ Aug 14 2013, 00:51) *
!!!!! NEW RELEASE !!!!!

Fixed (hopefully) a bug that prevented resolution of paths on network shared drives.

Also, added the much demanded option to exclude certain kinds of files. The excluded extensions may be separated by commas, colons, semicolons, spaces, or '|'.

Let me know if it works! Thanks to all for the patience.

But sadly I can't find the option to use this functionality to exclude cue files in the creation of the tags files in the preferences dialog, or documentation telling how to do so. Thanks!

EDIT: Found it [File / Preferences / Advanced / Tagging / m-TAGS / m-TAGS creator / Excluded extensions :] thanks for the awesomely powerful plugin, luigi!


This post has been edited by rykiff: Sep 12 2013, 10:12
Go to the top of the page
+Quote Post
luigimercurio
post Sep 13 2013, 23:56
Post #144





Group: Developer
Posts: 53
Joined: 23-January 11
Member No.: 87562



QUOTE (rykiff @ Sep 12 2013, 10:47) *
Ah thank you for the confirmation, so far it's working perfectly! Although I did run into the problem referenced (and fixed) here:

QUOTE (luigimercurio @ Aug 14 2013, 00:51) *
!!!!! NEW RELEASE !!!!!

Fixed (hopefully) a bug that prevented resolution of paths on network shared drives.

Also, added the much demanded option to exclude certain kinds of files. The excluded extensions may be separated by commas, colons, semicolons, spaces, or '|'.

Let me know if it works! Thanks to all for the patience.

But sadly I can't find the option to use this functionality to exclude cue files in the creation of the tags files in the preferences dialog, or documentation telling how to do so. Thanks!

EDIT: Found it [File / Preferences / Advanced / Tagging / m-TAGS / m-TAGS creator / Excluded extensions :] thanks for the awesomely powerful plugin, luigi!


You're welcome, and the UTF-8 issue should not be an issue at all on XP. I use XP myself.


Go to the top of the page
+Quote Post
rykiff
post Oct 14 2013, 17:58
Post #145





Group: Members
Posts: 8
Joined: 11-September 13
Member No.: 110039



All has been well in the world of music using m-tag. However there is one thing that I can't seem to figure out... when m-tag generates .tag files for music, it doesn't append the file name as a placeholder for the title in the metadata if it the title is blank (which is fine with me). However, foobar's default behavior for displaying title information when it can't be found in the metadata is to display the file name... which it references as the !.tag file, leaving me with hundreds of ! titles for music that has no metadata. Is there a way to alter this behavior so that m-tag sets a title placeholder for metadata-less music based on the file name?

I noticed that the file names are referenced in the "other properties" category as <@>, but I have no idea how I would append a script in the title column for displaying said information when the title is missing. Something like $if(%title%,%title%,%@%)?

EDIT: Figured it out, just change the title script to $if($meta(title) missing,%title%,$info(@))

This post has been edited by rykiff: Oct 14 2013, 18:28
Go to the top of the page
+Quote Post
rykiff
post Oct 14 2013, 19:24
Post #146





Group: Members
Posts: 8
Joined: 11-September 13
Member No.: 110039



Whoops, double post...

Figured it out, this will let you play files without metadata and display all titles correctly (m-tag files with no metadata will have a ! appended to the end).

$if($meta(title) missing,%title%,$if($info(@) missing,$info(@) - !, %filename%))

This post has been edited by rykiff: Oct 14 2013, 19:26
Go to the top of the page
+Quote Post
luigimercurio
post Oct 17 2013, 00:25
Post #147





Group: Developer
Posts: 53
Joined: 23-January 11
Member No.: 87562



I think you should be able to just use $if2($meta(title),$info(@) - !)

Keep in mind that $info(@REFERENCED_FILE) contains the full path to the media file, in case you prefer that. If you do not like the "file://" prefix, use $substr().
Go to the top of the page
+Quote Post
rykiff
post Nov 18 2013, 19:54
Post #148





Group: Members
Posts: 8
Joined: 11-September 13
Member No.: 110039



Nice thank you. So far my foobar experience has been headache free with m-tags, however I would like to accomplish what I think sokeking has done by adding radio stations to my library using m-tags to format the titles. However, when I right click a loaded radio station and generate a m-tags file for it, I get this error:
CODE
Decoding failure at 0:00.000 (Unsupported format or corrupted file):
"F:\RY\Downloads\#Music\#Radio\!.tags" / index: 1

Honestly I'm at a loss of what to do, when I check the .tags file everything looks in order:
CODE
[
   {
      "@" : "http://eu1.fastcast4u.com:9300/|0",
      "GENRE" : "JAZZ, FUSION, WORLD",
      "TITLE" : "Dcsoundstream- Music with a mix of Jazz, Fusion, & World",
      "URL" : "http://www.DCSOUNDSTREAM.COM"
   }
]

If anyone could offer some insight on this, I would be extremely thankful. Being able to have all of my webradios listed in my library with custom tags would be wonderful.
Go to the top of the page
+Quote Post
rykiff
post Nov 19 2013, 13:02
Post #149





Group: Members
Posts: 8
Joined: 11-September 13
Member No.: 110039



Ahh interesting, if I swap my radio URL with the one sokeking's post it works perfectly. No idea why, would the streaming protocol being different break the functionality? I can load both radio stations perfectly from a playlist, but m-tags only opens one.

This post has been edited by rykiff: Nov 19 2013, 13:07
Go to the top of the page
+Quote Post
rykiff
post Nov 20 2013, 13:29
Post #150





Group: Members
Posts: 8
Joined: 11-September 13
Member No.: 110039



Weird, I was able to fix this by checking "Only use absolute paths in references" in Tagging > m-TAGs > m-TAGs creator. All is well now, once again, thank you for the awesomely powerful plugin! Being able to tweak my songs to an OCD level of tagging without touching the source file is a dream come true. cool.gif
Go to the top of the page
+Quote Post

7 Pages V  « < 4 5 6 7 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th November 2014 - 15:26