IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Themes for CUI/WSH show “SCRIPT ERROR” instead of buttons+progress bar, [split from “Columns UI appearance”/TOS #5]
Neo-neostroboman...
post Sep 11 2012, 15:10
Post #1





Group: Members
Posts: 2
Joined: 11-September 12
Member No.: 103071



I seem to be having script issues with every Column UI theme that I attempt to install, despite not missing any components and following provided instructions (e.g. those provided with http://moosss4.deviantart.com/#/d5a121z).
The progress bar, the shuffle and replay buttons are all replaced by portions of a severe "SCRIPT ERROR" black-on-white image, depending on the element's size. I am new to foobar and am absolutely unfamiliar with its plugin ecosystem and scripting; am I missing some basic customization fact?
Go to the top of the page
+Quote Post
MordredKLB
post Sep 11 2012, 16:23
Post #2





Group: Members
Posts: 198
Joined: 1-May 09
From: Austin, TX
Member No.: 69413



QUOTE (Neo-neostrobomantula @ Sep 11 2012, 09:10) *
I seem to be having script issues with every Column UI theme that I attempt to install, despite not missing any components and following provided instructions (e.g. those provided with http://moosss4.deviantart.com/#/d5a121z).
The progress bar, the shuffle and replay buttons are all replaced by portions of a severe "SCRIPT ERROR" black-on-white image, depending on the element's size. I am new to foobar and am absolutely unfamiliar with its plugin ecosystem and scripting; am I missing some basic customization fact?

Those are almost assuredly WSH Panel Mod panels. First I'd update to the latest version of WSHPanelMod. If that doesn't work you're going to have to look at the console and see what the errors are and try and fix them yourself.
Go to the top of the page
+Quote Post
Falstaff
post Sep 11 2012, 17:15
Post #3





Group: Members
Posts: 2799
Joined: 12-November 06
Member No.: 37463



let me add:
- first, update to the last version of WSH Panel Mod (except if the config provides the components to use)
- then check File>Preferences>Tools>WSH Panel Mod page, be sure to untick the 'Safe Mode' option
- and only after that, check the Console to see what is the line # in error and if you're not able to fix it by yourself, post this erreor message with line # to the config creator, it will surely help you because we don't like to leave bugs in our WSH jscript smile.gif

HTH

EDIT: to view console, use Menu VIEW>Console wink.gif

This post has been edited by Falstaff: Sep 11 2012, 17:15


--------------------
http://br3tt.online.fr/
Go to the top of the page
+Quote Post
Neo-neostroboman...
post Sep 12 2012, 05:15
Post #4





Group: Members
Posts: 2
Joined: 11-September 12
Member No.: 103071



Thanks to you both for the help despite having posted to the wrong thread.
Updating the WSH mod to the latest version caused the placeholders to change from "script error" to "aw crashed! :(", I guess that is a form of improvement. ;)

It also caused six WSH error windows of this format and varying first string to pop-up on startup:
CODE
"Scripting Engine Initialization Failed ({9D361AF4-DE5B-430C-A260-C24930CBE8A6}, CODE: 0x800401f3): Invalid class string".

(I suppose that would be one for every panel that failed to load.) Unfortunately a quick search for this kind of error didn't yield much. I checked the console but once again (as it did before upgrading the WSH mod) there is nothing but the standard report on load times.
The skins that I tried were mostly updated versions of legacy ones, so I suppose that weird issues are not to be unexpected; however, most comments e.g. on DeviantArt are not reporting any issue, which makes me guess that I am indeed missing something.

Anyway, I'll close the off-topic here and avoid bringing on the issue in the WSH thread (time is a-tickin'!). I reckon that I will be using the vanilla-ugly (but functional) UI until, hopefully, Windows 8 stirs the skin authors a bit.
Thanks again for the help. :)

This post has been edited by Neo-neostrobomantula: Sep 12 2012, 05:17
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd July 2014 - 18:10