IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

5 Pages V  « < 2 3 4 5 >  
Reply to this topicStart new topic
WASAPI output component version 3.0 final, 2013-03-09: v3.2.3
maxim_fr
post May 22 2013, 20:11
Post #76





Group: Members
Posts: 5
Joined: 23-February 13
Member No.: 106831



QUOTE (MrMonkey @ May 22 2013, 16:49) *
...That way, anything that isn't handled by your device can be resampled to a rate that is. ...

Thanks a lot!
Go to the top of the page
+Quote Post
Meeko
post Jun 22 2013, 13:12
Post #77





Group: Members
Posts: 82
Joined: 24-December 09
From: New York
Member No.: 76308



Hey, I don't post here much, but I thought I'd bring this up because I'm frankly baffled as to why this happens with foobar's WASAPI component.

Computer Specs: Windows 8 Pro, Realtek Onboard Audio, M-Audio Fastrack USB; computer sound settings are set to 16-bit, 44khz playback

The issue: When playing some files on my computer, every now and then the sample rate changes depending on the source file. When using WASAPI, foobar will quit and say "Unrecoverable playback error: Unsupported stream format: 22050 Hz / 16-bit / 2 channels". This is just one possibility...it hates any 24-bit 96khz files from HDTracks as well. It doesn't matter if WASAPI is in push/event mode, and it does not matter which device I use, onboard or USB sound.

Now, you must be thinking, well, its because your computer is set to 16-bit 44khz. If that's so, why does the WASAPI components in other media players (namely AIMP and xmplay) not choke on these files? They play them as if there's nothing fishy or automatically adjust for the different in bit depth and sample rate. Only foobar stops on me. Any ways to prevent foobar from stopping when it hits one of these files?


--------------------
foobar2000, FLAC, and qAAC -V68
It just works people!
Go to the top of the page
+Quote Post
maxim_fr
post Jun 22 2013, 13:23
Post #78





Group: Members
Posts: 5
Joined: 23-February 13
Member No.: 106831



QUOTE (Meeko @ Jun 22 2013, 14:12) *
Any ways to prevent foobar from stopping when it hits one of these files?

The exhaustive solution is just two posts above yours.

Please take an advice as a rule: to read few last pages plus the first post of any forum thread before asking a question.
80+% of questions will be answered even before you ask smile.gif
Go to the top of the page
+Quote Post
Meeko
post Jun 23 2013, 02:20
Post #79





Group: Members
Posts: 82
Joined: 24-December 09
From: New York
Member No.: 76308



Just missed that post I guess! Oops! Well, anyway, the SOX resampler works great and I'm not having any major issues now with odd sampling rates and WASAPI. smile.gif


--------------------
foobar2000, FLAC, and qAAC -V68
It just works people!
Go to the top of the page
+Quote Post
DragonQ
post Jul 27 2013, 15:35
Post #80





Group: Members
Posts: 49
Joined: 27-March 07
Member No.: 41926



QUOTE (rix81 @ Oct 14 2012, 08:01) *
thanks for great work!

can I ask for feature request pls? There's problem when output sound via HDMI.

It's related to playback, when track changes or i do seek, the foobar interrupts sound and enables it again in a small moment (what is normal of course).
But it causes to reanitilize the reciever each time and the sound disappears for a second (what is right behavior of receiver when sound stream changes).
But that is the issue.

Is there a chance to do something like 'keep connection alive' or output digital silence, when foobar stops sound, within wasapi plugin? It would solve the problem.


*Also what I notice -
when I test Wasapi on Amd videocard it works 100% Perfect, for some reason it doesn't interrupt sound.
but wasapi with Nvidia and intelHd interrupt sound as i describe above and the problem is present

thank you,
Alex

Please, please, please fix this bug! I can't use WASAPI in Foobar because every time I do a manual track change, the first second or so of the song gets cut off. This is due to the nVidia "silent stream bug" and is only fixed by changing the behaviour to output silence instead of interrupting the stream. Every time the stream is interrupted and restarted, the receiver has to "lock on" to the signal again and thus you miss the first second or so of audio.

This can be fixed using third party software in DirectSound mode but not WASAPI. From what I've read, it's fixed in Media Monkey and JRiver already!
Go to the top of the page
+Quote Post
rnddude
post Jul 27 2013, 23:36
Post #81





Group: Members
Posts: 2
Joined: 27-July 13
Member No.: 109330



I was going to start a new thread, but this one might be better for my problem...
I have a Musica Pristina music server that uses Windows8 and foobar2000 as the file control interface. I have been accessing the server to rip and play music with a windows wireless laptop using remote desktop and the servers IP address. That all works fine, but I bought an IPad Mini and installed Jump so that I could have a more mobile controller. I am also having Jump access the server via the IP address (not Google), and that works fine also, but for one small issue, actually it is a big issue. Keep in mind that the Ipad will be dedicated to being a controller, nothing else.

Foobar users will know that in the file-preferences-playback-output menu, you have to pick an output device. Once my NAD amp is powered up, foobar normally sees it and offers it as a selection, in my case it is "WASAPI (event)-speakers (2-NAD USB Audio)" That happens when I am using the laptop and Remote Desktop to see the server, but it does NOT offer that output option when using the IPAD with Jump to access the server. If I immediately take control from the IPad and enter the server with the Laptop, everything is normal and the output option for my NAD is visible, grab control back with the IPad/jump, and the option disappears. Needless to say, without that output option, I cannot make the server/foobar play music with the IPad, only with the laptop. I can, however, do everything else, including ripping CD's.

I was hoping someone else may have had this issue and figured out a resolution.
Go to the top of the page
+Quote Post
bitp
post Aug 23 2013, 22:16
Post #82





Group: Members
Posts: 2
Joined: 23-August 13
Member No.: 109770



Windows 8 x64, Realtek High Definition Audio on board, Schiit Audio Bifrost USB (GEN 2) using USB to connect to computer. foobar2000 v1.29 + WASAPI v3.2.3
DS and WASAPI (push) are working, but after configuring WASAPI (event) to the Bifrost and attempting to play the same FLAC and I'm prompted with an error. "Unrecoverable playback error: Invalid argument"

Playback devices -> Bitfrost Properties -> Advanced Tab
Default Format set to 24 bit, 192000 Hz (Studio Quality)
Exclusive Mode options checked: Allow applications to take exclusive control of this device, Give exclusive mode applications priority

I have tried configuring the Bitfrost Properties to use various formats and bitrates in the 16 bit and 24 bit space. Am I overlooking something and making a newbie mistake or is this a bug? Help! I would love to explore bit-perfect playback.
Go to the top of the page
+Quote Post
RavenGT
post Sep 6 2013, 03:35
Post #83





Group: Members
Posts: 18
Joined: 4-December 07
Member No.: 49242



I'm using WASAPI 3.2.3, FB2K 1.2.9 and SoX Resampler Mod.

Under Advanced > Playback > WASAPI, there is no checkbox for "Attempt to play unsupported stream formats". Where can I find this? I'm trying to make it play 88.2khz but 96khz is all it can play right now.
Go to the top of the page
+Quote Post
bitp
post Sep 12 2013, 03:33
Post #84





Group: Members
Posts: 2
Joined: 23-August 13
Member No.: 109770



QUOTE (bitp @ Aug 23 2013, 16:16) *
Windows 8 x64, Realtek High Definition Audio on board, Schiit Audio Bifrost USB (GEN 2) using USB to connect to computer. foobar2000 v1.29 + WASAPI v3.2.3
DS and WASAPI (push) are working, but after configuring WASAPI (event) to the Bifrost and attempting to play the same FLAC and I'm prompted with an error. "Unrecoverable playback error: Invalid argument"

Playback devices -> Bitfrost Properties -> Advanced Tab
Default Format set to 24 bit, 192000 Hz (Studio Quality)
Exclusive Mode options checked: Allow applications to take exclusive control of this device, Give exclusive mode applications priority

I have tried configuring the Bitfrost Properties to use various formats and bitrates in the 16 bit and 24 bit space. Am I overlooking something and making a newbie mistake or is this a bug? Help! I would love to explore bit-perfect playback.

UPDATE: This was a driver issue. It turns out Schiit released an updated driver the same week I posted. After installing the updated "Schiit_USB_1_03" drivers, WASAPI (event) playback is functional.

This post has been edited by bitp: Sep 12 2013, 03:34
Go to the top of the page
+Quote Post
Mardel
post Sep 12 2013, 19:36
Post #85





Group: Members
Posts: 27
Joined: 12-March 08
Member No.: 51986



I downloaded this version (3.2.3, released on 2013-03-09) but it's not listed on output list (after foobar restart). [link]

This post has been edited by Mardel: Sep 12 2013, 19:36


--------------------
Wavpack -hh or TAK -pMax
OggVorbis aoTuVb6.03 -q 4
Go to the top of the page
+Quote Post
db1989
post Sep 12 2013, 22:34
Post #86





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Did you install the component using the proper method? The importance of this has been discussed in the past with specific reference to this plugin.
Go to the top of the page
+Quote Post
Mardel
post Sep 12 2013, 23:35
Post #87





Group: Members
Posts: 27
Joined: 12-March 08
Member No.: 51986



QUOTE (db1989 @ Sep 12 2013, 23:34) *
Did you install the component using the proper method? The importance of this has been discussed in the past with specific reference to this plugin.

What's the proper method? I clicked onto download link and foobar opened the component I applied the settings and foobar restarted himself that's all.


--------------------
Wavpack -hh or TAK -pMax
OggVorbis aoTuVb6.03 -q 4
Go to the top of the page
+Quote Post
db1989
post Sep 12 2013, 23:59
Post #88





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Yeah, that should be the right way. I was just checking because there were problems before with people who had used other (non-)methods of installation. Someone else will have to advise about this problem as I have no other ideas; sorry.
Go to the top of the page
+Quote Post
Mardel
post Sep 13 2013, 18:40
Post #89





Group: Members
Posts: 27
Joined: 12-March 08
Member No.: 51986



QUOTE (db1989 @ Sep 13 2013, 00:59) *
Yeah, that should be the right way. I was just checking because there were problems before with people who had used other (non-)methods of installation. Someone else will have to advise about this problem as I have no other ideas; sorry.

I had to reinstall foobar, now it works. huh.gif


--------------------
Wavpack -hh or TAK -pMax
OggVorbis aoTuVb6.03 -q 4
Go to the top of the page
+Quote Post
danny.d
post Oct 29 2013, 09:41
Post #90





Group: Members
Posts: 81
Joined: 16-November 06
From: Nor Cal
Member No.: 37664



Works great with a M2Tech Hiface USB to SPDIF interface and a Bryston BDA-1 DAC, all rates and formats, including HD Tracks.

Thank you!!

This post has been edited by danny.d: Oct 29 2013, 09:46
Go to the top of the page
+Quote Post
HTA
post Oct 31 2013, 16:02
Post #91





Group: Members
Posts: 14
Joined: 5-November 12
From: Saudi Arabia
Member No.: 104339



i tried WASAPI for the first time today, connecting my PC straight into my AVR via HDMI. stereo sound never was so good before. now i finally got to enjoy my AVR dac.
Go to the top of the page
+Quote Post
db1989
post Nov 7 2013, 20:21
Post #92





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Did you verify that subjective impression with an objective double-blind test, or should I just bin it as most likely a symptom of expectation bias and as per TOS #8?
Go to the top of the page
+Quote Post
wraaaa
post Jan 13 2014, 20:19
Post #93





Group: Members
Posts: 16
Joined: 11-February 07
Member No.: 40523



I'd like to request the addition of fade-in/fade-out capability to the WASAPI output component. I prefer to use WASAPI over DirectSound for reasons related to my hardware setup. However, the abrupt stopping of sound on pausing a track or switching tracks is a pain sometimes and makes it less usable to me.

I did search for this topic and it seems that there isn't much support for adding this feature. I understand that the data output is no longer bit-perfect during the fading, but that really isn't a big deal (as I said, I don't prefer WASAPI because of some idea that bit-perfect output sounds any different than DirectSound). Adding this feature would just make the program feel much more polished for those that use WASAPI. Additionally, this is a feature that's offered by JRiver and MediaMonkey, so I hope this is something that can be easily added.
Go to the top of the page
+Quote Post
Propheticus
post Jan 13 2014, 22:59
Post #94





Group: Members
Posts: 219
Joined: 10-September 11
Member No.: 93615



Something like foo_dsp_crossfader might work. Haven't used it myself since version ~1.1.11 of foobar started supporting crossfading (DS only though), so I don't knwo if it still works.
Go to the top of the page
+Quote Post
wraaaa
post Jan 14 2014, 15:58
Post #95





Group: Members
Posts: 16
Joined: 11-February 07
Member No.: 40523



QUOTE (Propheticus @ Jan 13 2014, 15:59) *
Something like foo_dsp_crossfader might work. Haven't used it myself since version ~1.1.11 of foobar started supporting crossfading (DS only though), so I don't knwo if it still works.


Thanks. Unfortunately that DSP doesn't allow for fading on pause/stop.
Go to the top of the page
+Quote Post
misha0209
post Jan 24 2014, 06:33
Post #96





Group: Members
Posts: 36
Joined: 20-June 11
Member No.: 91689



hi,
@db1989
any chance you could implement DSD over PCM in WASAPI in the near (or distant) future?
really like WASAPI component, and i jsut got a DAC that can do DSD, but through DoP.
i know there is a component, but there is an audible difference between WAWSAPI and and that one when i stream PCM data. that one sounds more congested, i think the PCM is not just passed through to the ASIO driver. and it is a real hassle to switch outputs each time i want to listen to PCM/DSD
thanks for reading!
Go to the top of the page
+Quote Post
eahm
post Feb 18 2014, 06:22
Post #97





Group: Members
Posts: 1084
Joined: 11-February 12
Member No.: 97076



Why AIMP3's WASAPI is not exclusive and foobar2000's doesn't even have the option? Sometimes the non-exclusive can be more suitable.

Never used or cared much about it, I was just testing AIMP3 and saw WASAPI was configured and other sounds were playing as well. It would be a useful option IMO but if Peter didn't integrate it probably there is a good reason. Is there?



This post has been edited by eahm: Feb 18 2014, 06:57


--------------------
/lwAsIimz
Go to the top of the page
+Quote Post
misha0209
post Feb 19 2014, 15:07
Post #98





Group: Members
Posts: 36
Joined: 20-June 11
Member No.: 91689



hello again,

i asked the moderator who started the thread.. but the thread seems dead sad.gif

do once again, @Peter this time.

is there any chance this plugin, or foobar for that matter might support DSD over PCM (DoP) standard?
i know there is a component, but i think that it has a much greater audio path than what you could do in WASAPI.
would help the few of us that want to stick with foobar with the really high end systems that can do DoP.

thanks much, still hoping for an answer.
Go to the top of the page
+Quote Post
Porcus
post Feb 19 2014, 20:17
Post #99





Group: Members
Posts: 1842
Joined: 30-November 06
Member No.: 38207



QUOTE (misha0209 @ Feb 19 2014, 15:07) *
hello again,

i asked the moderator who started the thread.. but the thread seems dead sad.gif


Well ... you might get a moderator's attention for writing this:

QUOTE (misha0209 @ Jan 24 2014, 06:33) *
i know there is a component, but there is an audible difference between WAWSAPI and and that one when i stream PCM data. that one sounds more congested, i think the PCM is not just passed through to the ASIO driver. and it is a real hassle to switch outputs each time i want to listen to PCM/DSD


... without having actually tested.


--------------------
One day in the Year of the Fox came a time remembered well
Go to the top of the page
+Quote Post
WarZard-X
post Mar 3 2014, 11:20
Post #100





Group: Members
Posts: 20
Joined: 11-February 11
From: Switzerland
Member No.: 88089



Maybe a bug?
I'm using a 24-bit codec (VT2021). With Wasapi 2.1 I get a warning when I use a wrong output format.
8-bit: Unrecoverable playback error: Unsupported stream format: 44100 Hz / 8-bit / 2 channels
32-bit: Unrecoverable playback error: Unsupported stream format: 44100 Hz / 32-bit / 2 channels

Since Wasapi 3.0 - 3.2.3 there's still a warning for 8-bit output, but not for 32-bit.
When I play a lossless file in 32-bit output format you can hear sound on the left speaker, the right speaker is muted.
When I play a lossy mp3 file in 32-bit output format you can hear sound on the left speaker, the right speaker plays static noise.
Is this a driver thing or a Wasapi bug? It should display a warning since my card doesn't support 32-bit.
Go to the top of the page
+Quote Post

5 Pages V  « < 2 3 4 5 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th September 2014 - 06:40