IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

5 Pages V  « < 3 4 5  
Reply to this topicStart new topic
WASAPI output component version 3.0 final, 2013-03-09: v3.2.3
Case
post Mar 3 2014, 13:33
Post #101





Group: Developer (Donating)
Posts: 2206
Joined: 19-October 01
From: Finland
Member No.: 322



Sounds like a driver bug. Old 2.1 version of the component tried to use floating point output in 32-bit mode. This was changed for v3.0 and it now reverts to PCM mode if float mode fails. Your drivers report it as supported, yet fail horribly with it.
Go to the top of the page
+Quote Post
BigRedMachineSla...
post Mar 26 2014, 02:49
Post #102





Group: Members
Posts: 22
Joined: 9-July 02
From: QLD
Member No.: 2530



For the benefit of any one having glitching/pausing problems with WASAPI Event Mode, I've managed to fix my issues by adjusting advanced settings within Foobar. I'm playing back FLAC's and MP3's from my external 320GB hard drive, using Foobar2000 v 1.3.1 and WASAPI 3.2.3 on Windows 7 (64 bit). My specific issue was the playback of MP3's regularly pausing and/or stuttering when using Event Mode. The issue did not occur with FLAC's, or when using Push Mode. I'm on a work laptop that is locked down so hard I can't change anything in the OS, even down to my task bar auto hide or turning the date/time display on or off. I've found Event Mode drastically clearer and more open sounding compared to Push Mode, so I've tried just about everything possible to get it working glitch free.

The main setting that fixed the glitching was Advanced>Playback>Thread priority>Thread priority (1-7) and setting it to 1, rather than the default 7. This is the opposite of what I've read on various forums.

I also had to bump up the "Hardware buffer in MS - event mode" to 75. I tried up to 100, but then foobar would have a melt down and do this weird, glitchy, fast forward playback.

Other settings that I'm using are:
Using MMCSS set to Pro Audio
Buffer length set to 350ms (minimum determined by the ctrl-alt-delete method)(http://www.head-fi.org/t/539638/how-to-set-perfect-buffer-lengths)

Everything else is default and no active DSP's.

I still get the occasional glitch, so there is obviously a DPC latency issue on the computer, which I can't fix due to the PC being locked down.
Go to the top of the page
+Quote Post
Case
post Mar 26 2014, 07:38
Post #103





Group: Developer (Donating)
Posts: 2206
Joined: 19-October 01
From: Finland
Member No.: 322



You say you have tried just about anything but have you tried keeping the output buffer longer and playback priority high? Put the playback thread priority back to 7 and pump the output buffer to something like 5000 ms. Low output buffer offers no benefits in music playback. And unless you have a very special output device with broken drivers there is absolutely no difference in the playback between event and push WASAPI outputs.
Go to the top of the page
+Quote Post
Kohlrabi
post Mar 26 2014, 07:51
Post #104





Group: Super Moderator
Posts: 1017
Joined: 12-March 05
From: Kiel, Germany
Member No.: 20561



QUOTE (BigRedMachineSlash @ Mar 26 2014, 02:49) *
I've found Event Mode drastically clearer and more open sounding compared to Push Mode, so I've tried just about everything possible to get it working glitch free.
Don't waste your time on hunting figments of your imagination. If "push" mode or DirectSound don't have any glitches, use those, preferably the latter.

QUOTE (BigRedMachineSlash @ Mar 26 2014, 02:49) *
Buffer length set to 350ms (minimum determined by the ctrl-alt-delete method)(http://www.head-fi.org/t/539638/how-to-set-perfect-buffer-lengths)
There is zero benefit of having a short buffer for music playback other than that changing DSPs on-the-fly will have the changes kick in earlier. If you are experiencing glitches, try to increase buffer size to something reasonable like a couple of seconds to avoid those. The guide on head-fi is plain wrong:
QUOTE
Having the lowest latency possible is important for your audio.
This is a lie, at least with respect to audio playback.

QUOTE (BigRedMachineSlash @ Mar 26 2014, 02:49) *
I still get the occasional glitch, so there is obviously a DPC latency issue on the computer, which I can't fix due to the PC being locked down.
Too bad, this might also be important to solve.

This post has been edited by Kohlrabi: Mar 26 2014, 08:15


--------------------
PRaT is the new jitter.
Go to the top of the page
+Quote Post
BigRedMachineSla...
post Mar 26 2014, 13:15
Post #105





Group: Members
Posts: 22
Joined: 9-July 02
From: QLD
Member No.: 2530



If I set a long buffer, the pauses increase and take longer for playback to recover. But yeah, I agree that low latency shouldn't be that important for playback unless you're simultaneously recording or using DSP's. I'll try some further tests.

I probably should do an ABX test or something, but at least on my work machine there is an easily discernible difference in sound quality between modes. Maybe an RMAA test would prove the point, however it's not the main purpose of my post, so please ignore my previous comment on sound quality (I should have known better). On my home PC there is no significant differences between the two modes. More than likely my work PC's sound or usb drivers are broken, but there's nothing I can do.

This post has been edited by BigRedMachineSlash: Mar 26 2014, 13:18
Go to the top of the page
+Quote Post
BigRedMachineSla...
post Mar 27 2014, 00:46
Post #106





Group: Members
Posts: 22
Joined: 9-July 02
From: QLD
Member No.: 2530



I did a "reset page" for the advanced preferences. This seemed to help quite a bit, so maybe my settings were corrupted or something. At 350 ms output buffer, the stutters were still there, but only after a few songs played, not straight away. I put the buffer up to 3000 ms and everything seems pretty good now.
Go to the top of the page
+Quote Post
romka18
post Apr 26 2014, 06:12
Post #107





Group: Members
Posts: 47
Joined: 30-September 11
Member No.: 94073



didnt update this component for a long time. After i did it i found some problem: when next track has different format (96khz/24bit instead of previously played 44.1/16) playback stops with error message: "Unrecoverable playback error: Device invalidated" or "wrong arguments (or somehow like that)", but if wait 2-3 seconds and manually begin playback of new file, it plays fine. I didnt noticed this problem before. Using USB sound card E-MU 0204, Win8.1 x64.

p.s. maybe somehow add pause between different source tracks?

This post has been edited by romka18: Apr 26 2014, 06:17
Go to the top of the page
+Quote Post
A_Man_Eating_Duc...
post Apr 26 2014, 07:17
Post #108





Group: Members
Posts: 930
Joined: 21-December 01
From: New Zealand
Member No.: 705



I have no problems switching from 16/44.1 to 24/96 using WASAPI.

Are there any newer drivers for your E-MU 0204?


--------------------
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.
Go to the top of the page
+Quote Post
romka18
post Apr 26 2014, 08:03
Post #109





Group: Members
Posts: 47
Joined: 30-September 11
Member No.: 94073



nope, they are old as this soundcard. And no any hope for update. WASAPI ver. 2.1 make it same, looks like i get it after win8.1 update. Seems like it really need some delay between tracks like this.
Go to the top of the page
+Quote Post
A_Man_Eating_Duc...
post Apr 26 2014, 10:52
Post #110





Group: Members
Posts: 930
Joined: 21-December 01
From: New Zealand
Member No.: 705



Does the 0204 support ASIO output? Maybe that's the way to go?


--------------------
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.
Go to the top of the page
+Quote Post
romka18
post Apr 26 2014, 11:25
Post #111





Group: Members
Posts: 47
Joined: 30-September 11
Member No.: 94073



only ASIO4ALL, but it plays fine only 16/44.1. In higher resolution it begins play cracks, noise and more over the music.
Best of all 0204 handles by DS output, but it begins to glitch when i work in visual studio, so i need WASAPI.

also, is it possible to get sources of this foo_out_wasapi? Intersting in some moments
Go to the top of the page
+Quote Post
A_Man_Eating_Duc...
post Apr 26 2014, 12:11
Post #112





Group: Members
Posts: 930
Joined: 21-December 01
From: New Zealand
Member No.: 705



Have you tried using LatencyMon to see if it could be a driver causing the problem?

Also tried changing USB ports?

Tried the beta driver?
http://support.creative.com/downloads/welc...Type=11#type_11


This post has been edited by A_Man_Eating_Duck: Apr 26 2014, 12:13


--------------------
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.
Go to the top of the page
+Quote Post
romka18
post Apr 26 2014, 13:43
Post #113





Group: Members
Posts: 47
Joined: 30-September 11
Member No.: 94073



LatencyMon says my pc isnt good for realtime audio. But playing music - isnt real-time task. Dont want install beta drivers - files from it smaller than the original driver, so i dont believe them. Also, problem isnt in playback, it between different tracks. Maybe, device configured for new track after buffer is filled with new pcm data (async, or maybe something like that). Or hardware problem - device really need some time to switch something
Go to the top of the page
+Quote Post
A_Man_Eating_Duc...
post Apr 27 2014, 08:44
Post #114





Group: Members
Posts: 930
Joined: 21-December 01
From: New Zealand
Member No.: 705



I would be looking in to the reason why LatencyMon is reporting your PC is struggling with realtime audio. That would explain why your getting glitches when your using ASIO.

First thing i would try is the beta driver, if it doesn't fix it then just roll back to the latest stable version. Other than that i don't think your going to be about to the the source code for foo_out_WASAPI since it is maintained by the creator of Foobar2000.

This post has been edited by A_Man_Eating_Duck: Apr 27 2014, 08:49


--------------------
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.
Go to the top of the page
+Quote Post
romka18
post Apr 28 2014, 14:24
Post #115





Group: Members
Posts: 47
Joined: 30-September 11
Member No.: 94073



i have installed beta drivers and my problem has been solved after few reboots, so stay on wasapi renderer

asking for sources not to fix them, now digging in microsoft`s example wasapi out for win8, and this one are cracking too much on start or end playback
Go to the top of the page
+Quote Post
Elbi
post Jul 22 2014, 00:33
Post #116





Group: Members
Posts: 1
Joined: 22-July 14
Member No.: 116771



Is there any reason why foobar2000 WASAPI plugin supports only exclusive mode? I really, really dislike this "exclusive" part, I use WASAPI because I have sound issues when using DirectSound (sound crackling and skipping). Other programs like AIMP3 support WASAPI Shared mode (http://i.imgur.com/qqpdpyG.png), which is perfect for me, but I don't want to change my audio player that I use since 2004. Is there any way I can use foobar2000 with WASAPI non-exclusive mode?
Go to the top of the page
+Quote Post
Case
post Jul 22 2014, 01:49
Post #117





Group: Developer (Donating)
Posts: 2206
Joined: 19-October 01
From: Finland
Member No.: 322



DirectSound uses WASAPI shared mode behind the scenes. There's no need for foobar2000 to reimplement it. Don't use too small buffers or touch priority settings and there won't be glitching.
Go to the top of the page
+Quote Post

5 Pages V  « < 3 4 5
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd August 2014 - 01:48