IPB

Welcome Guest ( Log In | Register )

foobar+refalac Tagging Issue, Tags missing when converting Flac to Alac
Lumpf
post Jul 15 2012, 15:56
Post #1





Group: Members
Posts: 3
Joined: 15-July 12
Member No.: 101441



Hello dear community,

I'm new, probably grant me some dumbness.

I'm trying to convert my FLAC collection, including 24/96 material to alac for use on my iPod. For this i use the refalac encoder with following settings:
Encoder:C:\Encoder\qaac\refalac.exe
Extension: m4a
Parameters: --silent --no-optimize --ignorelength - -o %d
max BSP: 24
Lossless/Hybrid

I snatched that from other posts, it was the only configuration that allowed me to run it. Others, left me with the output "please re-check paramters".
I included a libFlac.dll from my flac-encoder in the qaac folder. C++ environment is installed and i also copied the full folder, so the refalac .dlls are included as well. I'm running win7 x64 with the x86 refalac. (shouldn't be any problem afaik).

Now it does endoce new files, but without the tags. Foobar is unable to tag them ("usupported/corrupt file") and doesn't even show bitrates etc, but itunes plays them fine, shows the info, but no tags.

This the encoder output:
CODE
1 out of 1 tracks converted with major problems.

Source: "E:\Musikbackups\Flac\Anteater - 2012 EP\01 Above Than Beside Me.flac"
  An error occurred while finalizing the encoding process (Unsupported format or corrupted file) : "F:\All Music\My iPod\Anteater - 2012 EP\01 Above Than Beside Me.m4a"
  Conversion failed: Unsupported format or corrupted file


And this is the Console log:
CODE
Opening track for playback: "E:\Musikbackups\Flac\Anteater - 2012 EP\01 Above Than Beside Me.flac"
CLI encoder: C:\Encoder\qaac\refalac.exe
Destination file: F:\All Music\My iPod\Anteater - 2012 EP\01 Above Than Beside Me.m4a
Encoder stream format: 44100Hz / 2ch / 16bps
Command line: "C:\Encoder\qaac\refalac.exe" --silent --no-optimize --ignorelength - -o "01 Above Than Beside Me.m4a"
Working folder: F:\All Music\My iPod\Anteater - 2012 EP\
Encoder process still running, waiting...
Encoder process terminated cleanly.
Writing tags to encoded file failed: Unsupported format or corrupted file
An error occurred while finalizing the encoding process (Unsupported format or corrupted file) : "F:\All Music\My iPod\Anteater - 2012 EP\01 Above Than Beside Me.m4a"
Conversion failed: Unsupported format or corrupted file
could not enumerate tracks (Unsupported format or corrupted file) on:
F:\All Music\My iPod\Anteater - 2012 EP\01 Above Than Beside Me.m4a
Total encoding time: 0:01.904, 121.84x realtime


Thanks for help,
Greetings, Lumpf

This post has been edited by Lumpf: Jul 15 2012, 16:05
Go to the top of the page
+Quote Post
 
Start new topic
Replies
derty2
post Nov 23 2012, 18:00
Post #2





Group: Members
Posts: 581
Joined: 5-June 11
Member No.: 91257



This thread has not solved anything. . . the same problem is happening to me too!

Some of the previous comments are referring to foobar2000 support for ALAC playback.
The O.P. started this thread to mainly solve an encoding problem AND NOT a playback problem

even though, in reality, the encoding problem will give playback problems too. . .

MY TEST:

- I am running Windows XP w/SP3
- Install foobar2000 v1.1.17 (DUI standard install, portable mode)
- Download ""qaac_2.01.zip (x86)" and unpack the 5 files to foobar2000 config folder root (libsoxrate.dll | msvcp100.dll | msvcr100.dll | qaac.exe | refalac.exe)
- Configure the ALAC encoder parameters in "foobar2000 Converter Setup" exactly as in the 1st post
- Drop some well tagged FLAC files into a new playlist and go to "Converter", and try converting to ALAC

- ALAC files are created, but "Information" console message window pops up this:
   -------------------------------------------------------------
   Could not load info (Unsupported format or corrupted file (moov box not found)) from:
   "C:\Test\Encode To ALAC\01.track.m4a"
   Could not load info (Unsupported format or corrupted file (moov box not found)) from:
   "C:\Test\Encode To ALAC\02.track.m4a"
   Could not load info (Unsupported format or corrupted file (moov box not found)) from:
   "C:\Test\Encode To ALAC\03.track.m4a"
   ---------------------------------------------------------------


- I drop the newly created ALAC files into the foobar2000 playlist and double-click an item for playback, but "Playback error" console message window pops up this:
   -------------------------------------------------------------
   Unable to open item for playback (Unsupported format or corrupted file (moov box not found)) from:
   "C:\Test\Encode To ALAC\01.track.m4a"
   Unable to open item for playback (Unsupported format or corrupted file (moov box not found)) from:
   "C:\Test\Encode To ALAC\02.track.m4a"
   Unable to open item for playback (Unsupported format or corrupted file (moov box not found)) from:
   "C:\Test\Encode To ALAC\03.track.m4a"
   ---------------------------------------------------------------


- I select all the ALAC files in the foobar2000 playlist and try going to Properties, but "Information" console message window pops up again and no Properties window appears:

- I also notice the Tags are not in existence in the Playlist View (just question marks).

So, does anybody have any working solutions for encoding to ALAC files with foobar2000 ?

Thanks in advance.
Go to the top of the page
+Quote Post
lvqcl
post Nov 23 2012, 18:19
Post #3





Group: Developer
Posts: 3383
Joined: 2-December 07
Member No.: 49183



QUOTE (derty2 @ Nov 23 2012, 21:00) *
This thread has not solved anything. . .

O rly?

QUOTE (derty2 @ Nov 23 2012, 21:00) *
the same problem is happening to me too!

No, your problem is different. Simply download older version (qaac_1.46.zip).
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st September 2014 - 18:00