IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
libFLAC 1.2.1 20070917 - piping problems with 6ch files?, 6ch, 16Bit, 48kHz wave -> flac = 2hr file@45kbps
ChronoSphere
post Jul 1 2012, 15:01
Post #1





Group: Members
Posts: 491
Joined: 11-March 07
Member No.: 41384



I am not sure if it's a problem with foobar2000 or libflac, since I don't really know how to test piping outside foobar

I have a 6ch, 16Bit, 48kHz wave file with a length of 00:02:23 and a bitrate of 4608kbps (as displayed by foobar)
When I try to convert it to flac (foobar command line: flac.exe --verify -8 - -o %d), it results in a 6ch, 16Bit, 45kbps file with a length of 02:04:17

The file plays fine up to the correct length, followed by silence.

If I convert the same file via command line (flac.exe --verify -8 file.wav), everything works fine.
I also tried to convert the file to wavpack from foobar and it converted correctly, which makes me think it's really a flac issue and not foobar.

Am I missing something?

Go to the top of the page
+Quote Post
lvqcl
post Jul 1 2012, 15:05
Post #2





Group: Developer
Posts: 3381
Joined: 2-December 07
Member No.: 49183



Default settings for FLAC in foobar2000 include --ignore-chunk-sizes option. Either add it or use "%s -o %d" instead of "- -o %d".

This post has been edited by lvqcl: Jul 1 2012, 15:17
Go to the top of the page
+Quote Post
ChronoSphere
post Jul 1 2012, 15:16
Post #3





Group: Members
Posts: 491
Joined: 11-March 07
Member No.: 41384



Hmm, I don't remember removing that one, but it's been ages since I touched my converter options.
This seems to have fixed it, I don't really understand the issue though. Is the encoder getting data in chunks and basing the playtime off the number of chunks/their size?
Go to the top of the page
+Quote Post
db1989
post Jul 1 2012, 15:23
Post #4





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



I ran a built-in Google search on foobar2000 FLAC ignore chunk sizes for you: http://www.hydrogenaudio.org/forums/index....showtopic=80017

This post provides some explanation, albeit incorrectly blaming foobar2000 – or, at least, using ambiguous language that implies that – when the application has no culpability at all:
QUOTE (GeSomeone @ Apr 16 2010, 14:16) *
foobar2000 stopped to provide the accurate file length to the encoders, I think this thread gives you a clue.
[…]
This only matters when encoding from stdin (which is the most efficient), when you do "flac -s -8 %s -o %d" --ignore_chunk_size is not needed because Flac can see the exact length of the temporary file.

The thread linked in my quote contains this post, which explains the issue, why foobar2000 (or any other intermediary) cannot possibly be to blame, and its solution:
QUOTE (Peter @ Mar 31 2006, 21:15) *
You need to encode through temp files (%s) instead of stdin. This simply can't be fixed with stdin because length of source file is not always known accurately without having decoded entire file in advance; encoders should expose additional switches to handle "truncated" WAV files like wavpack does.
…and as flac.exe now does, in the form of --ignore-chunk-sizes, making the necessity of encoding via temporary files a thing of the past.

This post has been edited by db1989: Jul 1 2012, 15:34
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th September 2014 - 16:18