IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Closed TopicStart new topic
1.1.13 Playback options don't stick
Sandrine
post Jun 13 2012, 10:27
Post #1





Group: Members
Posts: 319
Joined: 2-July 10
Member No.: 81991



I'm encountering a bug with 1.1.13 that "Playback follows cursor" etc. options do reset themselves with each new track played to the state they were in when foobar was started. The only way for me to make them stick is select/deselect an option and then immediately restart foobar. Can anyone reproduce this?
Go to the top of the page
+Quote Post
Sandrine
post Jul 20 2012, 19:07
Post #2





Group: Members
Posts: 319
Joined: 2-July 10
Member No.: 81991



QUOTE (Sandrine @ Jun 13 2012, 11:27) *
I'm encountering a bug with 1.1.13 that "Playback follows cursor" etc. options do reset themselves with each new track played to the state they were in when foobar was started. The only way for me to make them stick is select/deselect an option and then immediately restart foobar. Can anyone reproduce this?


Clandestinely fixed in 1.1.14b1... too embarrassing for changelog? cool.gif
Go to the top of the page
+Quote Post
Sandrine
post Jul 22 2012, 09:57
Post #3





Group: Members
Posts: 319
Joined: 2-July 10
Member No.: 81991



Dang, only fixed in my head. Embarrassing, me.
Go to the top of the page
+Quote Post
kode54
post Jul 22 2012, 18:51
Post #4





Group: Admin
Posts: 4579
Joined: 15-December 02
Member No.: 4082



Both options seem to take immediate effect. Are you sure you didn't enable the wrong option by mistake?
Go to the top of the page
+Quote Post
Sandrine
post Aug 1 2012, 18:30
Post #5





Group: Members
Posts: 319
Joined: 2-July 10
Member No.: 81991



Probably my problem description was misleading, let me try again:

1. Playback follows cursor = disabled
2. Start playing a track
3. While track is playing, click to enable "Playback follows cursor"
4. Skip to next track
5. While track is playing, click to disable "Playback follows cursor"
6. Skip to next track
7. Observe that "Playback follows cursor" did enable itself again.
Goback to 3. and repeat ad infinitum.

So, the problem should probably be called "Playback follows cursor" doesn't stick without stopping playback".
Go to the top of the page
+Quote Post
Alexxander
post Aug 1 2012, 18:47
Post #6





Group: Members
Posts: 457
Joined: 15-November 04
Member No.: 18143



I can't reproduce it on my v1.1.13. "Playback follows cursor" only enables or disables by my mouseclicking.
Go to the top of the page
+Quote Post
lvqcl
post Aug 1 2012, 19:42
Post #7





Group: Developer
Posts: 3339
Joined: 2-December 07
Member No.: 49183



Playlist Attributes:

QUOTE
It's not recommended to use "playback follows cursor" together with prioritized playlists or "continue on playlist". It might lead to glitches during playback in certain situations.


That's all that I can find about "playback follows cursor" setting problem.

This post has been edited by lvqcl: Aug 1 2012, 19:44
Go to the top of the page
+Quote Post
fbuser
post Aug 1 2012, 20:29
Post #8





Group: Developer
Posts: 675
Joined: 26-September 07
Member No.: 47369



But this has nothing to do with the described problem.

This post has been edited by fbuser: Aug 1 2012, 20:29
Go to the top of the page
+Quote Post
Sandrine
post Aug 1 2012, 20:50
Post #9





Group: Members
Posts: 319
Joined: 2-July 10
Member No.: 81991



Thanks for the feedback, I might have to try this on a virgin installation.
Go to the top of the page
+Quote Post
Sunrays
post Jan 3 2014, 15:40
Post #10





Group: Members
Posts: 10
Joined: 31-December 13
Member No.: 113678



Anyone has a solution for this problem?

This "Playback follows cursor" keeps re-enabling itself. This option is so annoying i want to completely erase it from the system. please help. Thank you

This post has been edited by Sunrays: Jan 3 2014, 15:41
Go to the top of the page
+Quote Post
ChronoSphere
post Jan 3 2014, 15:59
Post #11





Group: Members
Posts: 463
Joined: 11-March 07
Member No.: 41384



QUOTE (Sandrine @ Aug 1 2012, 18:30) *
Probably my problem description was misleading, let me try again:

1. Playback follows cursor = disabled
2. Start playing a track
3. While track is playing, click to enable "Playback follows cursor"
4. Skip to next track
5. While track is playing, click to disable "Playback follows cursor"
6. Skip to next track
7. Observe that "Playback follows cursor" did enable itself again.
Goback to 3. and repeat ad infinitum.

So, the problem should probably be called "Playback follows cursor" doesn't stick without stopping playback".

I just tried that and cannot reproduce it. Are you sure none of foobar's files/folders got set to read-only by mistake? Including the appdata directory.
Go to the top of the page
+Quote Post
Sunrays
post Jan 3 2014, 16:50
Post #12





Group: Members
Posts: 10
Joined: 31-December 13
Member No.: 113678



Hm, i can..
when i play a song (and the option is disabled), i skip to next track and boom.. its enabled.

and yes? the foobar folders and also the appdata folders are 'Read Only (only applies to files in folders)' , and it doesn't go away when i change it in the Properties dialogue, its instantly Read Only again.

Edit:
mm, ok, after removing Playlist Attributes component, it works.. but, the question is if there is a fix to make it work together?

This post has been edited by Sunrays: Jan 3 2014, 17:35
Go to the top of the page
+Quote Post
ChronoSphere
post Jan 3 2014, 19:36
Post #13





Group: Members
Posts: 463
Joined: 11-March 07
Member No.: 41384



Interesting, I expected the folders to not be read-only, but mine are, as well. Seems it's not the cause then.
I'm not familiar with that component, but if removing it fixed the behaviour, then it's a bug in that component and will probably have to be updated to be compatible with 1.3
Go to the top of the page
+Quote Post

Closed TopicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 30th July 2014 - 20:38