IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
foobar2000 seems to be playing only first 5 sec of a long silent track, [TOS #6: was "Song not playing appropriately"]
tallica
post Jun 12 2012, 20:18
Post #1





Group: Members
Posts: 5
Joined: 22-May 10
Member No.: 80830



This has do to with the Korn album: Follow the Leader. Those who know about this album, know that there are several -blank- tracks at the beginning of the CD. I wanted to tie those Silence tracks together into the first actual song of the album. I used a song merger to put all of the silence tracks together with the first song. Now when I put the new file into Foobar, it only plays the first 5 seconds of silence then ends. If I play that new file on Windows Media Player, it plays the full 1 min of silence then the 4 min song.

I'm pretty sure it's not the song merge software messing with things because I successfully merged Led Zeppelin's Heartbreaker and Living Loving Maid into one song and Foobar plays that fine.

Any suggestions on this? Is foobar just not liking that full minute of silence and assuming the track is blank, and so shortens it to 5 seconds?
Go to the top of the page
+Quote Post
MordredKLB
post Jun 12 2012, 20:23
Post #2





Group: Members
Posts: 198
Joined: 1-May 09
From: Austin, TX
Member No.: 69413



Do you have the "Skip Silence" DSP enabled? It shouldn't normally skip the whole track, but that 5 seconds of silence thing points in that direction. What happens if you play the entire album with the silent tracks included?
Go to the top of the page
+Quote Post
tallica
post Jun 12 2012, 20:40
Post #3





Group: Members
Posts: 5
Joined: 22-May 10
Member No.: 80830



I'm not sure what "skip silence" dsp is. Before I merged the songs there were 12 tracks of silence, each was 5 seconds long. I'm not sure how long each of those tracks were supposed to be before they were on Foobar though.

It seems like Foobar is looking at the track and seeing if there is sound content in the first part of the song file, if not then it shortens it to 5 seconds.

EDIT: Found the "skip silence" that was not active, so that's not the issue.

I did find this thread (in German) not sure if it's related but I saw a 5 second silence stat. http://foobar-users.de/index.php?topic=2429.0

I don't want to mess with any numbers and screw up my Foobar, but my issue may have something to do with the Decoding section of Preferences > Advanced > Decoding.

My Tone/Sweep sample rate is set at 44100 and Additional correction file folders is empty.

This post has been edited by tallica: Jun 12 2012, 21:01
Go to the top of the page
+Quote Post
MordredKLB
post Jun 12 2012, 22:29
Post #4





Group: Members
Posts: 198
Joined: 1-May 09
From: Austin, TX
Member No.: 69413



That thread is referencing the tone generator of foobar (which can also generate an arbitrary length of silence) and has nothing to do with your problem. Unfortunately, I don't know what's causing it.

I do see that the first twelve tracks are all 5 seconds of silence... so that points back to the output of the program that joined them not being handled well by foobar. I know you've said the joiner has worked fine in the past, but as the tracks essentially contain no audio data that doesn't mean they'd be handled the same way. I'd suggest trying to find a different program which can concatenate tracks and see if that fixes your problem in foobar.
Go to the top of the page
+Quote Post
db1989
post Jun 12 2012, 22:35
Post #5





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



QUOTE (MordredKLB @ Jun 12 2012, 22:29) *
I do see that the first twelve tracks are all 5 seconds of silence... so that points back to the output of the program that joined them not being handled well by foobar.
Which makes it apropos for tallica to specify what program performed the joining, and what format the input and output files are.
Go to the top of the page
+Quote Post
tallica
post Jun 12 2012, 23:15
Post #6





Group: Members
Posts: 5
Joined: 22-May 10
Member No.: 80830



QUOTE (MordredKLB @ Jun 12 2012, 22:29) *
That thread is referencing the tone generator of foobar (which can also generate an arbitrary length of silence) and has nothing to do with your problem. Unfortunately, I don't know what's causing it.

I do see that the first twelve tracks are all 5 seconds of silence... so that points back to the output of the program that joined them not being handled well by foobar. I know you've said the joiner has worked fine in the past, but as the tracks essentially contain no audio data that doesn't mean they'd be handled the same way. I'd suggest trying to find a different program which can concatenate tracks and see if that fixes your problem in foobar.


The problem is certainly with Foobar, the file itself is over 5 minutes in length and fully plays in Windows Media Player (1 minute silence then 4 minutes of music). But when I try to play it in Foobar it only plays 5 seconds of silence and goes on to another song (the listing in Foobar is only for 5 seconds).

Because of this I'm thinking that Foobar checks the files for content and if it doesn't 'see' anything in the first part of the track, it limits it to 5 seconds.


QUOTE (db1989 @ Jun 12 2012, 22:35) *
QUOTE (MordredKLB @ Jun 12 2012, 22:29) *
I do see that the first twelve tracks are all 5 seconds of silence... so that points back to the output of the program that joined them not being handled well by foobar.
Which makes it apropos for tallica to specify what program performed the joining, and what format the input and output files are.


I used something called MergeMP3 which is freeware I found online. The first thing I did (and the real reason why I downloaded it) was for the Led Zeppelin songs. That worked just fine and I had no problems with Foobar using the newly created Led Zeppelin song file.

When I tried to combine 12 tracks of silence and 1 song track together, foobar didn't like it and shortened the 5 minute song to 5 seconds. The actual file that was created from this merge works fine in Windows Media Player. Actually plays the 12 tracks of silence (totaling 1 minute) before getting to the next song.

What I will do next is try to combine them all so that the song is first then the 1 minute of silence follows (just to see if Foobar will work). I'm sure it will work and that Foobar is doing some search of the music file to check if there is content, if it's not 'seeing' anything it limits the file down to 5 seconds.
Go to the top of the page
+Quote Post
tallica
post Jun 12 2012, 23:30
Post #7





Group: Members
Posts: 5
Joined: 22-May 10
Member No.: 80830



I just realized that my problem must be from converting these files from wma to mp3. When I did the Led Zeppelin merge, the files were already in mp3 format, so I didn't need to convert. But my Korn files are in wma format, and I needed to convert them before merging.

Now I am trying to either find a way to merge wma files or safely convert to mp3 before merging.

EDIT: That indeed was the issue for me. After finding a program that would merge my wma files, I merged them all into one and it is working fine in Foobar.

Thanks for everyone's help!

This post has been edited by tallica: Jun 12 2012, 23:44
Go to the top of the page
+Quote Post
db1989
post Jun 12 2012, 23:43
Post #8





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



QUOTE (tallica @ Jun 12 2012, 23:15) *
The problem is certainly with Foobar
I wouldnt be so presumptuous if I were you!

QUOTE
the file itself is over 5 minutes in length and fully plays in Windows Media Player (1 minute silence then 4 minutes of music). But when I try to play it in Foobar it only plays 5 seconds of silence and goes on to another song (the listing in Foobar is only for 5 seconds).
[]
I used something called MergeMP3 which is freeware I found online.
[]
Im sure [] Foobar is doing some search of the music file to check if there is content, if it's not 'seeing' anything it limits the file down to 5 seconds.
Or the combined file, which, as you said in an earlier post, was created from 12 tracks of silence, each [of which] was 5 seconds long, was not merged properly, with the result that foobar2000 encounters the original end of the first 5 s long MP3 and stops there. Doesnt that sound quite possible? I have no way to check right now, but I think this is quite likely, perhaps more so than your alternative placement of the blame upon foobar2000.
Go to the top of the page
+Quote Post
White_Shadow
post Jun 13 2012, 08:11
Post #9





Group: Members
Posts: 97
Joined: 3-May 11
Member No.: 90287



I know that this is a bit late, but fb2k can merge tracks, too. Simply use the converter an check the option "merge into one file".
Go to the top of the page
+Quote Post
Kohlrabi
post Jun 13 2012, 08:32
Post #10





Group: Super Moderator
Posts: 1148
Joined: 12-March 05
From: Kiel, Germany
Member No.: 20561



QUOTE (White_Shadow @ Jun 13 2012, 09:11) *
I know that this is a bit late, but fb2k can merge tracks, too. Simply use the converter an check the option "merge into one file".

Which involves transcoding lossy to lossy in case of WMA and MP3, which is punishable by ten whip lashes across the back.


--------------------
It's only audiophile if it's inconvenient.
Go to the top of the page
+Quote Post
White_Shadow
post Jun 13 2012, 14:33
Post #11





Group: Members
Posts: 97
Joined: 3-May 11
Member No.: 90287



And no on should use lossy files since there are lossless alternatives just like flac, right?

Beside of this, it was only a suggestion.
Go to the top of the page
+Quote Post
Kohlrabi
post Jun 13 2012, 16:14
Post #12





Group: Super Moderator
Posts: 1148
Joined: 12-March 05
From: Kiel, Germany
Member No.: 20561



QUOTE (White_Shadow @ Jun 13 2012, 15:33) *
Beside of this, it was only a suggestion.

My statement was meant half-jokingly. I just wanted to point out that foobar2000 converter always decodes and reencodes the file, as opposed to some tools which can losslessly merge MP3 files.


--------------------
It's only audiophile if it's inconvenient.
Go to the top of the page
+Quote Post
Zarggg
post Jun 13 2012, 17:34
Post #13





Group: Members
Posts: 566
Joined: 18-January 04
From: bethlehem.pa.us
Member No.: 11318



Just to confirm what db1989 has said, I've run into similar issues with MergeMP3 in the past. I tried to combine multiple files of an audiobook (each file was sourced from one side of a cassette tape), and when I tried to play it on my iPod, playback of the file ceased when what was originally the first file ended.
Go to the top of the page
+Quote Post
db1989
post Jun 13 2012, 18:30
Post #14





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Thanks, Zarggg; Im glad someone has experience, rather than my uninformed guess, which just happened to be lucky this time. biggrin.gif

It seems that WMPs playing the entire file must be due to its using a different decoder or behaviour; foobar2000 reads the end-of-file signal from the original first track, whereas WMP does not read it or ignores it.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 17:17