IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
DTS WAV issue: Unrecoverable playback error: Unsupported stream format, Can't play DTS audio via S/PDIF [moved from Movie/Multichannel Aud
doryon
post Jun 11 2012, 00:05
Post #1





Group: Members
Posts: 3
Joined: 10-June 12
Member No.: 100592



Hi,
I'vre trying without luck to play DTS-WAV files (.wav and/or .cue) via S/PDIF.
All I get is white noise, 2CH PCM audio or this error message:

Unrecoverable playback error: Unsupported stream format: 44100 Hz / 16-bit / 6 channels

I've trying anything and I'm frustrated.

My OS is Win7 and I play DTS/AC3/etc., video files without problem via S/PDIF

I've installed foo_input_dts, foo_spdifer and foo_out_wasapi and still nothing...

Could anyone please help me?

Thanks in advance!
Go to the top of the page
+Quote Post
DVDdoug
post Jun 11 2012, 21:04
Post #2





Group: Members
Posts: 2534
Joined: 24-August 07
From: Silicon Valley
Member No.: 46454



QUOTE
Unrecoverable playback error: Unsupported stream format: 44100 Hz / 16-bit / 6 channels
I'm just going to take a wild guess, because I've never used this format.

Originally, the idea was to burn the data onto a CD in CD format to fake-out the CD player. So, maybe the file header is wrong because the player software somehow "knows" this is 6-channels and is not getting faked-out into thinking it's sending-out regular 44.1K, 16-bit 2-channel stereo PCM. (The receiver or DTS decoder is not supposed to get faked-out... It's supposed to recognize the DTS and decode it.)


...Maybe you should just get some DVD authoring software and make a standard audio-only "video" DVD (or DVD-formatted files). Then, any DVD player (or DVD player software) that supports DTS could play the file. Better yet, make a DVD with Dolby AC3, because all DVD players (and DVD player software) are required to play AC3.

This post has been edited by DVDdoug: Jun 11 2012, 21:20
Go to the top of the page
+Quote Post
probedb
post Jun 11 2012, 23:30
Post #3





Group: Members
Posts: 1193
Joined: 6-September 04
Member No.: 16817



I thought DTS was 48KHz/16-bit and not 44.1KHz?

This post has been edited by probedb: Jun 11 2012, 23:30
Go to the top of the page
+Quote Post
doryon
post Jun 13 2012, 13:14
Post #4





Group: Members
Posts: 3
Joined: 10-June 12
Member No.: 100592



Thank you both for your input.
I'm yet to try and burn a CD/DVD. I've mounted a virtual drive with these files with PowerISO but with the same results.
I'll try to burn a DVD, but in the meantime, here's Media Info on one of them:

General
Complete name : D:\Downloads\5.1\Pink Floyd - The Division Bell\Pink Floyd - The Division Bell.wav
Format : Wave
File size : 671 MiB
Duration : 1h 6mn
Overall bit rate mode : Constant
Overall bit rate : 1 411 Kbps

Audio
ID : 0
Format : DTS
Format/Info : Digital Theater Systems
Format settings, Endianness : Little
Muxing mode : LE / 14
Codec ID : 1
Duration : 1h 6mn
Bit rate mode : Constant
Bit rate : 1 411.2 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 44.1 KHz
Bit depth : 24 bits
Compression mode : Lossy
Stream size : 671 MiB (100%)

Cheers!
Go to the top of the page
+Quote Post
Case
post Jun 13 2012, 19:18
Post #5





Group: Developer (Donating)
Posts: 2178
Joined: 19-October 01
From: Finland
Member No.: 322



You need to remove foo_input_dts or the DTS in the wav gets decoded. You also need to make sure you are using the WASAPI output and have Windows and foobar2000 volumes at maximum level. ReplayGain and DPSs must not alter the loudness either.
Go to the top of the page
+Quote Post
doryon
post Jun 20 2012, 16:56
Post #6





Group: Members
Posts: 3
Joined: 10-June 12
Member No.: 100592



QUOTE (Case @ Jun 13 2012, 15:18) *
You need to remove foo_input_dts or the DTS in the wav gets decoded. You also need to make sure you are using the WASAPI output and have Windows and foobar2000 volumes at maximum level. ReplayGain and DPSs must not alter the loudness either.


Man, that was it... I can't believe it... I just could try it today an voilą.
You are awsome, thanks a lot!!!
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd July 2014 - 16:13