IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
"Unable to open item for playback (device is not ready)"
maxson924
post May 12 2012, 22:16
Post #1





Group: Members
Posts: 3
Joined: 12-May 12
Member No.: 99769



First of all, my apologies if this topic already exists; I looked throughout this forum and didn't find anything like it.

As for my problem, I've been using foobar on an old PC for years with no problems. I store all my music on an external hard drive and have always just told foobar to monitor the music folder on that. Today I got a new computer and installed foobar, copying over the config files and all that from my old computer to this one (via my external drive). I've told foobar on this computer to monitor the music folder just like before. It recognizes all my files, no problems. But then when I try to actually play any files, it shows the error in the topic title.

As for specs, Asus X44L-BBK4, Windows 7 Home Premium, foobar v1.1.11. The old computer was a Dell Inspiron 1300 (yeah, it was old) with Windows XP and foobar v1.0.3. The external drive is a Seagate 500 GB USB drive, but I don't know the exact model nor how to check.

Any help is much appreciated!

This post has been edited by maxson924: May 12 2012, 22:17
Go to the top of the page
+Quote Post
Ouroboros
post May 12 2012, 22:47
Post #2





Group: Members
Posts: 291
Joined: 30-May 08
From: UK
Member No.: 53927



Try copying a few files to your new PC hard drive, just to make sure they play properly.

Run foobar2000 as Administrator (right click - run as Administrator) and try playing the files on the USB drive. If that works check the permissions and ownership of the USB drive and its contents.

This post has been edited by Ouroboros: May 12 2012, 22:50
Go to the top of the page
+Quote Post
Porcus
post May 12 2012, 23:49
Post #3





Group: Members
Posts: 1842
Joined: 30-November 06
Member No.: 38207



Everything is OK in Preferences > Playback > Output ?

QUOTE (maxson924 @ May 12 2012, 23:16) *
Today I got a new computer and installed foobar, copying over the config files and all that from my old computer to this one (via my external drive).

(Or does it perchance try to play with the old device which isn't there anymore?)


--------------------
One day in the Year of the Fox came a time remembered well
Go to the top of the page
+Quote Post
maxson924
post May 13 2012, 00:18
Post #4





Group: Members
Posts: 3
Joined: 12-May 12
Member No.: 99769



QUOTE
Try copying a few files to your new PC hard drive, just to make sure they play properly.


Yup, that worked.

QUOTE
Run foobar2000 as Administrator (right click - run as Administrator) and try playing the files on the USB drive.


This worked too!

QUOTE
If that works check the permissions and ownership of the USB drive and its contents.


Assuming I did the right thing (Right-clicked the drive -> Properties -> Security), it's set to allow full control for all users (I'm the only user). A friend of mine had suggested that before I came here but that alone didn't do the trick.

QUOTE
Everything is OK in Preferences > Playback > Output ?


I don't really know what to check for, but nothing strikes me as off. tongue.gif

QUOTE
(Or does it perchance try to play with the old device which isn't there anymore?)


If you mean the external drive, I have it plugged in as I'm trying this. So it is there, but I think I'm misunderstanding you.


Well, running foobar as an administrator seems to solve the problem! Now my only question is if I can get Windows to do that automatically, since I can't do that from the shortcut that's pinned to the taskbar. If anyone could tell me how to do that, that'd be great, and thanks again guys. :3
Go to the top of the page
+Quote Post
Ouroboros
post May 13 2012, 00:39
Post #5





Group: Members
Posts: 291
Joined: 30-May 08
From: UK
Member No.: 53927



If it runs as Administrator then it's definitely a permissions problem.

Have you set permissions for the entire disk, or just looked at them? Also, have you checked for all groups? Try again, this time make a change, then change it back again. It should take a while as it goes through every file on the disk.....

This post has been edited by Ouroboros: May 13 2012, 00:40
Go to the top of the page
+Quote Post
maxson924
post May 13 2012, 01:26
Post #6





Group: Members
Posts: 3
Joined: 12-May 12
Member No.: 99769



Well, I've set the permissions, but oddly enough it now automatically opens as administrator, so... problem solved, I think? o_O
Go to the top of the page
+Quote Post
kode54
post May 13 2012, 02:24
Post #7





Group: Admin
Posts: 4618
Joined: 15-December 02
Member No.: 4082



Have you fixed the permissions from the Properties dialog for the entire partition? I don't know what I used to format it as such, but my large storage drive's default base permissions are Full control for Everyone.

Also, opening as Administrator by default only occurs if you check the administrator permission setting in the compatibility page of the executable's Properties dialog, or if you set it to a Windows 2003/XP or older OS version compatibility mode.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st September 2014 - 00:01