IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
foobar, audioengine d1 dac and wasapi
elik_r
post May 3 2012, 17:01
Post #1





Group: Members
Posts: 9
Joined: 15-May 09
Member No.: 69824



I've recently purchased the said DAC.

Sound quality is great, but there are stuttering issues with foobar. Apparently this is known from audioengine's perspective, and they've specifically stated in their manual that one should set the buffer setting to a minimum.

Unfortunately, this doesn't solve the problem, and I can get occasional glitches on random (and more when opening/closing programs and the like).

Is this issue going to be addressed? I've tested a trial copy of J River and had no glitches, which led me to believe that this might be a software problem. I've also tried out MusicBee, and it also suffers from this, although a bit less.

Is this something general about USB dacs? or is it limited to the audioengine D1 alone? Has anyone found a way around this?
Go to the top of the page
+Quote Post
Kohlrabi
post May 3 2012, 21:11
Post #2





Group: Super Moderator
Posts: 1024
Joined: 12-March 05
From: Kiel, Germany
Member No.: 20561



QUOTE (elik_r @ May 3 2012, 18:01) *
they've specifically stated in their manual that one should set the buffer setting to a minimum.

Unfortunately, this doesn't solve the problem, and I can get occasional glitches on random (and more when opening/closing programs and the like).

Are you absolutely sure that the recommendation is to decrease the buffer size? Dropouts and stutters can be normally avoided by increasing it. You might want to try the default DirectSound output engine, too.


--------------------
Ceterum censeo Masterdiskem esse delendam.
Go to the top of the page
+Quote Post
elik_r
post May 4 2012, 15:54
Post #3





Group: Members
Posts: 9
Joined: 15-May 09
Member No.: 69824



QUOTE (Kohlrabi @ May 3 2012, 22:11) *
QUOTE (elik_r @ May 3 2012, 18:01) *
they've specifically stated in their manual that one should set the buffer setting to a minimum.

Unfortunately, this doesn't solve the problem, and I can get occasional glitches on random (and more when opening/closing programs and the like).

Are you absolutely sure that the recommendation is to decrease the buffer size? Dropouts and stutters can be normally avoided by increasing it. You might want to try the default DirectSound output engine, too.


yep, this is from the D1 FAQ on audioengine's website (http://audioengineusa.com/about/audioengine-d1-faq):

I'm having trouble using my D1 with Foobar in WASAPI and KS mode. What do I do?

In the Foobar control panel, under Preferences->Output, set the buffer length to minimum. A few customers have mentioned that WASAPI mode is more stable when used under WinAmp, so try that as well.



Using direct sound wouldn't solve my problem since I want a bit perfect output (that's the reason to use wasapi in the first place).
Go to the top of the page
+Quote Post
Kohlrabi
post May 4 2012, 19:08
Post #4





Group: Super Moderator
Posts: 1024
Joined: 12-March 05
From: Kiel, Germany
Member No.: 20561



QUOTE (elik_r @ May 4 2012, 16:54) *
I'm having trouble using my D1 with Foobar in WASAPI and KS mode. What do I do?

I don't really know anything about that DAC, but is ASIO an option?

QUOTE (elik_r @ May 4 2012, 16:54) *
In the Foobar control panel, under Preferences->Output, set the buffer length to minimum. A few customers have mentioned that WASAPI mode is more stable when used under WinAmp, so try that as well.

Did you try increasing the buffer? The notion of having a short or no buffer to improve audio quality or whatever is an audiophile myth. The point of having a buffer is to actually defeat glitches and dropouts.

QUOTE (elik_r @ May 4 2012, 16:54) *
Using direct sound wouldn't solve my problem since I want a bit perfect output (that's the reason to use wasapi in the first place).

I understand, but please try it to help us confirm whether this is a WASAPI problem, a general foobar2000 problem, or a problem of your DAC.

This post has been edited by Kohlrabi: May 4 2012, 19:36


--------------------
Ceterum censeo Masterdiskem esse delendam.
Go to the top of the page
+Quote Post
elik_r
post May 5 2012, 09:04
Post #5





Group: Members
Posts: 9
Joined: 15-May 09
Member No.: 69824



Asio isn't an option, neither is kernel streaming - both exhibit the same problems.

Increasing the buffer prevents playback from working. I'd say that the more you increase the buffer, the worse it gets. And 1000ms is a threshold which when crossed - breaks playback altogether.

DS doesn't suffer from any problems for all I've noticed (apart from reduced sound quality).
Go to the top of the page
+Quote Post
Andreasvb
post May 5 2012, 11:03
Post #6





Group: Members
Posts: 1337
Joined: 6-March 04
From: Sweden
Member No.: 12509



QUOTE (elik_r @ May 5 2012, 10:04) *
Asio isn't an option, neither is kernel streaming - both exhibit the same problems.

Increasing the buffer prevents playback from working. I'd say that the more you increase the buffer, the worse it gets. And 1000ms is a threshold which when crossed - breaks playback altogether.

DS doesn't suffer from any problems for all I've noticed (apart from reduced sound quality).

There's no reduced sound quality, unless proven: http://www.hydrogenaudio.org/forums/index....974#entry149481


--------------------
Windows 8.1u1 Pro x64 Media Center // foobar2000 1.3.3
Go to the top of the page
+Quote Post
Kohlrabi
post May 5 2012, 14:41
Post #7





Group: Super Moderator
Posts: 1024
Joined: 12-March 05
From: Kiel, Germany
Member No.: 20561



QUOTE (elik_r @ May 5 2012, 10:04) *
Increasing the buffer prevents playback from working. I'd say that the more you increase the buffer, the worse it gets. And 1000ms is a threshold which when crossed - breaks playback altogether.

What are you referring to in your second sentence, how can it get worse than "not working"? Also, WASAPI output in foobar2000 works with buffer sizes of up to 2000ms. Sounds like the driver for your DAC is seriously broken, try to contact Audioengine about it. In the meantime you should stick to DirectSound output, since...
QUOTE (elik_r @ May 5 2012, 10:04) *
DS doesn't suffer from any problems for all I've noticed


This post has been edited by Kohlrabi: May 5 2012, 14:51


--------------------
Ceterum censeo Masterdiskem esse delendam.
Go to the top of the page
+Quote Post
drvandermurder
post May 10 2012, 05:04
Post #8





Group: Members
Posts: 1
Joined: 10-May 12
Member No.: 99676



I recently bought an Audioengine D1 (amazing little DAC btw) and suffered from the same clicking/popping issues when using WASAPI. In foobar2000, with the buffer set at 500ms, the audio cut in and out and was extremely crackly. Reducing the buffer helped a little, but it didn't solve the problem. Increasing it made the problem even worse, as elik stated.

Then I switched to Jriver media center, which fared much better. Using WASAPI-Event Style with the default buffer of 100ms, there was still occasional popping/clicking. As with foobar, increasing the buffer oddly led to more popping. Believe it or not, setting it at the minimum 10ms solved the problem. Still heard a few infrequent pops now and then; setting Jriver to high process priority (in task manager > processes) seems to have gotten rid of the rest of them. Haven't had a problem since. *fingers crossed*

As an aside I'd also highly recommend Jriver, after having used it for a couple weeks. Despite being feature-packed it's incredibly fast, much more so than iTunes, and much more user-friendly than foobar2000.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th August 2014 - 07:16