IPB

Welcome Guest ( Log In | Register )

> foobar2000 Development Forum Rules

This forum is for developer discussions only. If you have a problem / bug report / idea / feature request that isn't related to foobar2000 SDK, post it in an appropiate forum instead - tech support questions go to support forum, everything else goes to general forum.
All non-developer posts on this forum will be removed. Continued abuse of this forum will result in admin actions (warnings, account suspension).

DSP crossover, anomaly on start and song change
Ray_D
post Apr 28 2012, 03:43
Post #1





Group: Members
Posts: 5
Joined: 28-April 12
Member No.: 99269



Hi

I have written a digital crossover dsp for three way speakers using fourth order Linkwitz-Riley filters and a low shelf filter for boosting the bass.
The version with hard coded frequencies and gains (no preset) works perfectly and sounds great.
I subsequently wrote a version with a preset allowing for user input.
It works; but, there is a clunk sound for a fraction of a second on start up and when a song change is forced.
The frequency display also shows full bars for a short time.
No anomaly is heard when songs change naturally.
I would like to understand the function calls that happen at those times to help debug this issue.
I am also unfamiliar with .dll debugging techniques.

Thanks

Ray
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 27th November 2014 - 06:40