IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Album Artist tag misread as ALBUMARTIST (no space)
timalina
post Apr 27 2012, 17:09
Post #1





Group: Members
Posts: 9
Joined: 24-March 09
Member No.: 68320



Hi, I've been using the default interface for Foobar for a few years, but decided it was time to check out some skins. I set up a skin called Simply Foobar2000 in a portable installation, but I have noticed a strange idiosyncrasy: in the new installation, all the tags in the "Album Artist" (with a space) field seem to have moved to a new "ALBUMARTIST" (no space) field, and the "Album Artist" field is left empty.

I say "seem", because when I open up the standard installation, the tags are all in the correct place.

Here are a couple of screenshots of the same album under the different installation.

Old, standard installation:




New, portable installation:




Does anyone have any clues as to what might be going on here, and how to rectify it on the new installation? I don't want to have to re-tag tens of thousands of files, when there doesn't seem to be anything wrong with them in the first place.

Thanks!

This post has been edited by timalina: Apr 27 2012, 17:12
Go to the top of the page
+Quote Post
BenB
post Apr 27 2012, 18:03
Post #2





Group: Members
Posts: 776
Joined: 17-April 12
Member No.: 98921



I suspect that the tagging settings differ between your installations. Go to Preferences> Advanced> Tagging and see if the settings are identical between them. If not, change the portable installation's settings to match those of your standard installation, then restart(<necessary?) the portable to see if that fixes the tagging discrepancy.

This post has been edited by BenB: Apr 27 2012, 18:04
Go to the top of the page
+Quote Post
db1989
post Apr 28 2012, 01:22
Post #3





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



All this is is that the field that is literally named ALBUMARTIST is not configured to be displayed under the (presumably to you more eye-friendly) name of Album Artist. I think this is supposed to be done as standard, but in any case it should be trivial for you to put in place using the options in the location identified above.

Edit: Actually, I bet ALBUM ARTIST, i.e. with a space, would map as intended. Try it? The variant containing a space is default/recommended, anyway.

This post has been edited by db1989: Apr 28 2012, 01:24
Go to the top of the page
+Quote Post
timalina
post Apr 28 2012, 19:22
Post #4





Group: Members
Posts: 9
Joined: 24-March 09
Member No.: 68320



Thanks both of you. I took the advice, but couldn't see any differences in the set-ups. In the event I've just started a fresh installation as my main installation was running so slow as to be unusable. On my new installation, the album art field is working as I'd expect it to, so I'll just be careful to back up whenever I'm adding a new component. I'm pretty sure it must have been one of the components I chucked in that made the difference.

Thanks.
Go to the top of the page
+Quote Post
Kohlrabi
post Apr 28 2012, 20:02
Post #5





Group: Super Moderator
Posts: 1148
Joined: 12-March 05
From: Kiel, Germany
Member No.: 20561



QUOTE (db1989 @ Apr 28 2012, 02:22) *
The variant containing a space is default/recommended, anyway.

Not completely true, Peter has explicitly changed at least the writing of Vorbis and FLAC comments in 1.1.8 (your link is related to 1.1.6 changes) to write the Album Artist to the ALBUMARTIST field instead of ALBUM ARTIST, to improve compatibility with other software. Since this is the default way foobar2000 writes Album Artist tags now, I think the recommendation is to use ALBUMARTIST instead of ALBUM ARTIST, at least for Vorbis and FLAC.

This post has been edited by Kohlrabi: Apr 28 2012, 20:05


--------------------
It's only audiophile if it's inconvenient.
Go to the top of the page
+Quote Post
db1989
post Apr 28 2012, 20:27
Post #6





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



My mistake; thanks for the correction.
Go to the top of the page
+Quote Post
kode54
post Apr 28 2012, 20:34
Post #7





Group: Admin
Posts: 4689
Joined: 15-December 02
Member No.: 4082



foobar2000 writes either field to Vorbis/FLAC/Speex files as "ALBUMARTIST" or "ALBUM ARTIST" depending on the configuration setting, but reads both back as "ALBUM ARTIST".
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th December 2014 - 19:34