IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

Full tag info not refreshing, even after "reload info from file(s
Chinch
post Mar 27 2012, 12:40
Post #1





Group: Members
Posts: 98
Joined: 22-July 09
Member No.: 71664



I am not sure whether this is a bug, or just a misunderstanding on my part, but it is a simple enough issue to describe and recreate:

If I have a file or album loaded in a playlist... say I select all 10 tracks on this album, and then embed the Front Cover album art into the said tag...

Using Columns UI, I have it showing a thumbnail of the album art next to each grouping of files (put into order by something natural, say... %album artist% %artist% %album% %discnumber% %tracknumber%

That's just for example, but similar to how an "album" would be made to group together.

Regardless of that, though... even if it is a single file, ungrouped, in either circumstance --

If I embed the Front Cover art using foobar2000... it of course doesn't show the album art (as expected)... but then I even go to the "Reload info from file(s)", which I was under the impression that this function basically re-read all of the tag info, etc... and updated the display elements accordingly (did something like a forced refresh on the display of those data fields...


But I can't get it to show the album or track's cover art, even after reloading the info from the file. The ONLY way that I can get it to show the embedded Front Cover is to remove the file from the playback/playlist queue, and re-add it freshly. Am I mistaken in thinking that the "Reload info..." should make it show the newly embedded cover art? If I am, is there any easier or quicker way to force it to re-read the embedded cover art and get it to update in the Columns UI display, showing a cover where there was previously none... other than the solution just mentioned (a full remove/re-add to queue)?


Or is the issue possibly that it only reloads the tag info that EXISTED PREVIOUSLY, e.g. when the file was first loaded into the queue? Therefore, now that I added a brand new tag that didn't exist at that point, it's only reloading the original tag info, and not any newly added ones?

Don't mean to be so repetative and elementary... I just want to make sure I am explaining my viewpoint of what is or isn't going on, and then if I need to be corrected in my understanding of something, then you can pinpoint exactly where I'm failing in my assumptions...

Thank you! It's just something that I have been "working around" for a long time, and I want to find out what I am possibly doing wrong and how to best accomplish the refresh!
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th December 2014 - 08:40