IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
How can i PREFER ID3v2 to ID3v1 ?!
Kshatriya
post Mar 12 2012, 03:29
Post #1





Group: Members
Posts: 4
Joined: 12-March 12
Member No.: 97719



Got mp3 with Jap tags ID3v1 and ID3v2, ID3v1 unreadable but fb2k PREFER THEM. mad.gif

How can i prefer ID3v2 tag, without updating file *important!* ?!

Already spent 2 hours but can't find the answer

This post has been edited by Kshatriya: Mar 12 2012, 03:31
Go to the top of the page
+Quote Post
A_Man_Eating_Duc...
post Mar 12 2012, 05:48
Post #2





Group: Members
Posts: 940
Joined: 21-December 01
From: New Zealand
Member No.: 705



Foobar2000 Preferences > Advanced > Expand Tagging > Expand MP3


--------------------
Who are you and how did you get in here ?
I'm a locksmith, I'm a locksmith.
Go to the top of the page
+Quote Post
kode54
post Mar 12 2012, 09:46
Post #3





Group: Admin
Posts: 4664
Joined: 15-December 02
Member No.: 4082



That's for tag writing. I think the problem here is with foobar2000 preferring ID3v1 tag values over ID3v2 when reading, which usually only happens on longer values, not equal or lesser length. Although, technically, it should probably prefer ID3v2 outright.
Go to the top of the page
+Quote Post
Kshatriya
post Mar 12 2012, 16:05
Post #4





Group: Members
Posts: 4
Joined: 12-March 12
Member No.: 97719



Any idea how to fix this?
Go to the top of the page
+Quote Post
Hengest
post Mar 13 2012, 13:33
Post #5





Group: Members
Posts: 133
Joined: 27-April 06
From: Perth, WA
Member No.: 30103



In foobar2000, Select the affected files, right-click, goto 'tagging' -> 'mp3 tag types..." Untick id3v1.

Edit: Just to make sure you know, this method will remove the id3v1 tags. So make sure that any files you do modify have either id3v2 or ape selected so you don't completely lose your tags!

This post has been edited by Hengest: Mar 13 2012, 13:38


--------------------
"Lifting Shadows Off a Dream"
Go to the top of the page
+Quote Post
frogworth
post Mar 13 2012, 13:59
Post #6





Group: Members
Posts: 176
Joined: 30-December 09
Member No.: 76511



I think any solution will involve removing the ID3 tags.
Another solution is to open the properties for the mp3, select all and copy (do for multiple mp3s at once if you like).
Then right-click on the track(s), select Tagging -> Remove tags from files. This will remove all tags including, of course, the corrupted/useless id3v1 tags.
Then edit the properties and paste back in your copied tags. This will write in your preferred tagging format - which you will have set via one of the suggestions above smile.gif
Go to the top of the page
+Quote Post
Kshatriya
post Mar 13 2012, 18:41
Post #7





Group: Members
Posts: 4
Joined: 12-March 12
Member No.: 97719



QUOTE (Kshatriya @ Mar 12 2012, 07:29) *
without updating file *important!* ?!


So thats foobar crappy BUG

This post has been edited by Kshatriya: Mar 13 2012, 18:48
Go to the top of the page
+Quote Post
Ouroboros
post Mar 13 2012, 19:27
Post #8





Group: Members
Posts: 291
Joined: 30-May 08
From: UK
Member No.: 53927



It's free. Stop complaining, and fix your "crappy" tags, then the problem will go away.
Go to the top of the page
+Quote Post
Kshatriya
post Mar 13 2012, 23:33
Post #9





Group: Members
Posts: 4
Joined: 12-March 12
Member No.: 97719



rly?

AIMP free too, but has no any problem with it, and that angry me even more cause i love foobar
Go to the top of the page
+Quote Post
db1989
post Mar 14 2012, 00:31
Post #10





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



What other applications do confers no obligation upon foobar2000. In any case, if you have a feature request (i.e. a suggested alteration to an intended behaviour), you are not helping your chances of being considered by phrasing your opinion in such an offhand and rude way, rather than filing your request formally and in a polite manner.

Which could be a shame, because an option to prefer a certain type of tag always (not only when it is larger) or at least to consistently prefer v2 (as kode54 says should occur) is a fair idea.
Go to the top of the page
+Quote Post
shakey_snake
post Mar 14 2012, 05:27
Post #11





Group: FB2K Moderator
Posts: 4322
Joined: 1-November 06
From: Cincinnati
Member No.: 37036



Preferring the longest tag values when tags do not match is a feature, not a bug. It keeps regular users from having to deal with truncated tag values.

In cases where you are storing latin tags in one tag type and kanji tags in another, the solution is to STOP DOING THAT. That is simply not what the different tag types are designed to do, and using them as such is poor practice. You could easily store your Latin based fields in user defined id3v2 fields named artist_LN, album_LN, title_LN so on and so forth.

This post has been edited by shakey_snake: Mar 14 2012, 05:28


--------------------
elevatorladylevitateme
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th November 2014 - 01:36