IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
DVD-Audio discs glitch audibly—only since I upgraded CPU and added RAM, Was: Strange DVD-Audio Decoder behavior (TOS #6)
markshan
post Feb 23 2012, 04:45
Post #1





Group: Members
Posts: 17
Joined: 16-March 10
Member No.: 79046



Hello all. I recently made some changes to my computer. I added a better video card, I upgraded my processor and I added RAM. Before I did all of this, DVD_Audio discs played back with no problem. Now, they glitch audibly. I thought perhaps it was an issue with the video card having HDMI, so I disabled the "AMD high definition audio device" in hardware manager and restarted. This didn't help. So I updated thje the latest satble version of both Foobar and the plug. This didn't help.

Out of curiosity, I used Foobar "convert" to save the file to my hard drive at 24/96. This played back flawlessly. Any ideas? Thanks.
Go to the top of the page
+Quote Post
markshan
post Feb 26 2012, 01:23
Post #2





Group: Members
Posts: 17
Joined: 16-March 10
Member No.: 79046



Anyone?

BTW, I think that the video card drivers are also a possible culprit, but that would have involved putting the entire post in the title line.
Go to the top of the page
+Quote Post
kode54
post Feb 26 2012, 03:37
Post #3





Group: Admin
Posts: 4693
Joined: 15-December 02
Member No.: 4082



Maybe your computer can no longer read them back in real-time. Try running the Decoding Speed Benchmark to see if they play back at least 1x real-time.
Go to the top of the page
+Quote Post
markshan
post Feb 27 2012, 06:33
Post #4





Group: Members
Posts: 17
Joined: 16-March 10
Member No.: 79046



Thanks. I will check this out.
Go to the top of the page
+Quote Post
markshan
post Feb 27 2012, 06:41
Post #5





Group: Members
Posts: 17
Joined: 16-March 10
Member No.: 79046



Here is the result of one track from the 24/96 stereo portion of the disc...

Settings:
Buffer entire file into memory: no
High priority: no
Passes: 1
File: D:\AUDIO_TS\AUDIO_TS.IFO
Run 1:
Length: 3:08.967
Opening time: 0:00.018
Decoding time: 0:07.789
Speed (x realtime): 24.261
Total:
Length: 3:08.967
Opening time: 0:00.018
Decoding time: 0:07.789
Speed (x realtime): 24.261

Unless I misunderstand something here, it doesn't look like the read speed is the issue.

I wish I had a list of which audio codecs install with the HDMI card. I still suspect some incompatibility there.

I truly appreciate the assistance.
Go to the top of the page
+Quote Post
markshan
post Feb 27 2012, 06:44
Post #6





Group: Members
Posts: 17
Joined: 16-March 10
Member No.: 79046



I just noticed something else that may help in finding the issue.

Once I scanned that first track, it played back the next time without issue. I played 15 seconds of the second track and it glitched like crazy. I stopped the track and restarted, and it didn't start glitching until 16 seconds in.
Go to the top of the page
+Quote Post
DDRRE
post Feb 27 2012, 08:16
Post #7





Group: Members
Posts: 22
Joined: 11-March 07
Member No.: 41385



QUOTE (markshan @ Feb 27 2012, 07:44) *
I just noticed something else that may help in finding the issue.

Once I scanned that first track, it played back the next time without issue. I played 15 seconds of the second track and it glitched like crazy. I stopped the track and restarted, and it didn't start glitching until 16 seconds in.


Which output driver are you using? DirectSound/WASAPI/KS/ASIO?

I had glitchy issues after a while of playback - but I don't remember what it was that fixed it. Try playing around with the DSPs you have enabled, the output buffer size, the sound card driver, and the sound card's sampling rate/bit-depth settings under Control Panel-Sound-Playback.

Reading your reply - it would seem that this is an I/O issue - the first 15 seconds were probably cached. You should prefer to rip all your discs and play them locally as a general rule of thumb. As to solving the current issue - take a look at the BIOS settings and play around. You could also try switching a SATA port, which would make the OS reinstall the drive's driver.

This post has been edited by DDRRE: Feb 27 2012, 08:19
Go to the top of the page
+Quote Post
markshan
post Feb 27 2012, 15:02
Post #8





Group: Members
Posts: 17
Joined: 16-March 10
Member No.: 79046



Good thoughts. I am using ASIO with an E-Mu 1212 sound card. I use this machine to do needledrops, so I spent some time getting everything how I wanted it. The thought of doing all of that over is less than appealing. But then, so is the thought of ripping all my discs and playing them locally. It is a sad surprise that making changes to improve the computer's performance have actually made it worse (at least in this way).

I was so hoping that I would post this and get an answer like "ATI's codec x is known to be incompatible". I'll keep digging.
Go to the top of the page
+Quote Post
DDRRE
post Feb 27 2012, 15:04
Post #9





Group: Members
Posts: 22
Joined: 11-March 07
Member No.: 41385



QUOTE (markshan @ Feb 27 2012, 16:02) *
Good thoughts. I am using ASIO with an E-Mu 1212 sound card. I use this machine to do needledrops, so I spent some time getting everything how I wanted it. The thought of doing all of that over is less than appealing. But then, so is the thought of ripping all my discs and playing them locally. It is a sad surprise that making changes to improve the computer's performance have actually made it worse (at least in this way).

I was so hoping that I would post this and get an answer like "ATI's codec x is known to be incompatible". I'll keep digging.


Try increasing the ASIO latency and playing with the buffer size. You can also try to see if this reproduces on DirectSound / WASAPI.
Go to the top of the page
+Quote Post
markshan
post Mar 2 2012, 04:37
Post #10





Group: Members
Posts: 17
Joined: 16-March 10
Member No.: 79046



Are there any known incompatibilities between K-Lite codec pack and Foobar? I didn't think to mention I had recently installed it as well.
Go to the top of the page
+Quote Post
markshan
post Mar 2 2012, 04:46
Post #11





Group: Members
Posts: 17
Joined: 16-March 10
Member No.: 79046



It just dawned on me that I hadn't played an audio CD since all of this started. I tried one and it glitched as well. Even more strange, when it glitched it also changed the playback speed and pitch. Is there some Foobar setting that controls clock speed? Again, no issues with files from the hard drive, but now I am finding that it won't play any optical media correctly.
Go to the top of the page
+Quote Post
Rollin
post Mar 2 2012, 14:12
Post #12





Group: Members
Posts: 196
Joined: 5-March 08
Member No.: 51815



QUOTE (markshan @ Mar 2 2012, 07:46) *
it won't play any optical media correctly.


Try to increase output buffer size in foobar.
Go to the top of the page
+Quote Post
markshan
post Mar 3 2012, 05:20
Post #13





Group: Members
Posts: 17
Joined: 16-March 10
Member No.: 79046



I did that. It didn't make any difference.
Go to the top of the page
+Quote Post
DDRRE
post Mar 4 2012, 14:15
Post #14





Group: Members
Posts: 22
Joined: 11-March 07
Member No.: 41385



QUOTE (markshan @ Mar 2 2012, 05:46) *
It just dawned on me that I hadn't played an audio CD since all of this started. I tried one and it glitched as well. Even more strange, when it glitched it also changed the playback speed and pitch. Is there some Foobar setting that controls clock speed? Again, no issues with files from the hard drive, but now I am finding that it won't play any optical media correctly.


See if this happens with other media players as well. And if you haven't already, use DirectSound.

If this reproduces with other media players, try changing the interface port for the drive, updating its firmware, and changing its I/O settings (DMA mode, 32bit transfers etc.).
Go to the top of the page
+Quote Post
markshan
post Mar 5 2012, 03:25
Post #15





Group: Members
Posts: 17
Joined: 16-March 10
Member No.: 79046



Not other players, but now it is happening with YouTube videos. Very strange, but it no longer seems to be a Foobar problem. Sorry to have put the blame where it doesn't seem to belong.

I actually think I am going to wipe my computer and start over. I have a system that will work nicely with 64 bit 7. I am going to rebuild with a video card without HDMI and I am not installing KLite this time. I think one of those two things is not getting along with my E-Mu 1212. If the behavior continues after all of this, I'll have to start looking for another card (I hope not, this one sounds amazing when it is working properly).

This card requires ASIO, and I can't figure out where buffer settings are. I think the card makes them automatically.

This post has been edited by markshan: Mar 5 2012, 03:26
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 26th December 2014 - 14:14