IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

Foobar 1.1.11, WASAPI and playback of files with different samplerates, [fixed in beta 3 of plugin: hydrogenaudio.org/forums/?showtopic=94907]
radiator27
post Feb 13 2012, 17:17
Post #1





Group: Members
Posts: 2
Joined: 13-February 12
Member No.: 97134



Hi

I'm using the latest WASAPI output plugin, ATI Radeon HD 5750 HDMI to Denon 1911 Receiver (computer is running Windows 7 Home Premium, 64 bit)

With foobar version 1.1.11 there is no playback when switching to a flac-file with a different samplerate than the previous - e.g. playing a 44.1 kHz flac and selecting a 96 kHz flac. I have to click on the new file several times before the new file will play.
If i use the Direct Sound output the problem goes away. And if I downgrade to foobar version 1.1.10 the problem also goes away, so i suspect that foobar version 1.1.11 does not report a proper output format every time a new file is selected. Maybe this is related to the new cross-fade functionality, that somehow breaks WASAPI output samplerate change?

My solution so far is to stay with version 1.1.10, but I hope that this can be fixed in a future version. :-)
Go to the top of the page
+Quote Post
 
Start new topic
Replies
Kohlrabi
post Mar 27 2012, 08:35
Post #2





Group: Super Moderator
Posts: 1087
Joined: 12-March 05
From: Kiel, Germany
Member No.: 20561



In the meantime, try ASIO if you need to feed bit-perfect data to your external receivers or decoders. If not, just stick to DirectSound. Volume control works nowadays even with the broken ASUS drivers.

This post has been edited by Kohlrabi: Mar 27 2012, 08:35


--------------------
It's only audiophile if it's inconvenient.
Go to the top of the page
+Quote Post

Posts in this topic
- radiator27   Foobar 1.1.11, WASAPI and playback of files with different samplerates   Feb 13 2012, 17:17
- - kode54   Cross fading is specific to DirectSound output.   Feb 13 2012, 17:31
- - bacondither   I have the same problem with version 1.1.11 and WA...   Feb 13 2012, 22:13
- - Jackal29a   I thought neither of my Xonar cards (ST & D2X,...   Feb 14 2012, 21:53
- - WarZard-X   I have exactly the same problem with 1.1.11 and WA...   Feb 18 2012, 19:21
- - WarZard-X   Does no one else have this problem with Wasapi ...   Feb 22 2012, 17:53
- - blindpainkiller   I have the same problem. Also, I more often than n...   Feb 22 2012, 19:43
- - gfh   Confirm. AMD Radeon 6950 HDMI to Denon 1912 Receiv...   Mar 16 2012, 14:19
- - Sandrine   1.1.12 beta1 is out, all testers to the fore   Mar 25 2012, 11:38
- - radiator27   Unfortunately version 1.1.12 beta 2 does not solve...   Mar 26 2012, 08:55
- - Sandrine   You should report this, it's not assured that ...   Mar 26 2012, 19:50
- - Mr.Ferrari   Same problem here with both 1.11 & 1.12beta + ...   Mar 27 2012, 06:07
- - Kohlrabi   In the meantime, try ASIO if you need to feed bit-...   Mar 27 2012, 08:35
|- - Mr.Ferrari   QUOTE (Kohlrabi @ Mar 27 2012, 09:35) In ...   Mar 27 2012, 16:21
|- - Dakeryas   Same problem here on an Audinst HUD USB Dac. I alw...   Mar 27 2012, 17:41
- - Mr.Ferrari   Could any developer please say something. So we kn...   Mar 30 2012, 15:54
- - WarZard-X   Will this ever be fixed?   Apr 30 2012, 10:32
- - Peter   Problem acknowledged, thanks for reporting. Unfort...   Apr 30 2012, 12:19
- - MaCs   I don't think it is WASAPI-related. I have exa...   May 11 2012, 13:32
- - bsw11   I have the same or similar problem switching betwe...   May 12 2012, 01:05
|- - db1989   QUOTE (bsw11 @ May 12 2012, 01:05) This r...   May 12 2012, 08:36
- - bsw11   QUOTE (db1989 @ May 12 2012, 00:36) QUOTE...   May 12 2012, 18:13
- - WarZard-X   Finally it's fixed with Wasapi Plugin 3.0 beta...   May 13 2012, 18:03


Closed TopicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st November 2014 - 12:10