IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Behavior of Albumartist/Album Artist Tags for Vorbis, The "Metadata writing mode" option does not seem to work(?)
Kwazulu
post Dec 11 2011, 19:19
Post #1





Group: Members
Posts: 18
Joined: 11-December 11
Member No.: 95744



Today, after upgrading from 1.1.7 to 1.1.10, I found that Foobar's treatment of ALBUMARTIST and ALBUM ARTIST had changed. When I entered something in the field ALBUMARTIST, it would be written to ALBUM ARTIST instead. I believe this is an intentional change, and the Foobar changelog confirmed that changes had been made to how tagging was handled. Fortunately, I found what appeared to be an option to restore the old behavior in the Advanced section under Tagging > Vorbis & FLAC > Metadata Writing Mode.

The two options there are:
"More compatible with various software - ALBUMARTIST, TRACKTOTAL, DISCTOTAL"
"Compatible with old foobar2000 versions - ALBUM ARTIST, TOTALTRACKS, TOTALDISCS"


At this point I became a bit confused. The one which was selected was the first option, suggesting that it should already be allowing me to write ALBUMARTIST. And as it turns out, changing the setting does not change the behavior as I expected it to. Am I misunderstanding what these options are for? I also tried, out on a limb, turning off Map TPE2 to Album Artist under ID3v2 revision and quirks which unsurprisingly didn't change anything (all my files are vorbis).

Are these options bugged or am I misinterpreting their purpose? And if they actually are not for the purpose I thought they were for, is there any way for me to write ALBUMARTIST in Foobar again without downgrading?

Please note, I'm not seeking an explanation for the change of defaults. I'm sure there are good reasons many people prefer the version with the space. But they do not apply to me, so I'm looking for a way to continue writing my tags with the fields I specify, as written, without being remapped to something else. I hope it's still possible! Thanks in advance for any help you guys can offer. I've found lots of great information on these message boards over the years but I never needed to register until now since it didn't seem my question had been asked before.
Go to the top of the page
+Quote Post
lvqcl
post Dec 11 2011, 20:33
Post #2





Group: Developer
Posts: 3358
Joined: 2-December 07
Member No.: 49183



foobar2000 writes ALBUMARTIST tag to .ogg file. And it writes TPE2 tag to .mp3 file. But the corresponding metadata field name is "Album Artist".
Go to the top of the page
+Quote Post
Kwazulu
post Dec 11 2011, 21:14
Post #3





Group: Members
Posts: 18
Joined: 11-December 11
Member No.: 95744



QUOTE (lvqcl @ Dec 11 2011, 14:33) *
foobar2000 writes ALBUMARTIST tag to .ogg file. And it writes TPE2 tag to .mp3 file. But the corresponding metadata field name is "Album Artist".


By default there are "display versions" of the fields which sometimes differ from the actual field name. Is this what you mean? I have my own set of fields in "Standard Fields" under the Properties dialog settings. What I'm trying to describe is not a cosmetic difference -- the vorbis tags written from 1.1.8 on automatically convert ALBUMARTIST to ALBUM ARTIST.

But as I've investigated it further, it does seem to be more complex than just that:

If I edit a tag in 1.1.7 and add "ALBUMARTIST", it shows up as such in the properties dialog thereafter and can be accessed with %albumartist% in formatting scripts. If I view that file in a non-Foobar tag editor, it appears as expected: one ALBUMARTIST tag and that's it. This is expected behavior, right?

If I do the same in 1.1.10, immediately after hitting "apply," the ALBUMARTIST field that I had just typed in becomes blank and instead an <ALBUM ARTIST> field is added. Scripts trying to access %albumartist% turn up a '?' instead, because there no longer is an ALBUMARTIST field. But oddly, if I check that file in a non-Foobar tag editor, what I see is inconsistent with this: it shows that there are both ALBUMARTIST and ALBUM ARTIST tags. Even more oddly, if I then delete the ALBUM ARTIST tag and reload in Foobar, Foobar continues to display exactly the same thing (that is, ALBUM ARTIST but not ALBUMARTIST). The only way to restore the correct tag at that point is to go back to Foobar 1.1.7 and edit it.
Go to the top of the page
+Quote Post
kode54
post Dec 12 2011, 00:07
Post #4





Group: Admin
Posts: 4608
Joined: 15-December 02
Member No.: 4082



The foobar2000 internal field name is %album artist% to maintain backwards compatibility with existing scripts. The correct fields are silently written to the respective files.
Go to the top of the page
+Quote Post
Kwazulu
post Dec 12 2011, 00:41
Post #5





Group: Members
Posts: 18
Joined: 11-December 11
Member No.: 95744



QUOTE (kode54 @ Dec 11 2011, 18:07) *
The foobar2000 internal field name is %album artist% to maintain backwards compatibility with existing scripts. The correct fields are silently written to the respective files.


This explanation doesn't seem to match with what I've seen, though perhaps I'm failing to understand how internal field names work. Can you explain in more detail?

Note that previous versions of Foobar wrote only ALBUMARTIST when I added an ALBUMARTIST field. 1.1.10 is writing both ALBUMARTIST and ALBUM ARTIST, but mysteriously, even though I know it's writing to both fields (as it can be confirmed by viewing the files in other software afterwards), inside Foobar, the Properties dialogue shows ALBUMARTIST as blank and %albumartist% returns "?". Note that files which were tagged in old versions of Foobar do not exhibit this behavior -- the problem is only occurring when a tag is written by 1.1.10, whereas untouched files continue to display ALBUMARTIST the same way in the Properties dialogue and function correctly in scripts that use %albumartist%. That seems to suggest (to this layperson, anyway) that this isn't just about silent mapping; wouldn't that internal remapping be something that occurs regardless of whether the tag was written by 1.1.10? Also, it wouldn't explain why I get an ALBUM ARTIST field showing up in other tag editors which wasn't present until I tried to write ALBUMARTIST in Foobar.
Go to the top of the page
+Quote Post
shakey_snake
post Dec 12 2011, 02:30
Post #6





Group: FB2K Moderator
Posts: 4322
Joined: 1-November 06
From: Cincinnati
Member No.: 37036



fb2k's "internal field names" are the same for all formats you could encounter. So, if you have some files that are mp3, some that are OGG vorbis, some that are FLAC, some that are WMA-- ALBUM ARTIST, the "internal field name", refers to all fields that someone would reasonably expect to find the field that corresponds to the artist of the entire album when different to the artist of the specific track, across all formats. This "internal field name" is understandably different than a formats specific tag name, as those format specific tag names vary across different tag types, formats, and perhaps even by tag version.

Now specifically With the format OGG Vorbis, pre-1.1.8 versions of fb2k expected that value in one place, other software expects it in another. So, for maximum compatibility, fb2K 1.1.8 and later writes that value to both places that where other software looks for it. If you are concerned with specifics about what software looks where, you should consult a dedicated tagging software. If you just want things to work, then just use foobar2000 and don't worry about it. smile.gif

This post has been edited by shakey_snake: Dec 12 2011, 15:27
Reason for edit: There was me talking out my ass again >_>


--------------------
elevatorladylevitateme
Go to the top of the page
+Quote Post
Kwazulu
post Dec 12 2011, 03:14
Post #7





Group: Members
Posts: 18
Joined: 11-December 11
Member No.: 95744



Thanks for the information. That's exactly what I thought internal field name meant, but having it confirmed is helpful. Unfortunately this fact on its own doesn't seem to explain the behavior I've described unless I'm missing some critical detail. My explanation of the behavior is kind of wordy and confusing and I think I may be failing to convey what the problem is correctly :/ Yes, on one hand there is the fact that I personally wish Foobar to only write ALBUMARTIST and to not write ALBUM ARTIST at all -- and I know this is a deliberate change, though I was hoping there was a way to toggle the behavior off. But the more pressing part of this is that when I do write a tag with 1.1.8+, it isn't merely writing an extra field that I don't want; it's making the other field completely inaccessible. %albumartist% still works on all files with an ALBUMARTIST field except those written by 1.1.8+. Like you said, Foobar is writing to both fields. But once it has done so, for some reason it's no longer able to "see" ALBUMARTIST at all and that field is displayed as empty by both the Properties dialogue and the formatting script. In my initial post I didn't yet realize it was successfully writing ALBUMARTIST; the real problem is that it isn't seeing ALBUMARTIST after it's been written. It isn't something likely to affect a lot of other users, but it does appear to be a bug rather than intended behavior.

(I know it's not an urgent concern to anyone but me, and in any case I'm content to stick with 1.1.7 for now, but I figured it's worth a try to investigate it here.)

I'm still curious though what Metadata Writing Mode is supposed to do since it has no effect on this but looked a lot like it was supposed to.

Thanks again.

This post has been edited by db1989: Dec 12 2011, 15:15
Reason for edit: removing unnecessary full quote of above post
Go to the top of the page
+Quote Post
kode54
post Dec 12 2011, 03:38
Post #8





Group: Admin
Posts: 4608
Joined: 15-December 02
Member No.: 4082



It is seeing both fields and preferring ALBUMARTIST over ALBUM ARTIST. Unless you have some reason for wanting to write different values to each field, then this should be just fine.

EDIT: I just added "Album Artist" to an Ogg Vorbis file using the default settings, and it was written as ALBUMARTIST, not both fields.
Go to the top of the page
+Quote Post
Kwazulu
post Dec 12 2011, 03:58
Post #9





Group: Members
Posts: 18
Joined: 11-December 11
Member No.: 95744



Thanks for testing. Apparently something is actually wrong with my installation. It's silly, but it hadn't occurred to me to test that earlier since the problem didn't begin until I upgraded this morning. I just created a fresh portable install to confirm what you said and indeed, everything worked exactly as expected. I don't know what the deal is with my original install -- I didn't have many plug-ins, just Columns_UI and the Columns UI album list I think, which I thought were pretty safe -- but something about it must have gotten botched somewhere in the course of the last year or perhaps during the upgrade, since I am still able to reproduce the aberrant results. In any case, I now have a solution I am very happy with, even though it means I'm going to have to migrate all my settings over. Thanks very much!

This post has been edited by db1989: Dec 12 2011, 15:16
Reason for edit: ditto
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2014 - 09:26