IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Creative Zen won’t load Nero AAC files to internal memory (any method), Was “NeroAAC encoded files in Zen internal memory”
grums
post Dec 2 2011, 10:50
Post #1





Group: Members
Posts: 10
Joined: 8-March 11
Member No.: 88810



I'm not sure if this should be posted in the AAC forum, but here goes:

My Creative ZEN (3 years old, newest firmware) refuses to load AAC files to its internal memory (using either Windows or ZEN Explorer).
They are encoded with Nero AAC newest version and have file type M4A.
They play OK from the SD card.
I can see in the forums that there has been problems in this area before, but I'm not sure what the status is.

Creative support states that it will accept 'iTunes Plus' files - how do I make mine look like that?
Is it just a question of adding some tags, or is it more involved?
Can somebody please provide a short AAC clip which is known to play from the internal memory on a ZEN?

Regards, Ole
Go to the top of the page
+Quote Post
db1989
post Dec 2 2011, 12:38
Post #2





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Whilst I use a ZEN X-Fi Style (‘it does the job… just’), I haven’t heard anything about other models or this problem. However, I thought I’d post the following, just in case.

QUOTE (grums @ Dec 2 2011, 09:50) *
Creative support states that it will accept 'iTunes Plus' files - how do I make mine look like that?
Is it just a question of adding some tags, or is it more involved?
That may just be advertising to tie in with the popularity of iTunes, rather than any prescription for compatible files. But for the sake of reference, certain hardware—although I’m not aware of anything by Creative having been implicated—does require an otherwise inconsequential cosmetic hack to play AAC/MP4: ‘Guide: hack neroAacEnc to make files play on “iTunes encoded only” h/w
Go to the top of the page
+Quote Post
grums
post Dec 3 2011, 20:33
Post #3





Group: Members
Posts: 10
Joined: 8-March 11
Member No.: 88810



Thank you - I patched the AAC-file instead (as described in the thread you mention), but no success - it still refuses to transfer the file using Creative Explorer or Windows Explorer (also when I try to be sneaky: copy the file to the iTunes folder in the Creative Explorer tree and try to sync).

The funny thing is that the ZEN will play the AAC-files from the SD card!
It seems like a Media synchronization policy problem or whatever...

Anybody out there owning a plain old ZEN which can play AAC-files from the unit's internal memory?
A small sample file would be of great help!
Go to the top of the page
+Quote Post
saratoga
post Dec 4 2011, 00:32
Post #4





Group: Members
Posts: 5169
Joined: 2-September 02
Member No.: 3264



Can you put the player into MSC mode? MTP can be weird about file types.
Go to the top of the page
+Quote Post
Remedial Sound
post Dec 4 2011, 05:20
Post #5





Group: Members
Posts: 508
Joined: 5-January 06
From: Dublin
Member No.: 26898



QUOTE (saratoga @ Dec 3 2011, 18:32) *
Can you put the player into MSC mode? MTP can be weird about file types.


AFAIK all Creative players work only with MTP. I found this out the hard way when I bought a Zen a few years back.
Go to the top of the page
+Quote Post
saratoga
post Dec 4 2011, 06:16
Post #6





Group: Members
Posts: 5169
Joined: 2-September 02
Member No.: 3264



QUOTE (Remedial Sound @ Dec 4 2011, 00:20) *
QUOTE (saratoga @ Dec 3 2011, 18:32) *
Can you put the player into MSC mode? MTP can be weird about file types.


AFAIK all Creative players work only with MTP. I found this out the hard way when I bought a Zen a few years back.


http://support.creative.com/kb/ShowArticle.aspx?sid=83635

If its really a plain zen, its MTP only, but lots of the zen series can do MSC.
Go to the top of the page
+Quote Post
Remedial Sound
post Dec 4 2011, 06:36
Post #7





Group: Members
Posts: 508
Joined: 5-January 06
From: Dublin
Member No.: 26898



True, but there are quite are number of ZEN models that are MTP-only in that table. And their policy on making some players MSC and others not (while being quite well capable of designing all of them to operate as either) is totally arbitrary.
Go to the top of the page
+Quote Post
grums
post Dec 6 2011, 14:28
Post #8





Group: Members
Posts: 10
Joined: 8-March 11
Member No.: 88810



Thanks all - my ZEN is MTP only on internal memory and MSC on the external SDHC card.
Internally it will transfer+play MP3 and WMA and has a database.
Externally it will play MP3, WMA, AAC - but has no database, only a browser.

Wish Rockbox could have been ported to it...

Anyone who can provide a shot clip of AAC which will transfer to+play from the internal memory of a ZEN (classic)?
Go to the top of the page
+Quote Post
filou85
post Dec 6 2011, 17:07
Post #9





Group: Members
Posts: 6
Joined: 6-August 10
Member No.: 82876



I have a Zen (4GB + 16 GB SDHC card). As far as I recall, I never have problem to transfer some acc music (in a m4a contener) encoded by nero on my Zen.

This evening, I will try to transfert some nero encoded aac music in it with Windows and Zen Explorer.
You can try to transfer your music by using Winamp or maybe Songbird.

I assumed the last nero aac encoder is the 1.5.4.0.
My Zen firmware version is 1.21.03e.

This post has been edited by filou85: Dec 6 2011, 17:10
Go to the top of the page
+Quote Post
filou85
post Dec 6 2011, 20:23
Post #10





Group: Members
Posts: 6
Joined: 6-August 10
Member No.: 82876



I just transfert (via MTP) some files encoded with Nero aac encoder v1.5.4.0 and all files play well.
I encode them twice. The first time from wav files by using a command line (no tag) and the second time from Flac with CUETOOLS (with tags). The tags were displayed as they should.

I will post a test file when I find how I can do.

This post has been edited by filou85: Dec 6 2011, 20:27
Go to the top of the page
+Quote Post
db1989
post Dec 6 2011, 21:50
Post #11





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



QUOTE (filou85 @ Dec 6 2011, 19:23) *
I will post a test file when I find how I can do.
http://www.hydrogenaudio.org/forums/index.php?showforum=35
Go to the top of the page
+Quote Post
grums
post Dec 7 2011, 20:20
Post #12





Group: Members
Posts: 10
Joined: 8-March 11
Member No.: 88810



Nero aac encoder is 1.5.4.0.
Zen firmware version is 1.21.03, 1.21.01 also fails.
Winamp has same problem - can't load the file.

Maybe it's a fault on my Windows system (XP SP3) ?

Looking forward to trying your file, filou85...
Go to the top of the page
+Quote Post
filou85
post Dec 8 2011, 22:29
Post #13





Group: Members
Posts: 6
Joined: 6-August 10
Member No.: 82876



I post the test file in this thread

I use Windows 7 (64bits) to transfert file. I test XP with a virtual machine but it doesn't work. The file is copied on my Zen but cannot be played by it. However, the file is well played on Windows 7 when I access it on the Zen.

I note another problem with Windows XP. The directshow filter coreAAC doesn't allow me to play m4a file with WMP.

Note: Each time I put the file in the Music directory of the Zen

This post has been edited by filou85: Dec 8 2011, 22:30
Go to the top of the page
+Quote Post
grums
post Dec 9 2011, 08:44
Post #14





Group: Members
Posts: 10
Joined: 8-March 11
Member No.: 88810



Thank you for the file, filou85!

I can play it on XP Media player - but only if I rename it to .MP4
I can't transfer it to my ZEN, same problem as before.

I have to be sure that you meant this:
Using Windows 7, the file can be transferred and played on the ZEN?
Using XP, the file can be transferred, but it doesn't play on the ZEN?
Go to the top of the page
+Quote Post
filou85
post Dec 9 2011, 16:50
Post #15





Group: Members
Posts: 6
Joined: 6-August 10
Member No.: 82876



QUOTE (grums @ Dec 9 2011, 08:44) *
I have to be sure that you meant this:
Using Windows 7, the file can be transferred and played on the ZEN?
Using XP, the file can be transferred, but it doesn't play on the ZEN?


Yes to both question.

However, note that I use a virtual machine to testing XP (Virtual PC 2010 - XP mode in Windows 7 Pro). I will try to transfert some mp3 files to investigate if the virtualization of XP, or just XP, is responsible of the fact that m4a files cannot be played by the Zen.
Go to the top of the page
+Quote Post
grums
post Dec 9 2011, 20:22
Post #16





Group: Members
Posts: 10
Joined: 8-March 11
Member No.: 88810



I'll await your reply - there might be two problems:
  • Transfer of file
  • Playback of file
I'm close to deciding that ZEN together with my XP version and Media Player drivers combo is the culprit.
I'm not going to try to Microsoft Update the system out of the problem, instead as a last resort I might try to get a VMware system going and try using Windows 7 from there...
Go to the top of the page
+Quote Post
grums
post Dec 21 2011, 13:18
Post #17





Group: Members
Posts: 10
Joined: 8-March 11
Member No.: 88810



I haven't had any positive progress on this - my PC is only able to run VMware Player 2.x, and when running the Win7 system installed as VMware guest, VMware asks for some VMware system files in order to recognize the ZEN, so I'll just leave it and waste no more time on it.
Thanks all for contributing - Rockbox rocks!
laugh.gif
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th December 2014 - 03:10