IPB

Welcome Guest ( Log In | Register )

4 Pages V  « < 2 3 4  
Reply to this topicStart new topic
lossyWAV 1.3.0 released, Added noise WAV bitdepth reduction method.
sundance
post Sep 14 2013, 18:51
Post #76





Group: Members
Posts: 166
Joined: 17-April 02
Member No.: 1804



Hello Nick,
seems I've got a similar issue like Mardel had (foobar 1.2.9 w/lossywav 1.3.0), although re-installation of fb2k didn't help here.

Setting up with the wiki recommended configuration gives the same error message Mardel had (Error 0x00000001).

Then I tried to simplify things by running this converter setup:
CODE
Encoder file: C:\Program Files\CmdlineTools\lossyWAV.exe
Parameters: - --outdir %d

Converter Status Report:
CODE
1 out of 1 tracks converted with major problems.

Source: "Z:\Robert Plant - Ship of Fools.wav"
  An error occurred while writing to file (The encoder has terminated prematurely with code 49 (0x00000031); please re-check parameters) : "Z:\TEMP\Robert Plant - Ship of Fools.lossy.wav"
  Additional information:
  Encoder stream format: 44100Hz / 2ch / 16bps
  Command line: "C:\Program Files\CmdlineTools\lossyWAV.exe" - --outdir "Robert Plant - Ship of Fools.lossy.wav"
  Working folder: Z:\TEMP\
  
  Conversion failed: The encoder has terminated prematurely with code 49 (0x00000031); please re-check parameters


Then w/o piping (and using a different target dir):
CODE
Encoder file: C:\Program Files\CmdlineTools\lossyWAV.exe
Parameters: %s --outdir %d

Status:
CODE
1 out of 1 tracks converted with major problems.

Source: "Z:\Robert Plant - Ship of Fools.wav"
  An error occurred while finalizing the encoding process (Object not found) : "D:\Robert Plant - Ship of Fools.lossy.wav"
  Conversion failed: Object not found


Any idea what I could try?

.sundance.

P.S. I tried to run it directly in a cmd.exe window:
CODE
"C:\Program Files\CmdlineTools\lossyWAV.exe" "Robert Plant - Ship of Fools.wav" --outdir "z:\temp\Robert Plant - Ship of Fools.lossy.wav"
lossyWAV 1.3.0, Copyright (C) 2007-2011 Nick Currie. Copyleft.
This is free software under the GNU GPLv3+ license; There is NO WARRANTY, to
the extent permitted by law. <http://www.gnu.org/licenses/> for details.
%lossyWAV Error% : Directory : z:\temp\Robert Plant - Ship of Fools.lossy.wav\ cannot be accessed.

Maybe there's something wrong with supplying a full path with --outdir
because this works:
CODE
"C:\Program Files\CmdlineTools\lossyWAV.exe" "Robert Plant - Ship of Fools.wav" --outdir "z:\temp"
lossyWAV 1.3.0, Copyright (C) 2007-2011 Nick Currie. Copyleft.
This is free software under the GNU GPLv3+ license; There is NO WARRANTY, to
the extent permitted by law. <http://www.gnu.org/licenses/> for details.
Filename  : Robert Plant - Ship of Fools.wav
File Info : 44.10kHz; 2 channel; 16 bit; 05:02.57, 50,90MiB
Progress  : 11.79%; 2.7503 bits; 11.40x; 00:03.12/00:26.54 ...


This post has been edited by sundance: Sep 14 2013, 19:00
Go to the top of the page
+Quote Post
lvqcl
post Sep 14 2013, 18:56
Post #77





Group: Developer
Posts: 3399
Joined: 2-December 07
Member No.: 49183



QUOTE (sundance @ Sep 14 2013, 21:51) *
Any idea what I could try?

Don't use --outdir
Go to the top of the page
+Quote Post
sundance
post Sep 14 2013, 19:04
Post #78





Group: Members
Posts: 166
Joined: 17-April 02
Member No.: 1804



@lvqcl:
Tried that, but fb2k complains about invalid encoder parameter without specifying %d
Go to the top of the page
+Quote Post
Mardel
post Sep 14 2013, 19:05
Post #79





Group: Members
Posts: 27
Joined: 12-March 08
Member No.: 51986



QUOTE (sundance @ Sep 14 2013, 19:51) *
...

My problem is quite unique.
If I reboot my pc I have to reinstall foobar agian because the problems come forward ASIO and WASAPI and pipe encode doesn't work.
But after reboot ASIO only works with an older compenent (1.2.6).
I don't know is windows (win 7 64 bit) or creative soundcard (xfi xtrememusic) related problem but pretty annoying.

This post has been edited by Mardel: Sep 14 2013, 19:06


--------------------
Wavpack -hh or TAK -pMax
OggVorbis aoTuVb6.03 -q 4
Go to the top of the page
+Quote Post
lvqcl
post Sep 14 2013, 19:15
Post #80





Group: Developer
Posts: 3399
Joined: 2-December 07
Member No.: 49183



QUOTE (sundance @ Sep 14 2013, 22:04) *
Tried that, but fb2k complains about invalid encoder parameter without specifying %d

I forgot that LossyWAV doesn't have an option to specify just output file name. sleep.gif
Go to the top of the page
+Quote Post
Nick.C
post Sep 14 2013, 19:31
Post #81


lossyWAV Developer


Group: Developer
Posts: 1791
Joined: 11-April 07
From: Wherever here is
Member No.: 42400



There is....

Try "--stdinname %d".

[edit] This is then used to create the ".lossy.wav" output filename. [/edit]

[edit2] Re-reading the question, "--outdir" should be used to specify the path to the directory where the output file should be created.

Also, why not just use the destination dialog in the foobar2000 converter to specify your output directory? [/edit2]

This post has been edited by Nick.C: Sep 14 2013, 21:31


--------------------
lossyWAV -q X -a 4 --feedback 4| FLAC -8 ~= 320kbps
Go to the top of the page
+Quote Post
sundance
post Sep 15 2013, 07:31
Post #82





Group: Members
Posts: 166
Joined: 17-April 02
Member No.: 1804



QUOTE (Nick.C @ Sep 14 2013, 20:31) *
Also, why not just use the destination dialog in the foobar2000 converter to specify your output directory?

That's what I did anyway, but still %d has to be supplied somewhere in the fb2k converter setup to be valid (and, sadly, something like "$directory(%d)" doesn't work either...)
But honestly, I don't need a "lossyWAV" setup; this issue just surfaced when I tried to create a working "lossyFLAC" converter setup (during my investigations), because I failed to make the wiki suggestion work here:
CODE
Encoder: C:\Windows\System32\cmd.exe
Extension : lossy.flac
Parameters: /d /c C:\"Program Files"\bin\lossywav - --quality standard --silent --stdout|
            C:\"Program Files"\bin\flac - -b 512 -5 -f -o%d --ignore-chunk-sizes
Go to the top of the page
+Quote Post
weepy
post Jan 8 2014, 11:24
Post #83





Group: Members
Posts: 2
Joined: 8-January 14
Member No.: 113880



Hi there - wonderful project,

I was wondering if it was ever going to be possible to get a LINUX/MAC compilable version of lossyWAV ?

Perhaps this is something to do with the port to C from Delphi ?

Cheers
Go to the top of the page
+Quote Post
sidewalking
post Mar 18 2014, 20:58
Post #84





Group: Members
Posts: 105
Joined: 16-September 03
Member No.: 8871



QUOTE (sundance @ Sep 15 2013, 00:31) *
QUOTE (Nick.C @ Sep 14 2013, 20:31) *
Also, why not just use the destination dialog in the foobar2000 converter to specify your output directory?

That's what I did anyway, but still %d has to be supplied somewhere in the fb2k converter setup to be valid (and, sadly, something like "$directory(%d)" doesn't work either...)
But honestly, I don't need a "lossyWAV" setup; this issue just surfaced when I tried to create a working "lossyFLAC" converter setup (during my investigations), because I failed to make the wiki suggestion work here:
CODE
Encoder: C:\Windows\System32\cmd.exe
Extension : lossy.flac
Parameters: /d /c C:\"Program Files"\bin\lossywav - --quality standard --silent --stdout|
            C:\"Program Files"\bin\flac - -b 512 -5 -f -o%d --ignore-chunk-sizes



Sounds like some of the issue I'm having with my foobar string. I tried lossyFLAC first and then just modified the last part to try WavPack for lossyWv to troubleshoot if my syntax was wrong on the lossyWAV side or the output encoder side. Same issue both ways, it's like it's looking for a concatenated filename first and now it's just not finding the output file (but this is all within one second...no encoding/decoding is taking place that I can tell.


QUOTE
1 out of 1 tracks converted with major problems.

Source: "C:\Users\scott\Documents\{APPS}\13 - Hallowed Ground.flac"
An error occurred while writing to file (The encoder has terminated prematurely with code 1 (0x00000001); please re-check parameters) : "C:\Users\scott\Music\How to Destroy Angels - (2013) Welcome Oblivion\13 - Hallowed Ground.lossy.wv"
Additional information:
Encoder stream format: 44100Hz / 2ch / 16bps
Command line: "C:\Windows\System32\cmd.exe" /d /c C:\Users\scott\Documents\{APPS}\foobar2000\lossywav - -quality high --silent --stdout|C:\Users\scott\Documents\{APPS}\foobar2000\wavpack -hm --blocksize=512 --merge-blocks -i - "13 - Hallowed Ground.lossy.wv"
Working folder: C:\Users\scott\Music\How to Destroy Angels - (2013) Welcome Oblivion\

Conversion failed: The encoder has terminated prematurely with code 1 (0x00000001); please re-check parameters


Here's my command line and parameters:

CODE
/d /c C:\Users\scott\Documents\{APPS}\foobar2000\lossywav - -quality high --silent --stdout|C:\Users\scott\Documents\{APPS}\foobar2000\wavpack -hm --blocksize=512 --merge-blocks -i - %d


I'm sure it's a small thing like a space or missing something...just cannot get it right. Any feedback or help I can get on my command here? I use Foobar commands all the time, putting my binaries all in the root foobar directory (as you see up there).

Thanks for any advice!!!

Scott
Go to the top of the page
+Quote Post
akin0780
post Mar 18 2014, 21:20
Post #85





Group: Members
Posts: 25
Joined: 25-September 13
From: Vancouver, CA
Member No.: 110332



This should work:

Place lossyWAV.exe and wavpack.exe in C:\foobar2000\ and use the following settings:

/d /c C:\foobar2000\lossywav.exe - -q 5 --silent --stdout|C:\foobar2000\wavpack.exe --blocksize=512 --merge-blocks -i - %d

This post has been edited by akin0780: Mar 18 2014, 21:21


--------------------
lossyWAV -q H | FLAC -5 ~= 480kbps
Go to the top of the page
+Quote Post
Nick.C
post Mar 18 2014, 21:58
Post #86


lossyWAV Developer


Group: Developer
Posts: 1791
Joined: 11-April 07
From: Wherever here is
Member No.: 42400



QUOTE (sidewalking @ Mar 18 2014, 19:58) *
Here's my command line and parameters:

CODE
/d /c C:\Users\scott\Documents\{APPS}\foobar2000\lossywav - -quality high --silent --stdout|C:\Users\scott\Documents\{APPS}\foobar2000\wavpack -hm --blocksize=512 --merge-blocks -i - %d


I'm sure it's a small thing like a space or missing something...just cannot get it right. Any feedback or help I can get on my command here? I use Foobar commands all the time, putting my binaries all in the root foobar directory (as you see up there).


It was indeed a small issue: you had "-quality" rather than "--quality" in the command line.


--------------------
lossyWAV -q X -a 4 --feedback 4| FLAC -8 ~= 320kbps
Go to the top of the page
+Quote Post
sidewalking
post Mar 20 2014, 02:11
Post #87





Group: Members
Posts: 105
Joined: 16-September 03
Member No.: 8871



QUOTE (Nick.C @ Mar 18 2014, 14:58) *
QUOTE (sidewalking @ Mar 18 2014, 19:58) *
Here's my command line and parameters:

CODE
/d /c C:\Users\scott\Documents\{APPS}\foobar2000\lossywav - -quality high --silent --stdout|C:\Users\scott\Documents\{APPS}\foobar2000\wavpack -hm --blocksize=512 --merge-blocks -i - %d


I'm sure it's a small thing like a space or missing something...just cannot get it right. Any feedback or help I can get on my command here? I use Foobar commands all the time, putting my binaries all in the root foobar directory (as you see up there).


It was indeed a small issue: you had "-quality" rather than "--quality" in the command line.


Thanks to you both! I knew it would be something as small as that, easily overlooked and whoops you with the unwanted results! rolleyes.gif
Go to the top of the page
+Quote Post
halb27
post Jun 22 2014, 22:08
Post #88





Group: Members
Posts: 2436
Joined: 9-October 05
From: Dormagen, Germany
Member No.: 25015



I did a personal listening test a while ago with various problem samples (all tonal, with the exception of castanets) using mp3, aac, mpc at various bitrates. Out of interest I also included lossyWAV though the samples were targeting at mp3 and alike.
Out of the samples tested herding_calls was the outstanding problem for lossyWAV. It took the economic quality (~400 kbps on average) to make it transparent for me.

This post has been edited by halb27: Jun 22 2014, 22:13


--------------------
lame3100m -V1 --insane-factor 0.75
Go to the top of the page
+Quote Post

4 Pages V  « < 2 3 4
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st October 2014 - 14:17