IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Cover artómany albums show wrong pic i.e. a different one from library, Was: Foobar Album Cover problem (TOS #6)
oversleptagain
post Jul 12 2011, 09:33
Post #1





Group: Members
Posts: 3
Joined: 12-July 11
Member No.: 92220



Hi, first post here laugh.gif

Foobar2K is running great for me, except for one issue. A lot of my albums (I'd say about 40% or so) display the wrong album art. They all show the same thing, in my case it happens to be Electric Light Orchestra's "Mr. Blue Sky" single cover.

Every single file in my library has embedded album art, and on my MP3 player it shows up just fine. I have the "Write ID3v2.3 Tags" option ticked, ID3v2 as my preferred tag writing scheme, and the "Force preferred tag writing scheme on all files regardless of existing files" box checked.

Also, all my mp3 files are loose in one folder, no organization. But they all have embedded art. I also tried extracting the art embedded in the files into separate files into the folder I have all my music in using mp3tag, but that didn't work either.

Thanks in advance to anyone who can help me out!
Go to the top of the page
+Quote Post
oversleptagain
post Jul 14 2011, 22:46
Post #2





Group: Members
Posts: 3
Joined: 12-July 11
Member No.: 92220



Bump sad.gif

I really hate seeing ELO's art when it should be something more along the lines of an Infected Mushroom cover...
Go to the top of the page
+Quote Post
marc2003
post Jul 14 2011, 23:06
Post #3





Group: Members
Posts: 4439
Joined: 27-January 05
From: England
Member No.: 19379



if you open windows explorer and goto organize>folder and search options* and then the view tab, untick the option hide protected operating system files. now browse to the folder and you should see old images that you'll want to delete. they are most likely remnants left behind by the evil that is windows media player.

(*exact terminology to find these options may depend on your windows version)
Go to the top of the page
+Quote Post
oversleptagain
post Jul 15 2011, 01:28
Post #4





Group: Members
Posts: 3
Joined: 12-July 11
Member No.: 92220



QUOTE (marc2003 @ Jul 14 2011, 14:06) *
if you open windows explorer and goto organize>folder and search options* and then the view tab, untick the option hide protected operating system files. now browse to the folder and you should see old images that you'll want to delete. they are most likely remnants left behind by the evil that is windows media player.

(*exact terminology to find these options may depend on your windows version)


Oh my gosh, thank you SO much! This fixed it perfectly.
Go to the top of the page
+Quote Post
Kraps
post Feb 13 2012, 20:07
Post #5





Group: Members
Posts: 4
Joined: 10-February 07
Member No.: 40497



I have a similar problem - in my music folder with flac files (covers embedded) there is folder.jpg file which foobar for unknown reasons displays for some (not all!) files instead of the embedded art. I'd rather leave folder.jpg as a fallback cover. I wonder what makes foobar display folder.jpg instead of the embedded art only for some of the files?

This post has been edited by Kraps: Feb 13 2012, 20:38
Go to the top of the page
+Quote Post
Frank Bicking
post Feb 13 2012, 20:56
Post #6





Group: Super Moderator
Posts: 1827
Joined: 24-July 02
Member No.: 2776



It picks whatever image has the larger file size.

I assume those FLAC files are CD images, all in a single folder? If so, remove folder.jpg from the search pattern, and select your fallback file under stub image path (Preferences, Display).
Go to the top of the page
+Quote Post
Kraps
post Feb 15 2012, 13:27
Post #7





Group: Members
Posts: 4
Joined: 10-February 07
Member No.: 40497



Nope, they're actually separate tracks of one of my albums.

But that was the answer I was looking for - I've just reduced the size of folder.jpg and the embedded covers got their priority. Thank you very much!

Foobar's behaviour is kinda strange though - shouldn't embedded art get priority regardless of size?

This post has been edited by Kraps: Feb 15 2012, 13:40
Go to the top of the page
+Quote Post
kode54
post Feb 15 2012, 20:21
Post #8





Group: Admin
Posts: 4578
Joined: 15-December 02
Member No.: 4082



And why should that be? Embedded art is often smaller, lower quality images than external art. The core tries to pick the highest quality image, assuming that larger size means higher quality.
Go to the top of the page
+Quote Post
80sMetalForever
post Apr 27 2014, 20:15
Post #9





Group: Members
Posts: 30
Joined: 22-February 14
Member No.: 114621



thank you so much! I have artists with only 1 or 2 tracks all lumped in specific genre folders and I for the life of me couldn't figure out what was going on with the cover art
Go to the top of the page
+Quote Post
BenB
post Apr 27 2014, 23:05
Post #10





Group: Members
Posts: 716
Joined: 17-April 12
Member No.: 98921



foobar has had an advanced album art preferences setting added since this thread was initiated and most of the subsequent posts were made.

It is found at Preferences > Advanced > Display > Album art > Embedded vs external.

There are three choices (all should be self-explanatory):
Prefer larger
Prefer external
Prefer embedded


This post has been edited by BenB: Apr 27 2014, 23:05
Go to the top of the page
+Quote Post
80sMetalForever
post May 2 2014, 18:45
Post #11





Group: Members
Posts: 30
Joined: 22-February 14
Member No.: 114621



thx for the info Ben, but I believe the issue we were having was the hidden cover files "overriding" embedded covers for situations when we have files lumped in the same folder. I want foobar to look for external and embedded, but in these specific scenarios these hidden covers were being applied to all tracks in that folder - once deleted all works fine. You have a good tip nonetheless!

EDIT
nevermind, I see the side topic you were referring to...is there a way to delete posts? I didn't see a way to delete mine.

This post has been edited by 80sMetalForever: May 2 2014, 18:49
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 25th July 2014 - 17:04