IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
writing wavpack sound to stdout
BearcatSandor
post Jun 25 2011, 11:13
Post #1





Group: Members
Posts: 149
Joined: 18-May 10
From: Montana, USA
Member No.: 80732



Folks,

i'm getting ampache setup on linux and i need to be able to write audio out to stdout for the streaming to work. My collection is in wavpack.

For instance, the command line for flac would be ""flac -dc %FILE% | lame -b %SAMPLE% -S - - ".

I've been searching for hours and i can't figure out how to decompress a wavpack file to a pipe and not to a file.

Any help is welcome. I'd rather not convert 12k files to flac and lose all that tagging.

Thanks.

This post has been edited by BearcatSandor: Jun 25 2011, 11:14


--------------------
Music lover and recovering high end audiophile
Go to the top of the page
+Quote Post
lvqcl
post Jun 25 2011, 11:24
Post #2





Group: Developer
Posts: 3357
Joined: 2-December 07
Member No.: 49183



This commandline should work:

wvunpack file.wv - | lame -b ...

Go to the top of the page
+Quote Post
BearcatSandor
post Jun 25 2011, 21:07
Post #3





Group: Members
Posts: 149
Joined: 18-May 10
From: Montana, USA
Member No.: 80732



QUOTE (lvqcl @ Jun 25 2011, 04:24) *
This commandline should work:

wvunpack file.wv - | lame -b ...

Thanks. That's what i've been playing with and it does not quite work. With flac, if i do "flac -dc myfile.flac | lame -b 8192 -S - - " i get crap (binary stuff) all over my screen. That's what i would expect and it's the correct behavior. There is no resulting file called myfile.wav. The -dc parameter means decode,pass to stdout.

If i do that with wavpack, which does not seem to have a "pass data to stdout" switch, by entering "wvunpack myfile.wv | lame -b 8192 -S - - " i just see it uncompressing and no crap flies up my screen as it should. I end up with a file called myfile.wav and i should not.


Any ideas?

Thanks.


--------------------
Music lover and recovering high end audiophile
Go to the top of the page
+Quote Post
bryant
post Jun 25 2011, 21:51
Post #4


WavPack Developer


Group: Developer (Donating)
Posts: 1291
Joined: 3-January 02
From: San Francisco CA
Member No.: 900



QUOTE (BearcatSandor @ Jun 25 2011, 03:13) *
Any help is welcome. I'd rather not convert 12k files to flac and lose all that tagging.

Please, I hope that's not necessary !! smile.gif

I think I know the problem. The command line that lvqcl gave will work fine in Windows, but there is a slightly different syntax required in Linux because on Linux you can have multiple input file entries on the command line and so a -o is required if an output file (or stdout) is specified:

CODE
wvunpack file.wv -o - | lame ...


This is shown in the usage line, but these formal format specifications are not always obvious, and I see that nowhere is it mentioned that dash (-) refers to stdin and stdout (although that is pretty common):

CODE
Usage:   WVUNPACK [-options] [@]infile[.wv]|- [...] [-o [@]outfile[.wav]|outpath|-]


Note that I added -o as a nop to the Windows version so that the same syntax could be used on both platforms if desired (this is used for Logitech's SqueezeCenter).

Hope this works better!

David

This post has been edited by bryant: Jun 25 2011, 22:02
Go to the top of the page
+Quote Post
BearcatSandor
post Jun 26 2011, 00:13
Post #5





Group: Members
Posts: 149
Joined: 18-May 10
From: Montana, USA
Member No.: 80732



Bryant,

Yes!!! Thank you so much! It's now working fantasticly. I can stream my wavpack files all over!

And to think I almost converted back to flac. That was a close one!

Thanks again,

Bearcat


--------------------
Music lover and recovering high end audiophile
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th August 2014 - 22:44