IPB

Welcome Guest ( Log In | Register )

Annoying distortion: Sansa Clip+ w/ Rockbox, Audible but not easily measurable
googlebot
post Jan 22 2011, 14:52
Post #1





Group: Members
Posts: 698
Joined: 6-March 10
Member No.: 78779



After reading several positive posts around here, I replaced my venerable iPod G5 Video with a little Sansa Clip+ and a 16GB flash card. Missing AAC support was a deal breaker, but Rockbox was reported to run fine.

I must say, compared to the absolutely flawless experience with my last iPod, I'm quite dissatisfied. It started with a bug of Rockbox 3.7.1 that large SD cards are sometimes not initialized properly (and thus don't appear in the menu), which affected my Transcend model. An upgrade to the latest daily build fixed this.

An issue, that I can't fix with whatever build, is annoying CPU noise. At the beginning of tracks and during rebuffering of longer tracks there is a short humming sound (like a bumblebee) mixed with a fast sequence of random high frequency tones. The sound differs as a function of data format and content. It is very homogeneous with WAV tracks (only humming) and different with lossy and lossless codecs. The same file encoded with FLAC and AAC leads to different short distortions. It is only audible for tracks with initial silence or very dynamic content, for example classical music with quiet passages or audio books. The original firmware does not show this behavior. It is probably a throttling issue. Rockbox just reads and decodes the file in a regular loop as fast as the CPU can deliver it. Due to cheap hardware design this leads to audible inference on the output. The original firmware probably works around this by some form of flow control and doesn't read the data any faster than required. But, as I've said, due to missing AAC support the original firmware is not an option.

The phenomenon is only audible with my headphones. The Creative EP-630 have a rather large sensitivity of 106 dB. I tried to record the distortion over a line-input and it is non-existent there. That made me think about the common practice of shutting people up with RMAA results or telling them that what they hear must be placebo. High-impedance, line-level inputs do not necessarily capture the same as what a sensitive headphone outputs.

Can anyone, who also owns sensitive earphones, recommend a comparable player (no video, real buttons) with flawless output? It would be nice if I could re-use the SD-card.

This post has been edited by googlebot: Jan 22 2011, 14:53
Go to the top of the page
+Quote Post
 
Start new topic
Replies
googlebot
post Mar 5 2011, 15:02
Post #2





Group: Members
Posts: 698
Joined: 6-March 10
Member No.: 78779



As I have written, my ALC889's line-in is not sensitive enough to capture the noise. I guess the Clip+ drives it with a larger voltage than the IEMs and then its output is fine.

I have uploaded my test file. It is nothing special, you could also just create your own, a mp3 with a forced high bitrate (so that it doesn't get buffered completely), with nothing but a high pitched tone inside. Copy it several times onto the SD card (not the internal storage) and then listen while you skip between tracks. The noise you hear is the same that annoys me during playback, when the SD card is accessed for re-buffering.

Maybe NwAvGuy can repeat the recording with his much better equipment. Then we would have an example.

This post has been edited by googlebot: Mar 5 2011, 15:06
Go to the top of the page
+Quote Post
Arnold B. Kruege...
post Mar 7 2011, 17:02
Post #3





Group: Members
Posts: 3797
Joined: 29-October 08
From: USA, 48236
Member No.: 61311



QUOTE (googlebot @ Mar 5 2011, 09:02) *
As I have written, my ALC889's line-in is not sensitive enough to capture the noise. I guess the Clip+ drives it with a larger voltage than the IEMs and then its output is fine.

I have uploaded my test file. It is nothing special, you could also just create your own, a mp3 with a forced high bitrate (so that it doesn't get buffered completely), with nothing but a high pitched tone inside. Copy it several times onto the SD card (not the internal storage) and then listen while you skip between tracks. The noise you hear is the same that annoys me during playback, when the SD card is accessed for re-buffering.


I don't see any need for sensitive measurements as the transients that are generated by my Clip+ with 01.02.15 firmware when I switch between 2 copies of the test file are pretty gross. The signal I record starts at the baseline, dives negative for about 50 milliseconds to an amplitude of about 20% of the test signal, bounces up for about 20 milliseconds, and then the test tone starts and its DC value starts out about 20% high and then bounces down to a nice symmetrical HF wave.

The most improtant characeristic of the test file is that it has a consdierable signal but is at such a high frequency that it can't be heard very easily.

Looks to me like the Clip's output is disconnected from the headphones when its changing files, and then gets hooked back up and there's a transient something like coupling capacitors charging up. That's odd because the performance of the Clip generally suggests that tehre are no output blocking caps. I guess the servo system that eliminates any need for them still simulates some of the odd things they might do with the power supply remoted and then applied to start playing the file.
Go to the top of the page
+Quote Post

Posts in this topic
- googlebot   Annoying distortion: Sansa Clip+ w/ Rockbox   Jan 22 2011, 14:52
- - odigg   I think people experienced with RMAA measurements ...   Jan 22 2011, 15:52
- - Soap   I believe the charge against the use of RMAA numbe...   Jan 22 2011, 16:03
|- - googlebot   QUOTE (Soap @ Jan 22 2011, 16:03) Bet you...   Jan 22 2011, 16:28
|- - odigg   QUOTE (googlebot @ Jan 22 2011, 10:28) I ...   Jan 22 2011, 19:00
- - Peter   Just for reference: I believe I'm having a sim...   Jan 22 2011, 16:44
- - bryant   There is a mention on this Rockbox page about anno...   Jan 22 2011, 20:25
- - Arnold B. Krueger   QUOTE (googlebot @ Jan 22 2011, 08:52) Af...   Jan 22 2011, 23:25
|- - Northpack   QUOTE (Arnold B. Krueger @ Jan 22 2011, 23...   Jan 25 2011, 11:14
- - probedb   You could post on the rockbox forums, plus also ra...   Jan 23 2011, 10:43
|- - odigg   I installed the latest version of Rockbox on my Cl...   Jan 24 2011, 21:30
- - greynol   I hope this gets fixed or Sansa implements gapless...   Jan 24 2011, 21:40
|- - 2Bdecided   QUOTE (greynol @ Jan 24 2011, 20:40) Sans...   Jan 25 2011, 10:25
|- - odigg   QUOTE (greynol @ Jan 24 2011, 15:40) I ho...   Jan 25 2011, 14:42
- - botface   @googlebot I have a Fuze v1 and have no problems ...   Jan 25 2011, 13:37
- - googlebot   I'm pretty sure that the noise cannot be heard...   Jan 25 2011, 20:21
- - Northpack   I can hear that noise too but as long as I am not ...   Jan 25 2011, 22:20
- - eevan   I can confirm that there is high noise level on Fu...   Jan 26 2011, 14:33
- - saratoga   googlebot just pointed me to this thread. I am ...   Mar 4 2011, 00:45
|- - googlebot   Which version of Rockbox are you using?   Mar 4 2011, 00:56
|- - odigg   QUOTE (saratoga @ Mar 3 2011, 18:45) I...   Mar 4 2011, 16:56
- - saratoga   r29342. But the Clip+ has been my preferred playe...   Mar 4 2011, 01:02
- - googlebot   Very interesting! Do you have a Rockbox build ...   Mar 4 2011, 02:11
- - Northpack   For me the noise is related to SD access. It's...   Mar 4 2011, 17:45
|- - odigg   QUOTE (Northpack @ Mar 4 2011, 11:45) For...   Mar 4 2011, 18:38
- - Northpack   Yes, I didn't mean the external SD specificall...   Mar 4 2011, 18:42
- - NwAvGuy   As I think the OP may already know, I did a full t...   Mar 5 2011, 02:30
|- - Northpack   QUOTE (NwAvGuy @ Mar 5 2011, 02:30) In te...   Mar 5 2011, 11:33
- - Arnold B. Krueger   QUOTE (googlebot @ Jan 22 2011, 08:52) Af...   Mar 5 2011, 13:06
- - googlebot   As I have written, my ALC889's line-in is not ...   Mar 5 2011, 15:02
|- - NwAvGuy   QUOTE (googlebot @ Mar 5 2011, 06:02) May...   Mar 5 2011, 18:21
||- - googlebot   QUOTE (NwAvGuy @ Mar 5 2011, 18:21) I can...   Mar 5 2011, 18:31
|- - Arnold B. Krueger   QUOTE (googlebot @ Mar 5 2011, 09:02) As ...   Mar 7 2011, 17:02
|- - googlebot   QUOTE (Arnold B. Krueger @ Mar 7 2011, 17...   Mar 7 2011, 17:34
|- - Arnold B. Krueger   QUOTE (googlebot @ Mar 7 2011, 11:34) QUO...   Mar 7 2011, 18:06
|- - googlebot   Yes, that's impressive. If you find the time, ...   Mar 7 2011, 19:12
|- - Arnold B. Krueger   QUOTE (googlebot @ Mar 7 2011, 13:12) Yes...   Mar 7 2011, 20:12
- - saratoga   Heres a patched build if someone wants to try it. ...   Mar 7 2011, 17:32
|- - kritip   QUOTE (saratoga @ Mar 7 2011, 17:32) Here...   Aug 5 2011, 17:20
|- - saratoga   QUOTE (kritip @ Aug 5 2011, 12:20) QUOTE ...   Aug 5 2011, 19:42
- - greynol   To me a lack of gapless playback = broken.   Mar 7 2011, 20:15
|- - Arnold B. Krueger   QUOTE (greynol @ Mar 7 2011, 14:15) To me...   Mar 7 2011, 22:21
|- - grums   On the Clip+/Rockbox there's a possibility to ...   Mar 8 2011, 20:30
|- - Lear   QUOTE (grums @ Mar 8 2011, 20:30) On the ...   Mar 8 2011, 22:04
|- - grums   QUOTE (Lear @ Mar 8 2011, 22:04) QUOTE (g...   Mar 9 2011, 13:26
|- - googlebot   ReplayGain does DAC wise nothing different than th...   Mar 9 2011, 13:29
- - googlebot   The only match, that I have found in my favorite c...   Mar 7 2011, 20:47
- - grums   You're right - just did a quick test, on my (n...   Mar 9 2011, 14:29
- - kritip   Thanks. I have tried that and the issue is still t...   Aug 6 2011, 07:41
- - saratoga   If it happens in then Sandisk firmware too, then y...   Aug 7 2011, 18:40
|- - kritip   Indeed, this noise doesn't really scale with v...   Aug 7 2011, 20:21
- - saratoga   Which rockbox version did you test?   Aug 7 2011, 20:48
- - kritip   the latest development and stable build, and the o...   Aug 7 2011, 21:19
- - saratoga   Yes, but which version did you test when you recor...   Aug 7 2011, 21:21
- - kritip   sorry: r30259-110806   Aug 7 2011, 21:24
- - Rezal   The Clip+ I have bought some weeks ago is also aff...   Aug 20 2011, 12:33
- - Rezal   Some additional findings (why can't I edit my ...   Aug 20 2011, 16:47
|- - db1989   QUOTE (Rezal @ Aug 20 2011, 16:47) why ca...   Aug 20 2011, 17:01
- - Sik_Lescinovid   I'm sorry to be bumping an old thread, but I c...   Dec 29 2012, 16:52
|- - saratoga   QUOTE (Sik_Lescinovid @ Dec 29 2012, 10:5...   Dec 29 2012, 20:33
|- - Sik_Lescinovid   QUOTE (saratoga @ Dec 29 2012, 21:33) I d...   Dec 29 2012, 21:39
- - saratoga   I'm not sure what the best way is. When I...   Dec 29 2012, 22:11
- - kritip   Well, after the clip broke (literally the clip), I...   Apr 6 2013, 22:46
- - kritip   Just to update, the new player doesn't exhibit...   Apr 15 2013, 17:53


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th September 2014 - 15:39