IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

3 Pages V  < 1 2 3  
Reply to this topicStart new topic
Issues with ASX streams, Split from: "foobar2000 v1.0 beta 2a"
Dvvarf
post Dec 30 2009, 00:21
Post #51





Group: Members
Posts: 10
Joined: 22-November 09
From: Russia
Member No.: 75176



Beta6 is out and no workaround for my problem (info for http://cluster.quantumart.ru/broadcast/def...dia=station2000 stream)... Is there a way to fix it it or i just should stick with mslive?

This post has been edited by Dvvarf: Dec 30 2009, 00:22
Go to the top of the page
+Quote Post
Peter
post Dec 30 2009, 12:21
Post #52


foobar2000 developer


Group: Admin
Posts: 3313
Joined: 30-September 01
Member No.: 84



QUOTE (Dvvarf @ Dec 30 2009, 00:21) *
Beta6 is out and no workaround for my problem (info for http://cluster.quantumart.ru/broadcast/def...dia=station2000 stream)... Is there a way to fix it it or i just should stick with mslive?

Please complain at the radio station administrator, they use custom metadata field names instead of ones defined in the Windows Media SDK.
Go to the top of the page
+Quote Post
Dvvarf
post Jan 4 2010, 14:57
Post #53





Group: Members
Posts: 10
Joined: 22-November 09
From: Russia
Member No.: 75176



QUOTE (Peter @ Dec 30 2009, 14:21) *
Please complain at the radio station administrator, they use custom metadata field names instead of ones defined in the Windows Media SDK.

Does that mean that WMP also uses these custom names?
P.S. Please, don't think that I'm trying to be impolite, I highly appreciate your work and I dont want to use this mslive plugin that just started to crush foobar sometimes. And unfortunately, its impossible to complain about this stream, because, though its being translated explicitly, it is not meant to be played with normal player, but with flash player provided by station. Also my posts could be dense, because I'm not too good at English.
Go to the top of the page
+Quote Post
hechacker1
post Jan 9 2010, 07:36
Post #54





Group: Members
Posts: 14
Joined: 5-November 04
Member No.: 17982



Ok, so I have done extensive work on my perl script that just returns the asx generated by Clear Channel radio streams (asx, mms).

Here is the asx as passed by clearchannel:

http://ordorica.org/tune.pl?station=kfi640

Yes, I tried changing the content type to:
video/x-ms-as

But it doesn't make a difference for foobar. For the purpose of letting you read the script in the browser I don't have a content type set.

So looking at the asx ClearChannel returns, can you tell me what needs to be fixed? I have a subroutine that tries to fix their asx to be more xml like:

'&' => '&amp;',
'<' => '&lt;',
'>' => '&gt;',
'"' => '&quot;'

But doing that change doesn't help foobar load. I also tried just changing the ampersand with no luck. Is some part of the clearchannel asx broken or needs to be rewritten to work with foobar?

Thanks if you can take a look at it. Otherwise I will just have to stick with mslive or use vlc.

I also tried changing my script to 302 redirect foobar2000 to a generated asx file linux (ordorica.org/tune.asx), but it made no difference.

This post has been edited by hechacker1: Jan 9 2010, 07:38
Go to the top of the page
+Quote Post
kode54
post Jan 9 2010, 10:47
Post #55





Group: Admin
Posts: 4691
Joined: 15-December 02
Member No.: 4082



QUOTE (hechacker1 @ Jan 8 2010, 22:36) *
Here is the asx as passed by clearchannel:

The quotes are fine, as are the angle brackets. You just need to replace the ampersands with entities. In the links. Otherwise, they're not valid. (Unless, somehow, those links actually contain <> or ". Which I doubt.)
Go to the top of the page
+Quote Post
hechacker1
post Jan 10 2010, 01:17
Post #56





Group: Members
Posts: 14
Joined: 5-November 04
Member No.: 17982



QUOTE (kode54 @ Jan 9 2010, 02:47) *
QUOTE (hechacker1 @ Jan 8 2010, 22:36) *
Here is the asx as passed by clearchannel:

The quotes are fine, as are the angle brackets. You just need to replace the ampersands with entities. In the links. Otherwise, they're not valid. (Unless, somehow, those links actually contain <> or ". Which I doubt.)


Ok, I have cleaned up ClearChannel's asx by removing leading and trailing whitespace, and changed & -> &amp;.

See it here:
http://ordorica.org/tune.pl?station=kfi640

mslive can play the new asx returned ok. So can vlc.

But foobar2000 beta6 just says "unsupported file format."

I also tried changing the content type:
#print "Content-Type: video/x-ms-as; charset=iso-8859-1\n\n";
#print "Content-Type: video/x-ms-as\n\n";

I tried with iso-8859 as suggested by this site:

http://www.trollied.org/~blimey/blog.php?i...2008:1203026794

But it made no change for foobar.

Any other suggestions? Finally, is there a way to disable that warning that my components are unsupported?

Thanks

EDIT: I had my script generate an .asx file and host it on my website:
http://ordorica.org/tune.asx

It only gets generated if you call this first:
http://ordorica.org/tune.pl?station=kfi640

And using this I can open a location (CTRL+U) to the .asx and foobar does load and play it!

So it seems foobar has a problem with loading from the content returned from the script itself.

This post has been edited by hechacker1: Jan 10 2010, 01:30
Go to the top of the page
+Quote Post
hechacker1
post Mar 16 2010, 01:40
Post #57





Group: Members
Posts: 14
Joined: 5-November 04
Member No.: 17982



Bump: Because I'm pretty sure the ASX is okay, but it still doesn't work with Foobar 1.0.1.

Alternatively: I am happy to use the mslive input plugin, but could we please get the option to prevent Foobar from nagging about it every time I open Foobar2000?

EDIT: The author of the mslive plugin renamed it to msl to get around the nag. I still wish for an option though.

This post has been edited by hechacker1: Mar 16 2010, 01:46
Go to the top of the page
+Quote Post
joelzhao
post May 25 2010, 02:58
Post #58





Group: Members
Posts: 77
Joined: 24-June 09
From: China
Member No.: 70932



I find a very strange situation, when I add the asx--"http://www.voanews.com/wm/live/newsnow.asx"--which I downloaded to my HDD, it runs well for a period time, but if change to another station and return this station, then it can't playback, and display the message: Unable to open item for playback (IWMReader::Open failed : 拒绝访问。 (0x80070005)):
And the stranger thing is if I add this asx file once again, the situation will occur again. I try this asx file in the media player, it runs well.
Go to the top of the page
+Quote Post
joelzhao
post May 29 2010, 13:26
Post #59





Group: Members
Posts: 77
Joined: 24-June 09
From: China
Member No.: 70932



Does anybody notice that the stream played by FB seems slower - always several seconds - than by media player? Who knows the reason?
Go to the top of the page
+Quote Post
Brazil2
post Apr 25 2012, 11:26
Post #60





Group: Members
Posts: 156
Joined: 9-May 10
Member No.: 80499



QUOTE (Peter @ Dec 1 2009, 00:28) *
What kind of tags and not displayed where? Any specific stations where I can see this behavior?

I'm not getting the Artist and Title tags from these streams:
http://wms.absoluteradio.co.uk/absoluteradio.co.uk/a8_hi
http://wms.absoluteradio.co.uk/absoluteradio.co.uk/vc_hi

It's displaying twice the name of the radio instead.
However it's working fine with AIMP. Any thoughts ?
Go to the top of the page
+Quote Post
Brazil2
post Apr 27 2012, 09:04
Post #61





Group: Members
Posts: 156
Joined: 9-May 10
Member No.: 80499



So, does anyone know a tagged WMA stream which is working fine on foobar ? Or is it still a known missing feature ?
Go to the top of the page
+Quote Post

3 Pages V  < 1 2 3
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 20:02