IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

Issues with ASX streams, Split from: "foobar2000 v1.0 beta 2a"
yandexx
post Nov 27 2009, 18:38
Post #1





Group: Members
Posts: 117
Joined: 11-March 04
From: Russia
Member No.: 12658



foobar2000 v1.0 beta 2a is now out.

Release Notes on foobar2000.org
Download page on foobar2000.org (downloads via BitTorrent protocol)
(Distribution of betas via BitTorrent not up for debate)

Issues fixed in v1.0 beta 2 from the previous beta:
  • New: Converter encodes to .m4a rather than to .mp4.
  • New: Notices for components that no longer serve any purpose.
  • Bug: Certain ASX playlist files are not parsed properly.
  • Bug: Unwanted playlist view scrolling when deleting items in certain scenarios.
  • Bug: cannot bind context menu commands to toolbar buttons.
  • Bug: "initialization failure" errors when making a clean non-portable install rather than upgrading from an earlier version.
  • Bug: possible unnecessary tag reloads on Media Library contents on startup.
  • Bug: doubleclicking the Selection Properties element no longer brings up the Properties dialog.

Beta 2a corrects the issue with foo_uie_biography being mis-detected as one of the obsolete components.


--------------------
stimulating the audio nerve directly
Go to the top of the page
+Quote Post
 
Start new topic
Replies
Cutter
post Nov 27 2009, 20:31
Post #2





Group: Members
Posts: 272
Joined: 3-December 03
Member No.: 10152



QUOTE (yandexx @ Nov 27 2009, 18:38) *
  • Bug: Certain ASX playlist files are not parsed properly.

Thanks for the release.
This ASX stream isn't played by foobar2000: http://www.polskieradio.pl/sluchaj/play.aspx?p=r1
Go to the top of the page
+Quote Post
hechacker1
post Jan 9 2010, 07:36
Post #3





Group: Members
Posts: 14
Joined: 5-November 04
Member No.: 17982



Ok, so I have done extensive work on my perl script that just returns the asx generated by Clear Channel radio streams (asx, mms).

Here is the asx as passed by clearchannel:

http://ordorica.org/tune.pl?station=kfi640

Yes, I tried changing the content type to:
video/x-ms-as

But it doesn't make a difference for foobar. For the purpose of letting you read the script in the browser I don't have a content type set.

So looking at the asx ClearChannel returns, can you tell me what needs to be fixed? I have a subroutine that tries to fix their asx to be more xml like:

'&' => '&',
'<' => '&lt;',
'>' => '&gt;',
'"' => '&quot;'

But doing that change doesn't help foobar load. I also tried just changing the ampersand with no luck. Is some part of the clearchannel asx broken or needs to be rewritten to work with foobar?

Thanks if you can take a look at it. Otherwise I will just have to stick with mslive or use vlc.

I also tried changing my script to 302 redirect foobar2000 to a generated asx file linux (ordorica.org/tune.asx), but it made no difference.

This post has been edited by hechacker1: Jan 9 2010, 07:38
Go to the top of the page
+Quote Post
kode54
post Jan 9 2010, 10:47
Post #4





Group: Admin
Posts: 4693
Joined: 15-December 02
Member No.: 4082



QUOTE (hechacker1 @ Jan 8 2010, 22:36) *
Here is the asx as passed by clearchannel:

The quotes are fine, as are the angle brackets. You just need to replace the ampersands with entities. In the links. Otherwise, they're not valid. (Unless, somehow, those links actually contain <> or ". Which I doubt.)
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th December 2014 - 05:38