IPB

Welcome Guest ( Log In | Register )

24 Pages V  « < 7 8 9 10 11 > »   
Reply to this topicStart new topic
WMP Tag Plus - MPEG4, Vorbis and FLAC metadata support for WMP
Tim De Baets
post Nov 26 2010, 21:38
Post #201


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Thank you for uploading the file. This seems to be a problem with TagLib, the tagging library that WMP Tag Plus uses, so I have reported this at its bug tracker. That will allow the TagLib developers to take a look at it, and hopefully, they will come up with a fix.

It would also be interesting to know how exactly these WavPack files were created (by which application etc.).
Go to the top of the page
+Quote Post
Tim De Baets
post Nov 28 2010, 18:24
Post #202


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Good news: the main TagLib developer, Lukas Lalinsky, has already fixed the problem. Unfortunately, I'm currently too busy with Windows Media Player Plus! 2.0 to prepare a new release of WMP Tag Plus, and to do all the required testing.

If you don't want to wait for the next WMP Tag Plus release to have this fixed, you can already download the newer version of TagLibTagSupport.dll here (edit: link removed - this fix is now included in WMP Tag Plus). Just unzip it, and replace the old version of that file with this one. Then start WMP, and re-add the WavPack files to library once more.

Note that this newer version hasn't been extensively tested, so it may still be causing other issues that I don't know about yet.

This post has been edited by Tim De Baets: Dec 15 2012, 16:37
Go to the top of the page
+Quote Post
jonnny
post Nov 30 2010, 09:36
Post #203





Group: Members
Posts: 3
Joined: 30-November 10
Member No.: 86117



Hi Tim,

Great work on WMP Tag Plus.

I have an issue. When I first install it, it works great, plays flac files, lists the music in WMP.

When I close WMP and re-open, the files are still listed in WMP but wont play "Windows Media Player cannot play this file"

I have re-downloaded and re-installed several times. I have rebuilt my music library. I am at a loss now.

Any ideas?

Cheers
Go to the top of the page
+Quote Post
Tim De Baets
post Nov 30 2010, 20:38
Post #204


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



What version of WMP and Windows? What's the full text of that error message?

Which codec do you have installed for playing FLAC files? After re-opening WMP, open the Tools - Plug-ins menu (press Ctrl+M if you don't see the Tools menu). Do you still see WMP Tag Plus listed there?
Go to the top of the page
+Quote Post
jonnny
post Dec 1 2010, 00:35
Post #205





Group: Members
Posts: 3
Joined: 30-November 10
Member No.: 86117



Sorry, I should have put this smile.gif

Win7-64bit, WMP 12, i think i have the shark 007 codec installed (at work at the moment).

Like I said, it works fine when I first install TagPlus but once i close WMP and re-open, WMPTagPlus is no longer in the plugin menu and FLAC flies will not play - "Windows Media Player cannot play this file". Sorry, I cant remember the whole message, at work smile.gif

Thanks
Go to the top of the page
+Quote Post
Tim De Baets
post Dec 1 2010, 17:33
Post #206


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



It sounds to me like you're running the (non-default) 64-bit version of WMP. WMP Tag Plus isn't compatible with this version. Likewise, you probably installed only the 32-bit version of Shark's codecs, which would explain why FLAC playback doesn't work either.

To check if this is really the case, you can start the 32-bit version of WMP, by manually running C:\Program Files (x86)\Windows Media Player\wmplayer.exe. If you do that, is WMP Tag Plus listed in the Plug-ins menu again, and does FLAC playback work correctly?
Go to the top of the page
+Quote Post
jonnny
post Dec 2 2010, 09:11
Post #207





Group: Members
Posts: 3
Joined: 30-November 10
Member No.: 86117



Hehe!

That was it! I should have been using the wmplayer.exe from ProgramFiles (x86).

Works fine even after closing now.

Thanks Tim!
Go to the top of the page
+Quote Post
Pedrozo
post Dec 2 2010, 11:32
Post #208





Group: Members
Posts: 9
Joined: 3-May 10
From: Poland
Member No.: 80374



Does WMP Tag Plus supports the ratings in FLAC? I mean does it save STARS? When I rebuild library my mp3 saving STARS but not my FLAC files. Its normal? Thx for reply.
Go to the top of the page
+Quote Post
Tim De Baets
post Dec 2 2010, 15:46
Post #209


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Yes, that's normal. WMP Tag Plus doesn't save the star ratings to FLAC, or to any other format that it supports, regardless of whether Maintain my star ratings as global ratings in files is checked in WMP's Options.

This is mainly because none of the formats provide any (de facto) standard tag for storing ratings in. I might let a future version of WMP Tag Plus store the ratings in a custom field, but I'm still unsure of this. Ratings are user-specific info, and this generally shouldn't be stored in the music files. Also, I don't think that there's any media player besides WMP that does this.
Go to the top of the page
+Quote Post
Pedrozo
post Dec 2 2010, 16:11
Post #210





Group: Members
Posts: 9
Joined: 3-May 10
From: Poland
Member No.: 80374



Than you for your reply. I reading about this problem in Internet, and I see many users have same problem with saving ratings. Not only in WMP but other programs too. I think, rating option in new WMP Tag Plus in necessary. You can add option, that gives choice about "Select, if you want save global rating to your file" or something like that. Sorry for my english...
Go to the top of the page
+Quote Post
Tim De Baets
post Dec 2 2010, 21:32
Post #211


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Well, I'll think about it, that's all I can say for now. The more people that request ratings to be saved to file, the more likely that this will be included in a next version.

In the meantime, you can already use the Metadata Backup tool to import/export WMP star ratings.

An additional WMP Tag Plus option for saving ratings wouldn't be necessary, the existing one in WMP's own options would probably work fine.
Go to the top of the page
+Quote Post
cosmos
post Dec 3 2010, 05:08
Post #212





Group: Members
Posts: 4
Joined: 3-December 10
Member No.: 86204



hi,,dude,,you really did a nice work,,wmp tag plus is perfect,,i like it so much,,it works like a charm with wmp12,,now i have a little problem with wmp11 when playing flac format file,,running on windows server 2008,,it can be seekable,,but the progress bar doesn't work,and no duration,could you please correct it? thanks in advance!
i cant upload screenshot here:(,,,

Go to the top of the page
+Quote Post
cosmos
post Dec 3 2010, 05:15
Post #213





Group: Members
Posts: 4
Joined: 3-December 10
Member No.: 86204



again,,i tried version 1.1,,the same,,and it was all fresh installation,,i really like you can solve for me,,thanks!
Go to the top of the page
+Quote Post
cosmos
post Dec 3 2010, 06:16
Post #214





Group: Members
Posts: 4
Joined: 3-December 10
Member No.: 86204



SOLVED!! laugh.gif laugh.gif cool.gifI just update my K-Lite mega codec pack to 6.5,,it works like a charm,,,,,once again,,thanks Tim for providing so nice WMP plugin,,,
Go to the top of the page
+Quote Post
darkane
post Dec 11 2010, 14:13
Post #215





Group: Members
Posts: 3
Joined: 20-November 10
Member No.: 85862



QUOTE (Tim De Baets @ Nov 28 2010, 19:24) *
Good news: the main TagLib developer, Lukas Lalinsky, has already fixed the problem. Unfortunately, I'm currently too busy with Windows Media Player Plus! 2.0 to prepare a new release of WMP Tag Plus, and to do all the required testing.

If you don't want to wait for the next WMP Tag Plus release to have this fixed, you can already download the newer version of TagLibTagSupport.dll here. Just unzip it, and replace the old version of that file with this one. Then start WMP, and re-add the WavPack files to library once more.

Note that this newer version hasn't been extensively tested, so it may still be causing other issues that I don't know about yet.

thanks alot tim the dll file worked great and i dont see any issues so far for the applications used to make the WV files it appears to be
EAC0.99 from the log file included i got the following data
EXTRACTOR: EAC 0.99 Prebeta4
READ MODE: Secure with NO C2, accurate stream, disable cache
CODEC: WavPack 4.50
SOURCE: Original CD
apparently i didnt rip it my self so i hope this data is helpful and good luck on all your projects
Go to the top of the page
+Quote Post
WonderCsabo
post Dec 30 2010, 18:48
Post #216





Group: Members
Posts: 23
Joined: 1-October 10
Member No.: 84271



Hi Tim!

What about the new release with FLAC cover support?
Go to the top of the page
+Quote Post
Tim De Baets
post Dec 31 2010, 16:01
Post #217


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Truth is, I still haven't even started working on the next major release of WMP Tag Plus.

Early October, I said that I was hoping to release the new WMP Tag Plus before the end of this year. Unfortunately, due to unexpected difficulties with the development of Windows Media Player Plus! 2.0, this has been delayed by at least 6 months.
Go to the top of the page
+Quote Post
WonderCsabo
post Jan 11 2011, 18:08
Post #218





Group: Members
Posts: 23
Joined: 1-October 10
Member No.: 84271



Uhh, that is very much time... crying.gif Good luck with the work!

(keep in your mind that i can help you with Hungarian l10n, if needed)
Go to the top of the page
+Quote Post
Stone Free
post Jan 15 2011, 23:28
Post #219





Group: Members
Posts: 57
Joined: 24-September 04
From: London
Member No.: 17277



I'm not sure whether it is the installation of this program, or whether its a new Windows 7 feature.

I've always wanted FLAC and AAC files to show their tag information in the standard windows columns of Artist etc, but had to put up with columns such as "Audio Artist" as AudioShell seemed to be the only thing that would show FLAC tags in windows.

Is it this plugin that has solved the problem?
Go to the top of the page
+Quote Post
Tim De Baets
post Jan 16 2011, 14:43
Post #220


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



If you are talking about the columns in Windows Explorer, then no, WMP Tag Plus will add additional tag support to WMP only.

To get FLAC tag support in Explorer, you can install this FLAC Property Handler. You shouldn't have to install anything for AAC, as Windows 7 already supports that format by default.
Go to the top of the page
+Quote Post
Stone Free
post Jan 16 2011, 14:57
Post #221





Group: Members
Posts: 57
Joined: 24-September 04
From: London
Member No.: 17277



QUOTE (Tim De Baets @ Jan 16 2011, 13:43) *
If you are talking about the columns in Windows Explorer, then no, WMP Tag Plus will add additional tag support to WMP only.

To get FLAC tag support in Explorer, you can install this FLAC Property Handler. You shouldn't have to install anything for AAC, as Windows 7 already supports that format by default.
Strange, I seem to have working tags in Explorer!

The only other thing I've installed is the Xiph.Org codecs.
Go to the top of the page
+Quote Post
Asuranceturix
post Jan 19 2011, 03:46
Post #222





Group: Members
Posts: 1
Joined: 19-January 11
Member No.: 87440



Hi, I have just installed WMP Tag Plus and it works beautifully with Windows Media Center. I want to use my classical music collection, where each track has a discrete ARTIST tag per performer (per recommendation at http://www.xiph.org/vorbis/doc/v-comment.html ). However, WMC only appears to be aware of the first ARTIST tag in each track. Is this the expected behaviour? Is there any way to get it to read all of them, so that a track can be found when searching for any of the participating performers? Thanks!
Go to the top of the page
+Quote Post
Tim De Baets
post Jan 19 2011, 19:52
Post #223


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Yes, that's the expected behaviour. WMP Tag Plus currently doesn't support tags with multiple values, and will only read the first value of such tags. Multiple value support is something that might be added in a future version.

This post has been edited by Tim De Baets: Jan 21 2011, 13:19
Go to the top of the page
+Quote Post
jbrid
post Jan 26 2011, 00:37
Post #224





Group: Members
Posts: 5
Joined: 26-January 11
Member No.: 87669



Hi Tim,
Thanks for your great work on this plugin. I am trying to troubleshoot an issue and I am hoping you can help.

I have added FLAC versions of the 16 Beatles albums to my music library. WMP recognizes the tags in about half of the albums. I have tried removing them from the library and re-adding them. I have also examined the flac tags using metaflac.

This song is working
CODE
METADATA block #2
  type: 4 (VORBIS_COMMENT)
  is last: false
  length: 180
  vendor string: reference libFLAC 1.2.0 20070715
  comments: 6
    comment[0]: artist=The Beatles
    comment[1]: title=There's A Place
    comment[2]: album=Please Please Me (2009 Stereo Remaster)
    comment[3]: date=2009
    comment[4]: tracknumber=13
    comment[5]: genre=Pop


This song is not working
CODE
METADATA block #2
  type: 4 (VORBIS_COMMENT)
  is last: false
  length: 175
  vendor string: reference libFLAC 1.2.0 20070715
  comments: 6
    comment[0]: artist=The Beatles
    comment[1]: title=Love Me Do
    comment[2]: album=Please Please Me (2009 Stereo Remaster)
    comment[3]: date=2009
    comment[4]: tracknumber=08
    comment[5]: genre=Pop


Anything else I can do to troubleshoot this?

Here is my system info:

OS: Win7 Ultimate x64
WMP: 12.0.7600.16667 (I have tested the x86 and x64 versions. Both have same symptoms)
Codec Pack:Shark007 2.7.6 + x64 Component

Thanks!
Go to the top of the page
+Quote Post
Tim De Baets
post Jan 26 2011, 17:20
Post #225


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



WMP Tag Plus definitely won't work in the x64 version of WMP, so it's recommended that you only use the x86 version.

Do you have the latest version of WMP Tag Plus, 1.2?

Are you sure that WMP Tag Plus is loaded in WMP? The plug-in should be listed in the Tools - Plug-ins menu, and should have a checkmark next to it (press Ctrl+M if you don't see the Tools menu). If you have any other tag support plug-ins for WMP installed, remove these to prevent conflicts. After that, please try re-adding the files to the library once again.
Go to the top of the page
+Quote Post

24 Pages V  « < 7 8 9 10 11 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th September 2014 - 03:17