IPB

Welcome Guest ( Log In | Register )

24 Pages V  « < 16 17 18 19 20 > »   
Reply to this topicStart new topic
WMP Tag Plus - MPEG4, Vorbis and FLAC metadata support for WMP
zafer
post May 27 2012, 11:34
Post #426





Group: Members
Posts: 18
Joined: 7-March 10
Member No.: 78806



Hi Tim, Hi everyone here wink.gif

Firstly, thousands thanks for including musepack support in this release. Finally, a stable plug-in, and very fast. Thanks for the great work Tim, and everybody who helped testing!

I just made several tests, using mpc tunes.
I still have no time length tags imported from the musepack tunes.
I also noted that the "Album Artist" tag is not imported (I tried both with "compilation" tag set top 1 or left empty).

How can I be of any help to solve those ?

Running Windows 7 x86, WMP12.
Go to the top of the page
+Quote Post
Tim De Baets
post May 28 2012, 14:06
Post #427


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



QUOTE (andrewfg @ May 27 2012, 11:57) *
There is certainly some indirection, but I don't think it is via folder.jpg Otherwise different tracks in the same folder would show the same cover art -- which is not the observed case.

Is it possible to use Play To without WMP running at all, i.e. by choosing it from Explorer's context menu?

Besides Folder.jpg, there are also AlbumArt_{GUID}_* files that allow tracks in the same folder to have different album art. The GUID in these filenames is the content of the song's WM/WMCollectionID tag, which can be viewed with the tag editor of my Windows Media Player Plus! plug-in (on the Advanced tab).

Then there's also WMP's album art cache in %LOCALAPPDATA%\Microsoft\Media Player\Art Cache\LocalMLS, but these should just all be cached copies of the Folder.jpg and AlbumArt_* files.

By the way, I'm still confused by the fact that you're not reporting the same troublesome track as wigster did. Wigster, could you please shed some light on this?

QUOTE (zafer @ May 27 2012, 12:34) *
I still have no time length tags imported from the musepack tunes.
I also noted that the "Album Artist" tag is not imported (I tried both with "compilation" tag set top 1 or left empty).

Please try re-adding the MPC files to the library. Make sure that WMP Tag Plus is checked in Tools - Plug-ins, select the MPC files, right-click, Delete - Delete from library only - OK. Then go to Tools - Advanced and select Restore deleted library items.

If that doesn't help, how were these files created? Would it be possible to upload one of these files through something like http://www.yousendit.com, and PM me the download link? Thanks!
Go to the top of the page
+Quote Post
zafer
post May 28 2012, 16:03
Post #428





Group: Members
Posts: 18
Joined: 7-March 10
Member No.: 78806



QUOTE (Tim De Baets @ May 28 2012, 14:06) *
If that doesn't help, how were these files created? Would it be possible to upload one of these files through something like http://www.yousendit.com, and PM me the download link? Thanks!


Hey Tim, thanks for replying so soon.

I tested the issue thouroughly. I did what you told me to do, and I still get no length reading in the library. Prior to that (yesterday) I had WMP rescan all the library (dy deleting the database files in %userprofile%\Local Settings\Application Data\Microsoft\Media Player).
So I checked the issue several times.

Here is what I got :
- Song Title, Artist, Album, Year, Track Number, Genre : those are read OK
- length : not read
- Rating : not read
- Album Artist : not read. It reads Artist instead, and according to file/folder context, it sets Album Artist = Artist OR Various Artists
- Compilation (value 0 or 1) not read or ignored (but that is perhaps not an issue).

Just PMed you with the link to a test file (musepack)

Thanks, Zafer.
Go to the top of the page
+Quote Post
zafer
post May 28 2012, 17:52
Post #429





Group: Members
Posts: 18
Joined: 7-March 10
Member No.: 78806



Hey Tim, this could be useful : it seems that (for mpc tunes) the plug-in sends length data to the library, but incorrect format or null.
Because now, I can't seek in the tune even if I open the tune from Explorer instead of WMP library.
When I do so (ie open an mpc tune from Explorer), I see the length information which disappears almost immediately, which would mean, I guess, that Explorer sends legnth information properly, which is immediately superseded by the data in the library.
Which means that the length tag is present in the library, but incorrect. Am I right ?
Go to the top of the page
+Quote Post
Tim De Baets
post May 28 2012, 20:29
Post #430


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Thank you for uploading the file. By looking at the file's tags, I see that it has been created by MAGIX Samplitude. Is this correct?

TagLib, the tagging library that WMP Tag Plus uses, also returns a track length of zero. This probably points to a bug in TagLib which might be related to the Musepack SV8 format. I have filed a bug here.

Ratings are never read by WMP Tag Plus. This is by design, as rating is something personal that should not be stored in music files. WMP Tag Plus currently doesn't read Compilation either.

Album artist isn't read because WMP Tag Plus looks for an ALBUM ARTIST tag, while the file you uploaded contains ALBUMARTIST (without the space). According to this page, the name with space should be used. However, these tag names are all but standard or fixed, and I might add support for the name without space as well in a future version - as is currently already the case for FLAC/Vorbis tags.
Go to the top of the page
+Quote Post
zafer
post May 28 2012, 21:41
Post #431





Group: Members
Posts: 18
Joined: 7-March 10
Member No.: 78806



QUOTE (Tim De Baets @ May 28 2012, 20:29) *
Thank you for uploading the file. By looking at the file's tags, I see that it has been created by MAGIX Samplitude. Is this correct?

TagLib, the tagging library that WMP Tag Plus uses, also returns a track length of zero. This probably points to a bug in TagLib which might be related to the Musepack SV8 format. I have filed a bug].

Exactly;) it was exported from Samplitude, then compressed using dBPowerAmp which keeps the tags while converting, and thank you very much for filing the bug smile.gif I've just made some SV7 files : length tag was read properly. As you said, the issue is related to sv8 only.

QUOTE (Tim De Baets @ May 28 2012, 20:29) *
Ratings are never read by WMP Tag Plus. This is by design, as rating is something personal that should not be stored in music files. WMP Tag Plus currently doesn't read Compilation either.

It is logical, indeed. I guess I took the bad habit of setting the rating in the file's header because I had to reset the library database very often due to frequent problems with the older tag plug-in that I had no choice but to use. Thanks for the info wink.gif

QUOTE (Tim De Baets @ May 28 2012, 20:29) *
Album artist isn't read because WMP Tag Plus looks for an ALBUM ARTIST tag, while the file you uploaded contains ALBUMARTIST (without the space). (...) I might add support for the name without space as well in a future version - as is currently already the case for FLAC/Vorbis tags.

Well thanks, and now I'll stick to the current version since it is very stable, and wait for next update.
Again many Thanks and Regards.


Go to the top of the page
+Quote Post
Tim De Baets
post Jun 2 2012, 20:34
Post #432


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Announcement: WMP Tag Plus 2.1 has been released. This minor update fixes a possible crash when closing WMP on Windows 7 (as reported earlier in this thread by Lieuandy). Updating is recommended if you're running Windows 7.
Go to the top of the page
+Quote Post
andrewfg
post Jun 9 2012, 17:30
Post #433





Group: Members
Posts: 84
Joined: 12-May 08
Member No.: 53478



The following question to Tim is perhaps not directly related to WMP Tag Plus...

By default WMP loads M4A tracks into the "Other Media" folder. And in WMP Tag Plus you did some magic to persuade WMP that M4A files shall be loaded into the "Music" folder instead.

And also by default WMP loads AIFF tracks into the "Other Media" folder too. This is odd, because WMP can in fact natively play AIFF tracks. So my question is how would one apply the same magic that you used on M4A files to persuade WMP also that AIFF files shall be loaded into the "Music" folder?


--------------------
AndrewFG (Whitebear -- http://www.whitebear.ch/mediaserver )
Go to the top of the page
+Quote Post
Tim De Baets
post Jun 11 2012, 10:15
Post #434


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



The question isn't related to M4A files either, because there the library classification depends on the format of the audio stream within the file. While for AIFF, WMP is probably just set to classify that file extension as Other Media.

To change this setting, you could try adding the .aiff extension on the Extensions tab of WMP Tag Plus settings and restarting WMP (it doesn't matter which tag format you select - it will be ignored anyway). If that doesn't help then please create a new thread at Hydrogenaudio or in the Windows 7 Media forum, as this is unrelated to WMP Tag Plus.
Go to the top of the page
+Quote Post
andrewfg
post Jun 11 2012, 12:55
Post #435





Group: Members
Posts: 84
Joined: 12-May 08
Member No.: 53478



QUOTE (Tim De Baets @ Jun 11 2012, 11:15) *
If that doesn't help then please create a new thread at Hydrogenaudio or in the Windows 7 Media forum, as this is unrelated to WMP Tag Plus.

Yes I know the post was OT. Sorry for that.

QUOTE (Tim De Baets @ Jun 11 2012, 11:15) *
The question isn't related to M4A files either, because there the library classification depends on the format of the audio stream within the file. While for AIFF, WMP is probably just set to classify that file extension as Other Media.

Notwithstanding the OT nature of my question, could you please explain what you do in WMP Tag Plus to persuade WMP12 that M4A files with ALAC payloads shall be classified as Music rather than Other Media?

QUOTE (Tim De Baets @ Jun 11 2012, 11:15) *
To change this setting, you could try adding the .aiff extension on the Extensions tab of WMP Tag Plus settings and restarting WMP (it doesn't matter which tag format you select - it will be ignored anyway).

That is a cool idea. I will give it a try.

PS I found one of your earlier posts about hacking the file extension entries for WMP12 in
CODE
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\] and/or
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\MLS\Extensions]
but that did not work. However after googling some more, it seems that since I have WIN7 64bit, I may need to hack
CODE
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Multimedia\WMPlayer\Extensions\] and/or
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\MediaPlayer\MLS\Extensions]
so I will keep you posted on this...


--------------------
AndrewFG (Whitebear -- http://www.whitebear.ch/mediaserver )
Go to the top of the page
+Quote Post
Steve Forte Rio
post Jun 11 2012, 14:50
Post #436





Group: Members
Posts: 443
Joined: 4-October 08
From: Ukraine
Member No.: 59301



Hi there. I have installed WMP Tag Plus 2.1 and the MONOGRAM Musepack DirectShow Decoder v0.9.2.0 / Splitter v0.4.0.0. WMP plays mpc files but it does not show the playback progress and I can't seek mpc files. Does anyone know why? WIndows 7 x64 SP1, fully updated.

also WMP does not show Metadata fields for APE files converted with foobar2000... Maybe it doesn't support some tagging schemes like APE or ID3v1?

This post has been edited by Steve Forte Rio: Jun 11 2012, 14:55
Go to the top of the page
+Quote Post
Tim De Baets
post Jun 11 2012, 16:17
Post #437


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



QUOTE (Steve Forte Rio @ Jun 11 2012, 15:50) *
Hi there. I have installed WMP Tag Plus 2.1 and the MONOGRAM Musepack DirectShow Decoder v0.9.2.0 / Splitter v0.4.0.0. WMP plays mpc files but it does not show the playback progress and I can't seek mpc files. Does anyone know why? WIndows 7 x64 SP1, fully updated.

also WMP does not show Metadata fields for APE files converted with foobar2000... Maybe it doesn't support some tagging schemes like APE or ID3v1?

In WMP, please go to Tools - Options - Plug-ins - Background - WMP Tag Plus - Properties - Tools, and click Refresh song tags (press Ctrl+M if you don't see the Tools menu). Does the scan pick up these MPC/APE songs and are the issues fixed after the songs' tags have been refreshed?

QUOTE (andrewfg @ Jun 11 2012, 13:55) *
Notwithstanding the OT nature of my question, could you please explain what you do in WMP Tag Plus to persuade WMP12 that M4A files with ALAC payloads shall be classified as Music rather than Other Media?

For determining the format of the audio stream within an M4A file, WMP 12 retrieves the System.Audio.Format property of such files. For files containing an AAC stream, the value of this property will be the MFAudioFormat_AAC GUID defined in the Windows SDK:

{00001610-0000-0010-8000-00AA00389B71}

But for files containing an ALAC stream, the value will be different:

{616C6163-767A-494D-B478-F29D25DC9037}

(see this thread for more info on how this GUID is generated)

WMP Tag Plus hooks into WMP's retrieval of this property, and when it sees the ALAC GUID being returned, it replaces it by the AAC GUID, thereby 'fooling' WMP into thinking that it's handling an AAC M4A file.
Go to the top of the page
+Quote Post
Steve Forte Rio
post Jun 11 2012, 19:27
Post #438





Group: Members
Posts: 443
Joined: 4-October 08
From: Ukraine
Member No.: 59301



QUOTE (Tim De Baets @ Jun 11 2012, 13:17) *
Does the scan pick up these MPC/APE songs and are the issues fixed after the songs' tags have been refreshed?


No and no. No tags can be read for APE and MPC seeking doesn't work , like it was before.
Go to the top of the page
+Quote Post
Tim De Baets
post Jun 11 2012, 21:01
Post #439


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Are the MPC files perhaps in the (newer) Musepack SV8 format? You can check this with Mp3tag. WMP Tag Plus relies on TagLib, which currently only supports the SV7 format. See here for the corresponding TagLib bug report.

How exactly did you generate the APE files with foobar2000? I don't see any built-in support for converting to APE and could only find a Monkey's Audio decoder.
Go to the top of the page
+Quote Post
Steve Forte Rio
post Jun 11 2012, 23:23
Post #440





Group: Members
Posts: 443
Joined: 4-October 08
From: Ukraine
Member No.: 59301



QUOTE (Tim De Baets @ Jun 11 2012, 18:01) *
Are the MPC files perhaps in the (newer) Musepack SV8 format? You can check this with Mp3tag. WMP Tag Plus relies on TagLib, which currently only supports the SV7 format. See here for the corresponding TagLib bug report.

How exactly did you generate the APE files with foobar2000? I don't see any built-in support for converting to APE and could only find a Monkey's Audio decoder.


Yes, of course, SV8. It's a pity if so...

foobar2000 converter setup:

MAC.exe (Monkey's Audio Console Front End v 4.10)
%s %d -c5000

This post has been edited by Steve Forte Rio: Jun 11 2012, 23:23
Go to the top of the page
+Quote Post
andrewfg
post Jun 13 2012, 06:51
Post #441





Group: Members
Posts: 84
Joined: 12-May 08
Member No.: 53478



QUOTE (Tim De Baets @ Jun 11 2012, 17:17) *
WMP Tag Plus hooks into WMP's retrieval of this property, and when it sees the ALAC GUID being returned, it replaces it by the AAC GUID, thereby 'fooling' WMP into thinking that it's handling an AAC M4A file.

Ok. Thanks for the insight. The conclusion for me is that I shall put it into the "too difficult" category and not pursue this topic further.


--------------------
AndrewFG (Whitebear -- http://www.whitebear.ch/mediaserver )
Go to the top of the page
+Quote Post
Tim De Baets
post Jun 13 2012, 14:18
Post #442


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



QUOTE (Steve Forte Rio @ Jun 12 2012, 00:23) *
foobar2000 converter setup:

MAC.exe (Monkey's Audio Console Front End v 4.10)
%s %d -c5000

I have just tried this myself and it's normal that no tags appear for these APE files in WMP, as no tags are added when the files are generated that way. The only thing that does appear in WMP is the song length of the files.

If you check the files with Mp3tag then you shouldn't see any tags there either.

This post has been edited by Tim De Baets: Jun 13 2012, 14:18
Go to the top of the page
+Quote Post
Steve Forte Rio
post Jun 13 2012, 18:46
Post #443





Group: Members
Posts: 443
Joined: 4-October 08
From: Ukraine
Member No.: 59301



QUOTE (Tim De Baets @ Jun 13 2012, 11:18) *
QUOTE (Steve Forte Rio @ Jun 12 2012, 00:23) *
foobar2000 converter setup:

MAC.exe (Monkey's Audio Console Front End v 4.10)
%s %d -c5000

I have just tried this myself and it's normal that no tags appear for these APE files in WMP, as no tags are added when the files are generated that way. The only thing that does appear in WMP is the song length of the files.

If you check the files with Mp3tag then you shouldn't see any tags there either.


But why? foobar2000 copies all tags from source to destination file. And it displays all tags such as artist and title for the resulting track (APEv2) unlike the WMP =\
Go to the top of the page
+Quote Post
Tim De Baets
post Jun 13 2012, 19:16
Post #444


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Foobar2000 certainly didn't do that in my test, so please check with Mp3tag.
Go to the top of the page
+Quote Post
Steve Forte Rio
post Jun 13 2012, 20:59
Post #445





Group: Members
Posts: 443
Joined: 4-October 08
From: Ukraine
Member No.: 59301



QUOTE (Tim De Baets @ Jun 13 2012, 16:16) *
Foobar2000 certainly didn't do that in my test, so please check with Mp3tag.


Mp3Tag also shows all the tags and APEv2.
Go to the top of the page
+Quote Post
Tim De Baets
post Jun 14 2012, 14:37
Post #446


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Please try re-adding the APE files to the library. Make sure that WMP Tag Plus is checked in Tools - Plug-ins, select the files in the library, right-click, Delete - Delete from library only - OK. Then go to Tools - Advanced and select Restore deleted library items.

If that doesn't help, would it be possible to upload one of these files through something like http://www.yousendit.com, and PM me the download link? Thanks!
Go to the top of the page
+Quote Post
Steve Forte Rio
post Jun 14 2012, 17:48
Post #447





Group: Members
Posts: 443
Joined: 4-October 08
From: Ukraine
Member No.: 59301



QUOTE (Tim De Baets @ Jun 14 2012, 11:37) *
Please try re-adding the APE files to the library. Make sure that WMP Tag Plus is checked in Tools - Plug-ins, select the files in the library, right-click, Delete - Delete from library only - OK. Then go to Tools - Advanced and select Restore deleted library items.

If that doesn't help, would it be possible to upload one of these files through something like http://www.yousendit.com, and PM me the download link? Thanks!


Don't know about library, usually I don't use WMP, I simply added this file to WMP playlist.
**
Ok, now I added it to the WMP library, nothing has changed.

Well, here's my APE file. I wrote tags artist and title to it, they are visible in foobar2000, Mp3Tag, but not in WMP.

This post has been edited by Steve Forte Rio: Jun 14 2012, 17:58
Go to the top of the page
+Quote Post
Tim De Baets
post Jun 15 2012, 17:24
Post #448


Author of WMPCDText


Group: Developer
Posts: 394
Joined: 13-August 07
Member No.: 46161



Thanks for uploading the APE file. I have just added it to WMP's library on my Windows 7 system and WMP Tag Plus picks up its tags just fine. Are you *really* sure that WMP Tag Plus was checked in Tools - Plug-ins when you added the file to your library?

Also, please make sure that ape is listed in WMP Tag Plus settings - Extensions and that it is set to Monkey's Audio (APE). On the Formats tab, the Monkey's Audio (APE) item should be checked as well.

If that still doesn't help, reinstalling WMP Tag Plus might.
Go to the top of the page
+Quote Post
Steve Forte Rio
post Jun 15 2012, 18:15
Post #449





Group: Members
Posts: 443
Joined: 4-October 08
From: Ukraine
Member No.: 59301



Seems like reinstalling solved the problem.

It's very strange, because everything was ok with all other formats.

This post has been edited by Steve Forte Rio: Jun 15 2012, 18:24
Go to the top of the page
+Quote Post
mjb2006
post Jul 7 2012, 10:11
Post #450





Group: Members
Posts: 790
Joined: 12-May 06
From: Colorado, USA
Member No.: 30694



I'm installing WMP Tag Plus for the first time. I got the dialog that says "WMP Tag Plus has detected that your media library contains songs of the newly supported formats and that Windows Media Player hasn't read any tags for these songs yet. WMP Tag Plus can refresh the tags of these songs. This means that the songs will be re-added to the library. All their current tags including star ratings and play counts will be preserved."

This makes it sound like the audio files are going to be modified. Are they?
If they do have to change, are the last-modified dates preserved?
Does any other function of WMP Tag Plus modify the files?
Go to the top of the page
+Quote Post

24 Pages V  « < 16 17 18 19 20 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st September 2014 - 15:42