IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
foo_run and the album art downloader
auldyin
post Feb 12 2009, 18:19
Post #1





Group: Members
Posts: 252
Joined: 29-September 01
Member No.: 48



Can one of you very kind chaps tell me how to install the coverdownloader plugin (is it a plugin?), along with foo_run into Foobar.
I get a 410 error message with Amazon and a parameter not valid error with iTunes Music Store

Help
Go to the top of the page
+Quote Post
Mar2zz
post Feb 12 2009, 18:52
Post #2





Group: Members
Posts: 669
Joined: 5-September 07
From: Netherlands
Member No.: 46810



I use this for covers
CODE
"C:\Program Files\foobar2000\Album Art Downloader\AlbumArt.exe" /ar "%artist%" /al "%album%" /mn 300 /mx 1000 /path "$replace(%_path%,%_filename_ext%,)folder.jpg"


and this for artist.jpg
CODE
"C:\Program Files\foobar2000\Album Art Downloader\AlbumArt.exe" /sources "LastFM Artist" /ar "%artist%" /mn 300 /mx 1000 /path "$replace(%_path%,%_filename_ext%,)artist.jpg"


this for discimage or back
CODE
"C:\Program Files\foobar2000\Album Art Downloader\AlbumArt.exe" /sources "Discogs,Coveralia" /ar "%artist%" /al "%album%" /mn 300 /mx 1000 /path "$replace(%_path%,%_filename_ext%,)back.jpg"


The 410 error I have not seen before.

This post has been edited by Mar2zz: Feb 12 2009, 18:53


--------------------
http://www.youtube.com/watch?v=whoj6BOSfE4 (foob.fm)
Go to the top of the page
+Quote Post
auldyin
post Feb 12 2009, 20:56
Post #3





Group: Members
Posts: 252
Joined: 29-September 01
Member No.: 48



Thanks!

Problem is that I don't know what to do with these "Codes"

Help would be much appreciated

Cheers
Go to the top of the page
+Quote Post
Mar2zz
post Feb 12 2009, 21:44
Post #4





Group: Members
Posts: 669
Joined: 5-September 07
From: Netherlands
Member No.: 46810



install foo_run. go to preferences > tools > run services.
there you can add these codes and then run them from contextmenu. select a song, choose the run service (for example find cover) and album art downloader will start, search for covers, and you choose one and it will save it for you in the folder the song is in.


--------------------
http://www.youtube.com/watch?v=whoj6BOSfE4 (foob.fm)
Go to the top of the page
+Quote Post
yorch
post Feb 12 2009, 22:31
Post #5





Group: Members
Posts: 1
Joined: 23-October 08
Member No.: 60789



Hi,

Do you happen to know a way to save the cover image to the file tags?

Thanks.
Go to the top of the page
+Quote Post
drbeachboy
post Feb 13 2009, 03:22
Post #6





Group: Members
Posts: 500
Joined: 22-October 04
From: Southern NJ
Member No.: 17776



When I use the code below in VISTA 64 bit I cannot get the program to run.
CODE
"C:\Program Files (x86)\AlbumArtDownloader\AlbumArt.exe" /ar "%artist%" /al "%album%" /mn 300 /mx 1000 /path "$replace(%_path%,%_filename_ext%,)front.jpg"

If I remove the path from foo_run and place it in my environment PATH, it works fine with the code below.
CODE
AlbumArt.exe /ar "%artist%" /al "%album%" /mn 300 /mx 1000 /path "$replace(%_path%,%_filename_ext%,)front.jpg"


Is there a way to get this to run keeping the file path in foo_run?


--------------------
Surf's Up!
"Columnated Ruins Domino"
Go to the top of the page
+Quote Post
drbeachboy
post Feb 13 2009, 05:07
Post #7





Group: Members
Posts: 500
Joined: 22-October 04
From: Southern NJ
Member No.: 17776



I did get this to work:
CODE
C:\Progra~2\AlbumArtDownloader\AlbumArt.exe /ar "%artist%" /al "%album%" /mn 300 /mx 1000 /path "$replace(%_path%,%_filename_ext%,)front.jpg"
without quotes in the path. I still have not been able to get to work using the full path name.


--------------------
Surf's Up!
"Columnated Ruins Domino"
Go to the top of the page
+Quote Post
Mar2zz
post Feb 13 2009, 08:28
Post #8





Group: Members
Posts: 669
Joined: 5-September 07
From: Netherlands
Member No.: 46810



The quotes are needed if you have a space in your path (like "program files". You have progra~2, no space so you don't need quotes).

Create a shortcut in windows to albumart.exe. Open the shortcut properties, copy the targetpath, paste it in the runcommand as path (use quotes if spaces are there). Should work.

Else, give a better explanation of the errors you get.


--------------------
http://www.youtube.com/watch?v=whoj6BOSfE4 (foob.fm)
Go to the top of the page
+Quote Post
drbeachboy
post Feb 13 2009, 16:50
Post #9





Group: Members
Posts: 500
Joined: 22-October 04
From: Southern NJ
Member No.: 17776



There is really not much of an explanation to give. When I quoted the PATH, neither AAD or MP3tag would start. Unquoting the PATH didn't work either. The only way that it would work was by using the 8 character PATh name. I was just wondering if this is a VISTA issue?

This post has been edited by drbeachboy: Feb 13 2009, 20:34


--------------------
Surf's Up!
"Columnated Ruins Domino"
Go to the top of the page
+Quote Post
Mar2zz
post Feb 13 2009, 17:17
Post #10





Group: Members
Posts: 669
Joined: 5-September 07
From: Netherlands
Member No.: 46810



Don't know, on XP here (and love it!).


--------------------
http://www.youtube.com/watch?v=whoj6BOSfE4 (foob.fm)
Go to the top of the page
+Quote Post
Purple Monkey
post Feb 13 2009, 20:14
Post #11





Group: Members
Posts: 473
Joined: 25-June 05
Member No.: 22962



()s are special characters in title formatting. Escape them like this: "..\Program Files '(x86)'\.."
Go to the top of the page
+Quote Post
drbeachboy
post Feb 13 2009, 20:30
Post #12





Group: Members
Posts: 500
Joined: 22-October 04
From: Southern NJ
Member No.: 17776



Thank you. It never dawned on me that title formatting would be the issue.


--------------------
Surf's Up!
"Columnated Ruins Domino"
Go to the top of the page
+Quote Post
that`guy
post Feb 13 2009, 21:00
Post #13





Group: Members
Posts: 2
Joined: 13-February 09
Member No.: 66956



Where does it save the files to?

How come it still doesn't show up in Album Art section on FooBar2k



EDIT: I guess it goes to the folder where the song is, Sadly Everyone of my songs doesn't have it's own folder. I guess I got some work to do if I want this to work.

This post has been edited by that`guy: Feb 13 2009, 21:05
Go to the top of the page
+Quote Post
Mar2zz
post Feb 13 2009, 21:26
Post #14





Group: Members
Posts: 669
Joined: 5-September 07
From: Netherlands
Member No.: 46810



When it grabs the right pictures, you have correct album and artist tags. in that case you could use foobar to move everything with a few clicks to %artist%/%album%/%filename_ext% (or variations on these). Be sure all tags artist and album are filled when doing this (use the search for example like NOT %artist% MISSING AND NOT %album% MISSING to filter out all good songs), your structure should be ok after that for the use of albumartdownloader.

edit:
i do not see a folder.jpg in your folder. you didn't grab it?

This post has been edited by Mar2zz: Feb 13 2009, 21:29


--------------------
http://www.youtube.com/watch?v=whoj6BOSfE4 (foob.fm)
Go to the top of the page
+Quote Post
that`guy
post Feb 13 2009, 22:39
Post #15





Group: Members
Posts: 2
Joined: 13-February 09
Member No.: 66956



No Don't get me wrong it does grab that Album art correctly, But What I'm trying to get working is the area hilighted in Red.

Go to the top of the page
+Quote Post
2E7AH
post Feb 13 2009, 23:13
Post #16





Group: Validating
Posts: 2424
Joined: 21-May 08
Member No.: 53675



i think you should address that here

it's elplaylist and we couldn't know where its setting refers for album art
maybe you'll find the answer just browsing through that thread

[edit]
from the first post it seems that it looks in "z:/_artists_/%artist%.jpg"

[edit 2]
well, that is for elplaylist and you are pointing on graphical browser: then right click on it, select settings and see where it looks for artist art

This post has been edited by 2E7AH: Feb 13 2009, 23:42
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd December 2014 - 10:37