IPB

Welcome Guest ( Log In | Register )

3 Pages V   1 2 3 >  
Reply to this topicStart new topic
TAK 1.1.0 - Beta release
TBeck
post Dec 19 2008, 02:44
Post #1


TAK Developer


Group: Developer
Posts: 1098
Joined: 1-April 06
Member No.: 29051



Beta release 4 of TAK 1.1.0 ((T)om's lossless (A)udio (K)ompressor)

It consists of:

- TAK Applications 1.1.0 Beta 4
- Winamp plugin 1.1.0 Beta 4
- Decoding library 1.1.0 Beta 4

The SDK will come with the final release.

Download:

Download link removed. TAK 1.1.0 Final has been released.

Fixes in Beta 2 / 08-12-20

- Takc.exe contained a bug: When using pipe encoding with the parameter combination -ihs -sts0, the encoder stopped with an error message.

Only Takc.exe and it's readme have been modified.

Fixes in Beta 3 / 08-12-20

- On very rare occasions (about 1 of 250,000 seeks in my tests) the decoder could fail when seeking to the end of a file with a quite large (i am testing up to 4 MB) meta data structure (APEv2-tag) at the end. This resulted in an "undecodable" error message and affected the decoding library and the winamp plugin.

All binaries and the readme have been modified.

Fixes in Beta 4 / 08-12-30

- Tiny speed improvements.
- If pipe encoding is used without the -ihs paramter (that is for instance required for foobar), TAKC will now reserve only 46 bytes in the header for the storage of wave file meta data. That's sufficient for a standard wave file header. Earlier version reserved 1 MB (!) in the header, making the compressed file accordingly bigger.

All binaries and the readme have been modified.

What's new

New Features:

- Support for 192 Khz Audio.
- Seeking without seek table.

Caution: Decoders prior to those released with V1.1.0 can't decode 192 Khz files and can't seek in files without seek table.

Improvements:

- Encoding and decoding speed improvements of about 3 percent for presets p0 and p1 on my system. Also some decoding speedup for p2.
- Fixed a bug in the encoder that resulted in suboptimal compression of some loud files and especially high resolution audio. Some files may gain about 0.05 percent of compression. Not much, but it comes without any speed penality.
- Further clean up of the Code.

Modifications:

- I hope you don't mind but i always had the feeling 5 presets are enough. Therefore i dropped the appropriately 'Insane' named preset -p5 and instead made presets 3 and 4 stronger. Okay, new -p4 will nevertheless be slightly weaker than old -p5, because i have reduced the maximum predictor count from 256 to 160. Before doing this i performed a detailed analysis of predictor count * compression * speed. There are not many files which benefit from such high predictor orders. Two of my file sets contain many of such files, but even they will only loose about 0.10 percent compression. Not a big loss if in exchange you get nearly half the decoding (cpu power) requirements.
- Removed option to modify the Prefilter sensitivity.

Known issues:

- If you use pipe decoding and the application reading the pipe is beeing terminated before the whole file has been read, TAKC may get into an endless loop and has to be manually killed with the task manager. I don't think this is a big issue but i will try to fix it in one of the next versions. BTW: Big thanks to shnutils for testing the pipe decoding!
- There seem to be some compatibility issues with pipe decoding to some other applications ("crc1632.exe" has been reported). I will try to fix it in the next release.

Some remarks:

The beta release has been delayed because my enhanced validation procedure found some bugs in the new seeking-without-seektable feature. After the correction of the 3 bugs i found, i lost about 2 percent of speed because of now suboptimal code alignment.

Beta testing

The beta version has already gone through extensive testing performed by my automatic scripts. But especially because of the many changes for 1.1.0 rare bugs are still possible (as always...). Please try the beta release and report any bugs in this thread.

It's important to test the new seeking-without-seek table feature:

- Encode a file (big files would be nice and APEv2 tags too) with no seek table: -sts0
- Play it back with Winamp or Foobar and perform some seeks.

I would also be happy about tests of compression efficiency and speed. Because the final release will have identical performance (there may be a speed variation of 1 to 2 percent because of different code alignment of another build), it does make sense to test the beta.

Thanks for testing and have fun

Thomas

This post has been edited by TBeck: Jan 5 2009, 06:01
Go to the top of the page
+Quote Post
Remedial Sound
post Dec 19 2008, 10:01
Post #2





Group: Members
Posts: 505
Joined: 5-January 06
From: Dublin
Member No.: 26898



Congrats on the new beta! beer.gif
Go to the top of the page
+Quote Post
CPKTV
post Dec 19 2008, 10:34
Post #3





Group: Members
Posts: 99
Joined: 8-March 08
Member No.: 51874



thanks for new beta.
does winamp plug-in supports transcoding?
Go to the top of the page
+Quote Post
ssjkakaroto
post Dec 19 2008, 16:54
Post #4





Group: Members
Posts: 203
Joined: 22-May 02
Member No.: 2096



Thanks for the beta Thomas.
Single file albums with embedded cuesheets and no seektable are seeking very fast here wink.gif


--------------------
Allegari nihil et allegatum non probare, paria sunt.
Go to the top of the page
+Quote Post
melomaniac
post Dec 19 2008, 18:17
Post #5





Group: Members
Posts: 43
Joined: 1-August 08
From: Brussels
Member No.: 56565



First, thank you Thomas for your dedicated work. smile.gif
I've used your codec for 9 months now and have never had a single problem.

I've just encoded/decoded some files with foobar2000, presets from p2 to p4. There are indeed some speed/compression changes/optimizations. p4 compression efficiency is very close to old p5 with a slightly faster speed. Synthetic Soul will have to update his lossless codec comparison.

I've also tried some long files using the seeking-without-seek table feature. Seeking is really fast and I've encountered no issues so far.

Looking forward to future releases and optimizations. wink.gif
Go to the top of the page
+Quote Post
Squeller
post Dec 19 2008, 21:32
Post #6





Group: Members
Posts: 2351
Joined: 28-August 02
Member No.: 3218



I wanted to test -sts0 with fb2k but couldn't make it work.

Command line arguments for takc.exe in fb2k: -e -sts0 - %d

CODE
Source: "M:\Musik\Klassik\_Various\Bainton - Symphony No. 3, Boughton - Symphony No. 1 (Handley - BBC CO)\CDImage.tak" / index: 3
  An error occurred while finalizing the encoding process (Object not found) : "C:\Users\Michel\Desktop\CDImage.tak"
  Conversion failed: Object not found


Hmm, yes, after the conversion is finished the file disappears and the fb2k error message appears. The conversion goes from a tak with embedded CUEs to another Tak.
Go to the top of the page
+Quote Post
TBeck
post Dec 19 2008, 21:51
Post #7


TAK Developer


Group: Developer
Posts: 1098
Joined: 1-April 06
Member No.: 29051



QUOTE (Squeller @ Dec 19 2008, 21:32) *
I wanted to test -sts0 with fb2k but couldn't make it work.

Command line arguments for takc.exe in fb2k: -e -sts0 - %d

You have to add the -ihs switch: -e -ihs -sts0 - %d

From the Readme:
QUOTE
...A similar problem arises if the other application does not know the final sample count of the audio data. This can happen, if the audio data is simultaneously beeing ripped from a cd or if the data is beeing converted from a format which doesen't provide an accurate size information before the whole decoding is done. In both cases the other application can not write an accurate sample count into the wave header which is beeing sent to TAK.

You have to tell TAK to ignore this size entry by adding the ignore-header-size switch to the command line:

CODE
takc -e -ihs - Outfile


This post has been edited by TBeck: Dec 19 2008, 21:58
Go to the top of the page
+Quote Post
Neasden
post Dec 19 2008, 21:55
Post #8





Group: Banned
Posts: 185
Joined: 1-July 08
Member No.: 55148



It would be nice a TAK website featuring the winning TAK logo!
Go to the top of the page
+Quote Post
Squeller
post Dec 19 2008, 22:44
Post #9





Group: Members
Posts: 2351
Joined: 28-August 02
Member No.: 3218



QUOTE (TBeck @ Dec 19 2008, 21:51) *
You have to add the -ihs switch: -e -ihs -sts0 - %d
Hmm. But I've just removed it because it brought me more trouble. This didn't even create a tak file at all.

- I load a cuesheet into fb2k, the references work, double clicking starts playback. Select some tracks now.
- start takc in the converter with "-e -ihs -sts0 - %d"
- The converter runs through at 1000x+, then "Could not start conversion process (Object not found)."
- Vista

Fb2k console says:

QUOTE
Command line: "M:\Musik\foobar2000\takc.exe" -e -ihs -sts0 - "CDImage.tak"
Working folder: C:\Users\Michel\Desktop\name\anothername\
Conversion failed: The encoder has terminated prematurely with code 2; please re-check parameters


This post has been edited by Squeller: Dec 19 2008, 22:46
Go to the top of the page
+Quote Post
TBeck
post Dec 19 2008, 23:11
Post #10


TAK Developer


Group: Developer
Posts: 1098
Joined: 1-April 06
Member No.: 29051



QUOTE (Squeller @ Dec 19 2008, 22:44) *
QUOTE (TBeck @ Dec 19 2008, 21:51) *
You have to add the -ihs switch: -e -ihs -sts0 - %d
Hmm. But I've just removed it because it brought me more trouble. This didn't even create a tak file at all.

Does it work without "-sts0"?
Go to the top of the page
+Quote Post
TBeck
post Dec 19 2008, 23:39
Post #11


TAK Developer


Group: Developer
Posts: 1098
Joined: 1-April 06
Member No.: 29051



QUOTE (TBeck @ Dec 19 2008, 23:11) *
QUOTE (Squeller @ Dec 19 2008, 22:44) *

QUOTE (TBeck @ Dec 19 2008, 21:51) *
You have to add the -ihs switch: -e -ihs -sts0 - %d
Hmm. But I've just removed it because it brought me more trouble. This didn't even create a tak file at all.

Does it work without "-sts0"?

Plobably not...

I can reproduce the bug! I will try to fix it soon.

Thanks for the report!

Thomas
Go to the top of the page
+Quote Post
TBeck
post Dec 19 2008, 23:50
Post #12


TAK Developer


Group: Developer
Posts: 1098
Joined: 1-April 06
Member No.: 29051



Ok, i've got it.

It only can happen with pipe encoding and the parameter combination -ihs -sts0.

There is code in my encoder that checks valid paramter combinations and i forgot to update it after implementing -sts0. Now the encoder refuses to work because of invalid arguments.

It's not dangerous, it will simply create no file and show an error message.

I hope to release a fixed beta 2 within 1 or 2 hours.

Thomas
Go to the top of the page
+Quote Post
Squeller
post Dec 19 2008, 23:54
Post #13





Group: Members
Posts: 2351
Joined: 28-August 02
Member No.: 3218



Thank you Thomas, I'll use it tomorrow then.
Go to the top of the page
+Quote Post
TBeck
post Dec 20 2008, 00:46
Post #14


TAK Developer


Group: Developer
Posts: 1098
Joined: 1-April 06
Member No.: 29051



Beta 2 has been released

The download link is in the first post.

This post has been edited by TBeck: Dec 20 2008, 00:53
Go to the top of the page
+Quote Post
Synthetic Soul
post Dec 20 2008, 09:40
Post #15





Group: Super Moderator
Posts: 4887
Joined: 12-August 04
From: Exeter, UK
Member No.: 16217



QUOTE (melomaniac @ Dec 19 2008, 17:17) *
Synthetic Soul will have to update his lossless codec comparison.
The problem is that my machine has been upgraded to XP, altering the test platform. I would like to get some tests done - I've tested TAK since the alphas and I feel compelled to continue - but it may not be part of that comparison.


--------------------
I'm on a horse.
Go to the top of the page
+Quote Post
Squeller
post Dec 20 2008, 09:51
Post #16





Group: Members
Posts: 2351
Joined: 28-August 02
Member No.: 3218



I encoded to some album image files with embedded Cuesheet and apev2 tags, sts0. Jumping from track to track and inside tracks works instantly so that currently I don't see a reason why I should use a seektable. BTW I chose tak since the beginning of my lossless archive, never ever had a single problem.
Go to the top of the page
+Quote Post
BenniP
post Dec 20 2008, 11:00
Post #17





Group: Members
Posts: 73
Joined: 16-February 03
From: Germany
Member No.: 5014



Hello,

i'am trying TAK for the first time, great compression and fast encoding speed!

It works fine but, don't know if this is beta related, I can't get pipe encoding to work.

My parameters in foobar
CODE
-e -p4 -sts0 - %d

foobar always tells me "could not enumerate tracks (Object not found) on:" follow by the filename.

I'm using the %s switch instead now.
Go to the top of the page
+Quote Post
melomaniac
post Dec 20 2008, 11:04
Post #18





Group: Members
Posts: 43
Joined: 1-August 08
From: Brussels
Member No.: 56565



QUOTE (Synthetic Soul @ Dec 20 2008, 09:40) *
QUOTE (melomaniac @ Dec 19 2008, 17:17) *
Synthetic Soul will have to update his lossless codec comparison.
The problem is that my machine has been upgraded to XP, altering the test platform. I would like to get some tests done - I've tested TAK since the alphas and I feel compelled to continue - but it may not be part of that comparison.

I get your point. Nevertheless, I run on XP and the speeds mentionned on your page are very close to what I got. New tests would be very helpful for the community so feel free to do it even regardless of your previous ones.
By the way, your comparison helped me a lot deciding which codec and preset to use so I must thank you for that.

QUOTE (BenniP @ Dec 20 2008, 11:00) *
Hello,

i'am trying TAK for the first time, great compression and fast encoding speed!

It works fine but, don't know if this is beta related, I can't get pipe encoding to work.

My parameters in foobar
CODE
-e -p4 -sts0 - %d

foobar always tells me "could not enumerate tracks (Object not found) on:" follow by the filename.

I'm using the %s switch instead now.

Squeller mentionned the problem. Thomas fixed it in Beta 2. I just tried it with a long 30-minute Bruckner movement and an album image with embedded cue sheet: it works fine now. Your command line missed -ihs so use this:
-e -p4 -ihs -sts0 - %d

This post has been edited by melomaniac: Dec 20 2008, 11:24
Go to the top of the page
+Quote Post
Squeller
post Dec 20 2008, 11:54
Post #19





Group: Members
Posts: 2351
Joined: 28-August 02
Member No.: 3218



TBeck, if -ihs is mandatory when using -sts0, you should internally handle the lack of that switch, otherwise many users would get confused.

This post has been edited by Squeller: Dec 20 2008, 11:55
Go to the top of the page
+Quote Post
BenniP
post Dec 20 2008, 11:56
Post #20





Group: Members
Posts: 73
Joined: 16-February 03
From: Germany
Member No.: 5014



Now that was easy! smile.gif

Thank you very much!

/EDit: Self-Notice: Oh and reading the complete thread would be quiet helpful. mad.gif smile.gif

This post has been edited by BenniP: Dec 20 2008, 11:59
Go to the top of the page
+Quote Post
TBeck
post Dec 20 2008, 14:10
Post #21


TAK Developer


Group: Developer
Posts: 1098
Joined: 1-April 06
Member No.: 29051



Beta 3 has been released

The download link is in the first post.

I am very confident that this will be the last beta.

Thomas
Go to the top of the page
+Quote Post
Synthetic Soul
post Dec 21 2008, 21:57
Post #22





Group: Super Moderator
Posts: 4887
Joined: 12-August 04
From: Exeter, UK
Member No.: 16217



QUOTE (Synthetic Soul @ Dec 20 2008, 08:40) *
QUOTE (melomaniac @ Dec 19 2008, 17:17) *
Synthetic Soul will have to update his lossless codec comparison.
The problem is that my machine has been upgraded to XP, altering the test platform. I would like to get some tests done - I've tested TAK since the alphas and I feel compelled to continue - but it may not be part of that comparison.
I tested TAK 1.1.0b3 as well as FLAC 1.2.1 again. The results for FLAC 1.2.1 were so similar that I thought it OK to add the TAK 1.1.0 results to my comparison (i.e.: I don't think the upgrade to XP has made a noticeable difference to the test set-up). As usual, use ?all=1 to view previous versions' settings.

Here's the data for TAK 1.0.4 and 1.1.0:

CODE
      |  1.0.4                    |  1.1.0
============================================================
-p0   |  65.803%    130x    147x  |  65.802%    131x    141x
-p0e  |  65.573%    108x    146x  |  65.573%    109x    142x
-p0m  |  65.455%     59x    146x  |  65.455%     61x    142x
-p1   |  64.837%    107x    145x  |  64.836%    108x    141x
-p1e  |  64.748%     89x    145x  |  64.748%     91x    141x
-p1m  |  64.640%     50x    146x  |  64.640%     51x    142x
-p2   |  64.078%     65x    128x  |  64.077%     66x    126x
-p2e  |  63.947%     52x    128x  |  63.946%     53x    126x
-p2m  |  63.861%     32x    128x  |  63.860%     32x    125x
-p3   |  63.833%     41x    117x  |  63.763%     38x    113x
-p3e  |  63.766%     33x    117x  |  63.695%     31x    112x
-p3m  |  63.727%     23x    116x  |  63.650%     20x    112x
-p4   |  63.643%     28x    111x  |  63.585%     24x    103x
-p4e  |  63.623%     18x    111x  |  63.562%     15x    104x
-p4m  |  63.604%     16x    111x  |  63.544%     14x    104x
-p5   |  63.576%     20x     98x  |
-p5e  |  63.543%     11x    102x  |
-p5m  |  63.525%     11x    102x  |


--------------------
I'm on a horse.
Go to the top of the page
+Quote Post
sauvage78
post Dec 21 2008, 22:14
Post #23





Group: Members
Posts: 677
Joined: 4-May 08
Member No.: 53282



Thks Synthetic Soul, the update of your comparison was usefull to me.


--------------------
CDImage+CUE
Secure [Low/C2/AR(2)]
Flac -4
Go to the top of the page
+Quote Post
TBeck
post Dec 21 2008, 22:16
Post #24


TAK Developer


Group: Developer
Posts: 1098
Joined: 1-April 06
Member No.: 29051



QUOTE (CPKTV @ Dec 19 2008, 10:34) *
thanks for new beta.
does winamp plug-in supports transcoding?

No.

QUOTE (ssjkakaroto @ Dec 19 2008, 16:54) *
Single file albums with embedded cuesheets and no seektable are seeking very fast here wink.gif

QUOTE (melomaniac @ Dec 19 2008, 18:17) *
I've just encoded/decoded some files with foobar2000, presets from p2 to p4. There are indeed some speed/compression changes/optimizations. p4 compression efficiency is very close to old p5 with a slightly faster speed.
...
I've also tried some long files using the seeking-without-seek table feature. Seeking is really fast and I've encountered no issues so far.

Fine!

QUOTE (Squeller @ Dec 20 2008, 09:51) *
I encoded to some album image files with embedded Cuesheet and apev2 tags, sts0. Jumping from track to track and inside tracks works instantly so that currently I don't see a reason why I should use a seektable.

Indeed i possibly will drop the seek table in one of the next version, when hopefully most users have upgraded to the new decoders with seeking-without-seek table support.

QUOTE (Squeller @ Dec 20 2008, 11:54) *
TBeck, if -ihs is mandatory when using -sts0, you should internally handle the lack of that switch, otherwise many users would get confused.

It's mandatory for foobar, but not in any other situation. For instance it's not required when reading the wave data directly from a file: "-e - <SomeWaveFile.wav"

QUOTE (Neasden @ Dec 19 2008, 21:55) *
It would be nice a TAK website featuring the winning TAK logo!

Yeah. I wanted to release this version with thelogo, but to be honest, i am not perfectly happy with it. It looks not so nice on my desktop, what is possibly caused by it's transparency feature. I will have to contact the creator to try some modifications.

Thank you all for testing the beta!

I intend to realease the final version within the next days. Please keep on reporting bugs if there are any....

Thomas
Go to the top of the page
+Quote Post
TBeck
post Dec 21 2008, 22:52
Post #25


TAK Developer


Group: Developer
Posts: 1098
Joined: 1-April 06
Member No.: 29051



QUOTE (Synthetic Soul @ Dec 21 2008, 21:57) *
Here's the data for TAK 1.0.4 and 1.1.0:
...

Thank you so much! rolleyes.gif

Although the results are obviously different from what i expected: Decoding got slower on your system!

Well, i am optimizing for my two systems: An Pentium III with 1 GHz and an Pentium Dual Core with 2 GHz. Both systems are encoding and decoding faster with V1.1.0.

Unfortunately i don't have an Athlon system to check. Probably your CPU doesen't like one of the new optimizations. I will try to compensate this in the next version.

Thomas
Go to the top of the page
+Quote Post

3 Pages V   1 2 3 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd August 2014 - 10:37