IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Large file support by neroAacEnc under Linux
sybasesql
post Oct 8 2008, 01:17
Post #1





Group: Members
Posts: 2
Joined: 8-October 08
Member No.: 59693



Hello!

neroAacEnc didn't support large file under Linux. I try to encode file temp.wav with size 2,261,120K bytes but neroAacEnc report error:
ERROR: could not open WAV file

The command is:
# neroAacEnc -br 48000 -2pass -if temp.wav -of temp.aac

My configuration:

# neroAacEnc --help
Nero AAC Encoder
Copyright 2008 Nero AG
All Rights Reserved Worldwide

Package build date: Sep 17 2008
Package version: 1.3.3.0

# uname -a
Linux localhost.localdomain 2.6.18-92.1.10.el5 #1 SMP Tue Aug 5 07:42:41 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux
Go to the top of the page
+Quote Post
menno
post Oct 8 2008, 01:26
Post #2


Nero MPEG4 developer


Group: Developer (Donating)
Posts: 1218
Joined: 11-October 01
From: LA
Member No.: 267



Hmm, that's the error you get when fopen() fails... do smaller files work properly?
Normally I would say, try adding -ignorelength to the command line, but I guess that will not help much (you should try it anyway wink.gif ).


And on a sidenote, neroAacEnc creates files in the MP4 container, so you probably should not call them .AAC as players will get confused about that.
Go to the top of the page
+Quote Post
sybasesql
post Oct 8 2008, 01:37
Post #3





Group: Members
Posts: 2
Joined: 8-October 08
Member No.: 59693



QUOTE (menno @ Oct 8 2008, 03:26) *
Hmm, that's the error you get when fopen() fails... do smaller files work properly?
Normally I would say, try adding -ignorelength to the command line, but I guess that will not help much (you should try it anyway wink.gif ).


And on a sidenote, neroAacEnc creates files in the MP4 container, so you probably should not call them .AAC as players will get confused about that.


Small files works great! I encode all of my xvid videos collection to h.264 and almost all files encoded well, but files with great than 2gb can't open.
-ignorelength options also didn't help. I try it before your post and almost all combination of options. sad.gif

I think that problem in integer types in neroAacEnc so encoder can't open files larger than int32.

I also submit support ticket about that error to nero ag from nero.com site.

If you need any tests I ready to do.

Thanks.
Go to the top of the page
+Quote Post
kjoonlee
post Oct 8 2008, 01:54
Post #4





Group: Members
Posts: 2526
Joined: 25-July 02
From: South Korea
Member No.: 2782



http://en.wikipedia.org/wiki/Large_file_support

http://www.suse.de/~aj/linux_lfs.html

I suppose the neroAacEnc is a 32bit executable.


--------------------
http://blacksun.ivyro.net/vorbis/vorbisfaq.htm
Go to the top of the page
+Quote Post
menno
post Oct 8 2008, 16:27
Post #5


Nero MPEG4 developer


Group: Developer (Donating)
Posts: 1218
Joined: 11-October 01
From: LA
Member No.: 267



QUOTE (sybasesql @ Oct 7 2008, 17:37) *
QUOTE (menno @ Oct 8 2008, 03:26) *

Hmm, that's the error you get when fopen() fails... do smaller files work properly?
Normally I would say, try adding -ignorelength to the command line, but I guess that will not help much (you should try it anyway wink.gif ).


And on a sidenote, neroAacEnc creates files in the MP4 container, so you probably should not call them .AAC as players will get confused about that.


Small files works great! I encode all of my xvid videos collection to h.264 and almost all files encoded well, but files with great than 2gb can't open.
-ignorelength options also didn't help. I try it before your post and almost all combination of options. sad.gif

I think that problem in integer types in neroAacEnc so encoder can't open files larger than int32.

I also submit support ticket about that error to nero ag from nero.com site.

If you need any tests I ready to do.


It's not really a problem in the Nero AAC Encoder (for which Nero doesn't offer any support, so your support ticket will probably not get answered), but in the underlying file system.
I will check for next version if we can add large file support.
Go to the top of the page
+Quote Post
[JAZ]
post Oct 8 2008, 18:04
Post #6





Group: Members
Posts: 1783
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



QUOTE (kjoonlee @ Oct 8 2008, 02:54) *
[I suppose the neroAacEnc is a 32bit executable.


You don't need a 64bit application to read a "large file", simply because the encoder does not need to have it all in memory.

Since the message is that it cannot open it, and menno suggests this in in the fopen call, it may have to do with the fopen call itself, and its structures.
This can be, since you usually can ask for the length of the file, and that usually returns an int.
(and note that int is still 32 bits in 64bits applications)
Go to the top of the page
+Quote Post
kjoonlee
post Oct 8 2008, 18:58
Post #7





Group: Members
Posts: 2526
Joined: 25-July 02
From: South Korea
Member No.: 2782



Well, the 2 gig / 4 gig restriction seems typical of fopen with regular 32bit binaries.


--------------------
http://blacksun.ivyro.net/vorbis/vorbisfaq.htm
Go to the top of the page
+Quote Post
[JAZ]
post Oct 8 2008, 19:55
Post #8





Group: Members
Posts: 1783
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



QUOTE (kjoonlee @ Oct 8 2008, 19:58) *
Well, the 2 gig / 4 gig restriction seems typical of fopen with regular 32bit binaries.


True, but for that, there are new methods, which don't require to compile in 64 bits (actually, the link to wikipedia you provided dealt with this briefly)

http://www.mkssoftware.com/docs/man3/fopen.3.asp
Go to the top of the page
+Quote Post
rberger
post Feb 28 2009, 14:31
Post #9





Group: Members
Posts: 8
Joined: 23-February 09
Member No.: 67305



QUOTE (menno @ Oct 8 2008, 16:27) *
I will check for next version if we can add large file support.


Eh, that or saving stats for multipass runs externally in a file, like x264 does. That way, one could just use pipes even on 2pass encodings, currently the only reason one needs actual input files in the first place.

I've got exactly the same problem here. An over 2:10 hour movie 6chan at 48k, which results into over 4GB of WAV. As of now, there's apparently no chance to 2pass encode that with Nero (on Linux).
Go to the top of the page
+Quote Post
XChesser
post Nov 7 2010, 01:35
Post #10





Group: Members
Posts: 1
Joined: 7-November 10
Member No.: 85493



The problem still exists in 1.5.4.0.
With mkfifo it works well.
Go to the top of the page
+Quote Post
OmnipotentEntity
post Aug 16 2011, 05:52
Post #11





Group: Members
Posts: 1
Joined: 16-August 11
Member No.: 93056



Just to expand on this a bit. You would run this from the command line.

rm audio.fifo; mkfifo audio.fifo; cat audio.wav > audio.fifo & neroAacEnc -ignorelength -if audio.fifo -of audio.mp4
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th September 2014 - 05:27