IPB

Welcome Guest ( Log In | Register )

7 Pages V  « < 5 6 7  
Reply to this topicStart new topic
LAME 3.98 Final, 2008-07-04 23:09
robert
post Sep 25 2008, 17:59
Post #151


LAME developer


Group: Developer
Posts: 788
Joined: 22-September 01
Member No.: 5



Where does that blank come frome in "Lame 3.98.2" ?

@vpa:
You'll have to rename the directory you created. Make doesn't like paths containing blanks.

This post has been edited by robert: Sep 25 2008, 19:06
Go to the top of the page
+Quote Post
vpa
post Sep 25 2008, 20:00
Post #152





Group: Members
Posts: 99
Joined: 13-April 08
Member No.: 52748



QUOTE (robert @ Sep 25 2008, 18:59) *
Where does that blank come frome in "Lame 3.98.2" ?

@vpa:
You'll have to rename the directory you created. Make doesn't like paths containing blanks.


Thanks. It still doesn't work with gcc 3.3, but at least 4.0.1 compiles it now.


--------------------
WavPack 4.50.1 -hhx6 | LAME 3.98.2 -V 0
Go to the top of the page
+Quote Post
/mnt
post Sep 28 2008, 01:18
Post #153





Group: Members
Posts: 697
Joined: 22-April 06
Member No.: 29877



I have just been doing some testing with V0 --vbr-new on LAME 3.97 and found a track that was not transparent to me at that setting and almost also on 3.98.2.

LAME 3.97 -V0 --vbr-new

CODE
foo_abx 1.3.3 report
foobar2000 v0.9.5.5
2008/09/28 00:18:38

File A: C:\Temp\LAME V0\White Zombie - Astro-Creep 2000\05. Electric Head, Pt. 2 (The Ecstasy).mp3
File B: C:\Rips\White Zombie - Astro-Creep 2000\05. Electric Head, Pt. 2 (The Ecstasy).flac

00:18:38 : Test started.
00:19:25 : 01/01 50.0%
00:19:31 : 02/02 25.0%
00:19:38 : 03/03 12.5%
00:19:44 : 04/04 6.3%
00:19:52 : 04/05 18.8%
00:19:55 : 05/06 10.9%
00:20:01 : 06/07 6.3%
00:20:06 : 07/08 3.5%
00:20:12 : 08/09 2.0%
00:20:16 : 08/10 5.5%
00:20:20 : 09/11 3.3%
00:20:24 : 10/12 1.9%
00:20:31 : 11/13 1.1%
00:20:39 : 12/14 0.6%
00:20:58 : 13/15 0.4%
00:21:08 : 14/16 0.2%
00:21:14 : 15/17 0.1%
00:21:18 : 16/18 0.1%
00:21:28 : 16/19 0.2%
00:21:34 : 17/20 0.1%
00:21:47 : 17/21 0.4%
00:21:57 : 18/22 0.2%
00:22:03 : 19/23 0.1%
00:22:12 : 20/24 0.1%
00:22:19 : 21/25 0.0%
00:22:24 : Test finished.

----------
Total: 21/25 (0.0%)


Drum smearing at 0:06, or could be a stereo collapse artifact or a noise on the left channel.

LAME 3.98.2 -V0

CODE

foo_abx 1.3.3 report
foobar2000 v0.9.5.5
2008/09/28 00:38:44

File A: C:\Rips\White Zombie - Astro-Creep 2000\05. Electric Head, Pt. 2 (The Ecstasy).flac
File B: C:\Temp\Transcodes\Mp3\Electric Head, Pt. 2 (The Ecstasy) LAME 3.98.2.mp3

00:38:44 : Test started.
00:39:14 : 01/01 50.0%
00:39:37 : 02/02 25.0%
00:39:48 : 02/03 50.0%
00:39:54 : 03/04 31.3%
00:40:06 : 04/05 18.8%
00:40:12 : 05/06 10.9%
00:40:22 : 05/07 22.7%
00:40:29 : 06/08 14.5%
00:40:36 : 07/09 9.0%
00:40:50 : 07/10 17.2%
00:40:57 : 07/11 27.4%
00:41:08 : 08/12 19.4%
00:41:15 : 09/13 13.3%
00:41:26 : 10/14 9.0%
00:41:40 : 11/15 5.9%
00:41:47 : 12/16 3.8%
00:42:02 : 13/17 2.5%
00:42:07 : 13/18 4.8%
00:42:16 : 14/19 3.2%
00:42:27 : 15/20 2.1%
00:42:32 : 16/21 1.3%
00:42:37 : 17/22 0.8%
00:42:51 : 18/23 0.5%
00:42:59 : 19/24 0.3%
00:43:06 : 20/25 0.2%
00:43:14 : 21/26 0.1%
00:43:29 : 22/27 0.1%
00:43:40 : Test finished.

----------
Total: 22/27 (0.1%)


The artifact at 0:06 is gone, but at 0:27 something sounds odd, which could be smearing.

I have uploaded a sample of the track.

This post has been edited by /mnt: Sep 28 2008, 02:21


--------------------
"I never thought I'd see this much candy in one mission!"
Go to the top of the page
+Quote Post
krmathis
post Sep 28 2008, 12:12
Post #154





Group: Members
Posts: 742
Joined: 27-May 02
From: Oslo, Norway
Member No.: 2133



QUOTE (vpa @ Aug 28 2008, 12:04) *
I've compiled it long time ago on my G5 myself, but I just tried your universal binary: I get a bus error on my iMac G5 unsure.gif Maybe it's not realy "universal"?

"Universal" point to the fact that its both PPC and Intel code in the same binary.
Perhaps you don't run Mac OS 10.5, which is what I used to compile this...
Go to the top of the page
+Quote Post
vpa
post Sep 29 2008, 17:39
Post #155





Group: Members
Posts: 99
Joined: 13-April 08
Member No.: 52748



QUOTE (krmathis @ Sep 28 2008, 13:12) *
Perhaps you don't run Mac OS 10.5, which is what I used to compile this...

Yes indeed. I'm still running 10.4


--------------------
WavPack 4.50.1 -hhx6 | LAME 3.98.2 -V 0
Go to the top of the page
+Quote Post
Sylph
post Oct 1 2008, 10:36
Post #156





Group: Members
Posts: 259
Joined: 1-February 08
Member No.: 50965



Does anyone know why I cannot download lame_enc.dll from LAME's site and instead have to go to RareWares?
Go to the top of the page
+Quote Post
Sebastian Mares
post Oct 1 2008, 11:31
Post #157





Group: Members
Posts: 3633
Joined: 14-May 03
From: Bad Herrenalb
Member No.: 6613



Because the LAME site does not offer binaries at all due to patent restrictions (distributing sources does not require patent fees to be paid, distributing binaries does AFAIK).


--------------------
http://listening-tests.hydrogenaudio.org/sebastian/
Go to the top of the page
+Quote Post
Sylph
post Oct 1 2008, 11:38
Post #158





Group: Members
Posts: 259
Joined: 1-February 08
Member No.: 50965



QUOTE (Sebastian Mares @ Oct 1 2008, 12:31) *
Because the LAME site does not offer binaries at all due to patent restrictions (distributing sources does not require patent fees to be paid, distributing binaries does AFAIK).


Perhaps I am mistaken, but I think a few versions back that was possible.

Thank you for the reply.
Go to the top of the page
+Quote Post
robert
post Oct 5 2008, 15:44
Post #159


LAME developer


Group: Developer
Posts: 788
Joined: 22-September 01
Member No.: 5



QUOTE (vpa @ Sep 25 2008, 21:00) *
QUOTE (robert @ Sep 25 2008, 18:59) *

Where does that blank come frome in "Lame 3.98.2" ?

@vpa:
You'll have to rename the directory you created. Make doesn't like paths containing blanks.


Thanks. It still doesn't work with gcc 3.3, but at least 4.0.1 compiles it now.

What is the problem with gcc 3.3? At what point will the build process fail?
Go to the top of the page
+Quote Post
[JAZ]
post Oct 6 2008, 20:37
Post #160





Group: Members
Posts: 1787
Joined: 24-June 02
From: Catalunya(Spain)
Member No.: 2383



QUOTE (robert @ Oct 5 2008, 16:44) *
What is the problem with gcc 3.3? At what point will the build process fail?


3.3 was labeled sometimes as a buggy version of gcc.
I have tried using version 3.4.5 in mingw (windows) and with it compiles just fine. Of course, it may be using different #define paths.
Go to the top of the page
+Quote Post
vpa
post Oct 7 2008, 06:44
Post #161





Group: Members
Posts: 99
Joined: 13-April 08
Member No.: 52748



I'll give it a try again this evening and post the error log.


--------------------
WavPack 4.50.1 -hhx6 | LAME 3.98.2 -V 0
Go to the top of the page
+Quote Post
francesco
post Oct 7 2008, 16:58
Post #162





Group: Members
Posts: 378
Joined: 28-January 06
Member No.: 27378



i have update lame to 3.98

but this version 3.98.2 is different i can't find the history about the 3.98.2
i mean in rarewares i can find 3.98.2

where can i find info about the improvement about 3.98.2 vs 3.98


in the history i can find this , nothing about the 3.98.2
QUOTE
LAME 3.98.1 not yet released

* Rogério Brito:
o More fixes for the abx tool for Unix systems:
+ Plugged a memory leak.
+ Fixed an endianness problem: users of big-endian machines can now do abx tests.
o Fixed history's HTML doctype
o Fixed history so that it finally validates at W3's validator
o Fixed compilation of frontend mp3rtp.c. Thanks to Kris Karas. Bugtracker item [ 2015432 ] mp3rtp missing uint16_t in lame 3.98
* Robert Hegemann:
o Fix for Bugtracker item [ 2031704 ] --id3v1-only didnt work in 3.98-final
o Fix for Bugtracker item [ 2022035 ] encoder_padding value and resampling
o Fix for Bugtracker item [ 2029282 ] Frequency filtering API broken in 3.98
o Fix for Bugtracker item [ 2039648 ] potential memory leak in parse_args() function in parse.c
o Fix for some tagging issues:
+ Made search for ID3v1 genres more sloppy, abbrevations may match more often as some simple typos. Examples:
# --tg "Alt. Rock" matches genre "Alternate Rock"
# --tg "acapela" matches genre "A Cappella"
+ New switch --pad-id3v2-size "n": adds ID3v2 tag with n padding bytes.

LAME 3.98 July 4 2008

* Anton Sergunov:
o Frontend DirectShow: enabling LAME dshow filter to connect to "File Writer Filter".
* Rogério Brito:
o Updates to the Debian Packaging
o Fixes to the abx tool for Unix systems (so that more people can evaluate LAME's compression against the original files)
* Alexander Leidinger:
o explicitely link the math lib to the lame lib
o add switch to disable the use of the compaq optimized math lib


This post has been edited by francesco: Oct 7 2008, 17:00
Go to the top of the page
+Quote Post
robert
post Oct 7 2008, 17:30
Post #163


LAME developer


Group: Developer
Posts: 788
Joined: 22-September 01
Member No.: 5



3.98.2 has a fix for a bug introduced in 3.98.1:
- [ 2123206 ] lame 3.98.1 segfaults with -h
Go to the top of the page
+Quote Post
vpa
post Oct 8 2008, 17:29
Post #164





Group: Members
Posts: 99
Joined: 13-April 08
Member No.: 52748



Well, I freshly depacked the source and now it also works with gcc3.3
Something must have been messed up that worse that even a make clean didn't fix it.


--------------------
WavPack 4.50.1 -hhx6 | LAME 3.98.2 -V 0
Go to the top of the page
+Quote Post
Hellenback
post Nov 2 2008, 09:15
Post #165





Group: Members
Posts: 6
Joined: 13-June 08
Member No.: 54289



QUOTE (vpa @ Sep 25 2008, 12:20) *
and 3.98.2 is somehow broken. It doesn't compile on OS X. Neither with gcc 3.3 nor with 4.0.1 :
CODE
(cd .libs/libmp3lame.lax/libmpgdecoder.a && ar x /Users/frankseyen/Desktop/Lame 3.98.2/lame-398-2/libmp3lame/../mpglib/.libs/libmpgdecoder.a)
ar: /Users/frankseyen/Desktop/Lame: Inappropriate file type or format
make[3]: *** [libmp3lame.la] Error 1

sad.gif


I am having one hell of a time trying to figure out how to make the new Lame release work with EAC as it has no .exe file in the zip download! All the code stuff is so far over my head. crying.gif I need simple answer as to how to get high rate VBR working with the new LAME release! (A command line code would be great once it is working!)
I realize there are many different command codes ( I have seen far too many! unsure.gif ) but don't know how to decide on what is best for a highest rate VBR encode in EAC.
Thanks in advance for any help.
Go to the top of the page
+Quote Post
melomaniac
post Nov 2 2008, 09:34
Post #166





Group: Members
Posts: 43
Joined: 1-August 08
From: Brussels
Member No.: 56565



Get the latest LAME bundle here (3.98.2)
Then, follow the wiki for EAC + LAME
Forget about --vbr-new since it's by default in 3.98.2
--> -V0 %s %d
V0 is the best quality VBR setting

BUT:

Since the recent release of lame 3.98.2, I've read a lot of forum posts. Most of people who used V2 by the past now prefer V3 and even lower because of the constant development and improvement of the codec.
http://www.hydrogenaudio.org/forums/index....showtopic=65101
I'm 23, have a pretty good hearing and use V5.5 for portable. You'd be surprised the amazing quality you'll get.

This post has been edited by melomaniac: Nov 24 2008, 20:29
Go to the top of the page
+Quote Post
start78
post Nov 2 2008, 17:48
Post #167





Group: Members
Posts: 192
Joined: 3-March 05
Member No.: 20320



My experience with embedding album art:

foobar2000 shows it. My hardware player doesn't.

If i embed an albumart from the same source file with mp3tag, both f2k and my hardware player show it.

What i found out: Mp3tag embeds the albumart as "front cover", but an albumart embedded with the lame encoder is called "other".

Is there a way to tell the encoder to embed the albumart as "front cover"? Or would you call it worth a change for one of the next versions?

This post has been edited by start78: Nov 2 2008, 22:23
Go to the top of the page
+Quote Post
eschw95458
post Dec 10 2008, 17:59
Post #168





Group: Members
Posts: 4
Joined: 10-December 08
Member No.: 64275



Has anyone compiled 398.2 for os x. If you have can you please point me to it. Thanks biggrin.gif
Go to the top of the page
+Quote Post
vpa
post Dec 13 2008, 13:00
Post #169





Group: Members
Posts: 99
Joined: 13-April 08
Member No.: 52748



QUOTE (eschw95458 @ Dec 10 2008, 17:59) *
Has anyone compiled 398.2 for os x. If you have can you please point me to it. Thanks biggrin.gif

If you are using a PowerPC Mac, then try Lame for OSX PPC
It contains a gcc 3.3 compile, a gcc 4.01 compile and a fresh cvs checkout (3.99 a1) compiled with gcc 4.01. I hope it's helpfull for you. smile.gif

This post has been edited by vpa: Dec 13 2008, 13:01


--------------------
WavPack 4.50.1 -hhx6 | LAME 3.98.2 -V 0
Go to the top of the page
+Quote Post
sblasl
post Dec 18 2008, 00:08
Post #170





Group: Members
Posts: 1
Joined: 17-December 08
Member No.: 64605



How about a version for the Intel side of OS X?

Thanks in advance.

QUOTE (vpa @ Dec 13 2008, 06:00) *
QUOTE (eschw95458 @ Dec 10 2008, 17:59) *

Has anyone compiled 398.2 for os x. If you have can you please point me to it. Thanks biggrin.gif

If you are using a PowerPC Mac, then try Lame for OSX PPC
It contains a gcc 3.3 compile, a gcc 4.01 compile and a fresh cvs checkout (3.99 a1) compiled with gcc 4.01. I hope it's helpfull for you. smile.gif
Go to the top of the page
+Quote Post
eschw95458
post Dec 31 2008, 15:24
Post #171





Group: Members
Posts: 4
Joined: 10-December 08
Member No.: 64275



QUOTE (eschw95458 @ Dec 10 2008, 10:59) *
Has anyone compiled 398.2 for os x. If you have can you please point me to it. Thanks biggrin.gif



Thanks for the reply, Sorry I didn't respond quicker I was gone for the holiday.
I am not using PPC. Intel Imac 2g Core Duo with 10.5.6.
Go to the top of the page
+Quote Post
Gew
post Dec 22 2009, 16:30
Post #172





Group: Members
Posts: 22
Joined: 6-November 09
Member No.: 74690



Just out of curiosity, why hasn't LAME v3.98.2 become the recommended version here at HA? Just about every music group (on "the scene") uses 3.97, prolly 'cuz it's HA-recommended. Me myself, I'm trying to figure out if there are any known disadvantages on 3.98 apart from 3.97? Known stability bugs? Compatibility bugs?? Anything(!) that would have you prefer 3.97 > 3.98.2? I've done lots of research, trying to fetch this answer someplace else, but there's not much to go on. And since I'm no audio pro, I'm kinda lost in a maze here..

Thankfor for all answers~
Go to the top of the page
+Quote Post
john33
post Dec 22 2009, 16:37
Post #173


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3760
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



QUOTE (Gew @ Dec 22 2009, 15:30) *
Just out of curiosity, why hasn't LAME v3.98.2 become the recommended version here at HA?....

Why do you say that? The Wiki clearly recommends 3.98.2.


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
Buckchoi
post Dec 23 2009, 03:03
Post #174





Group: Members
Posts: 16
Joined: 10-February 08
From: New Zealand
Member No.: 51180



QUOTE (Gew @ Dec 23 2009, 04:30) *
Just out of curiosity, why hasn't LAME v3.98.2 become the recommended version here at HA? Just about every music group (on "the scene") uses 3.97, prolly 'cuz it's HA-recommended. Me myself, I'm trying to figure out if there are any known disadvantages on 3.98 apart from 3.97? Known stability bugs? Compatibility bugs?? Anything(!) that would have you prefer 3.97 > 3.98.2? I've done lots of research, trying to fetch this answer someplace else, but there's not much to go on. And since I'm no audio pro, I'm kinda lost in a maze here..

Thankfor for all answers~


"The Scene" appears to be slow to adopt new standards.
Go to the top of the page
+Quote Post
rohangc
post Dec 23 2009, 06:08
Post #175





Group: Members
Posts: 570
Joined: 1-December 02
From: India
Member No.: 3948



QUOTE (john33 @ Dec 22 2009, 10:37) *
Why do you say that? The Wiki clearly recommends 3.98.2.


Maybe I am blind, but the wiki recommends the latest stable version, and the same page states that the latest stable version is 3.98. not 3.98.2. I just fixed this in the wiki.
Go to the top of the page
+Quote Post

7 Pages V  « < 5 6 7
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2014 - 04:09