IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Why tag MP3s with EAC?, Was: Additional Command Line [TOS#6]
DigitalCyber
post Dec 25 2007, 05:48
Post #1





Group: Members
Posts: 15
Joined: 22-March 07
Member No.: 41717



I was following this guide to set up EAC + LAME and it says
QUOTE
If you prefer not to let EAC tag your files, untick Add ID3 tag; and in the Additional command line options box, copy and paste one of the strings below, based on the tag format you prefer:

and gives the command lines for No Tags, ID3v1, ID3v2, ID3v1 & 2, and automatic

What I was wondering is, what would be the need for the last 4 if you dont want EAC to tag your files? Because I use Tag&Rename for tagging so I have no need for EAC when it comes to tagging

This post has been edited by DigitalCyber: Dec 25 2007, 05:49
Go to the top of the page
+Quote Post
fbuser
post Dec 25 2007, 10:45
Post #2





Group: Developer
Posts: 688
Joined: 26-September 07
Member No.: 47369



QUOTE (DigitalCyber @ Dec 25 2007, 05:48) *
What I was wondering is, what would be the need for the last 4 if you dont want EAC to tag your files? Because I use Tag&Rename for tagging so I have no need for EAC when it comes to tagging

With the last 4 options you tag the files with the encoder (here lame) with the specified parameters. Alternatively you can tag the files directly with EAC. With tagging via parameters the tagging can be better controlled.
Go to the top of the page
+Quote Post
greynol
post Dec 25 2007, 19:28
Post #3





Group: Super Moderator
Posts: 10338
Joined: 1-April 04
From: San Francisco
Member No.: 13167



The differences between letting EAC tag and configuring it to use Lame to tag when using the various lines specified in the wiki are only very slight, actually.

I asked Andre to provide the ability write ID3v2 tags without having to write ID3v1 tags a while back. If this were implemented then the only differences between using EAC and using Lame based on the wiki configurations would be that EAC will give you better genre support, the ability to place a leading zero for single digit track numbers and automatically specifies the ripping mode in the Encoded tag (when configured to create ID3v2 tags).

Besides the functionality of --id3v2-only and Lame's automatic mode, EAC certainly doesn't give you any less control over tagging than Lame.

Answering the OP's question, if you are using a tag editor to take care of this for you, then there's no reason for you use any of the last four options, or the first one (which is to let EAC do the taging).

This post has been edited by greynol: Dec 25 2007, 23:01


--------------------
Your eyes cannot hear.
Go to the top of the page
+Quote Post
DigitalCyber
post Dec 26 2007, 00:33
Post #4





Group: Members
Posts: 15
Joined: 22-March 07
Member No.: 41717



so then what would the command line be if I want to make V0 rips without tags so i can do the tagging in my other program?
Go to the top of the page
+Quote Post
ssjkakaroto
post Dec 26 2007, 15:30
Post #5





Group: Members
Posts: 203
Joined: 22-May 02
Member No.: 2096



QUOTE (DigitalCyber @ Dec 25 2007, 02:48) *
I was following this guide to set up EAC + LAME and it says
QUOTE
If you prefer not to let EAC tag your files, untick Add ID3 tag; and in the Additional command line options box, copy and paste one of the strings below, based on the tag format you prefer:

and gives the command lines for No Tags, ID3v1, ID3v2, ID3v1 & 2, and automatic
.snip.


--------------------
Allegari nihil et allegatum non probare, paria sunt.
Go to the top of the page
+Quote Post
exec
post Jan 21 2008, 22:45
Post #6





Group: Members
Posts: 204
Joined: 30-January 07
From: Germany
Member No.: 40168



When EAC (V0.99 pb3) is used for tagging, has anybody encountered problems with ID3v2.4? If I enable this option in EAC ("Use ID3V2.4.0 tags instead of ID3V2.3.0 tags"), then no ID3v2 tags are written at all. If I disable this option, then everything seems to work correctly (but only with ID3v2.3).

Is it a bug of EAC? Any suggestions?
Go to the top of the page
+Quote Post
exec
post Jan 23 2008, 12:24
Post #7





Group: Members
Posts: 204
Joined: 30-January 07
From: Germany
Member No.: 40168



Nobody encountered these problems? Could anybody please verify that there is (no) problem? Your help would be much appreciated.

All you have to do:
Configure EAC to compres to MP3 files (LAME), then check the Add ID3 tag option. Then, in the ID3 Tag tab, just tick all options.
When a track was ripped/compressed then, check the file with a tagging tool (e.g. MP3tag) and look for which ID3 tag versions are used. This should be ID3v1.1 and ID3v.2.4, but as I already mentioned, I can't bring EAC to write these ID3v2 tags, when the option Use ID3V2.4.9 tags instead of ID3V2.3.0 tags is enabled.

Just want to figure out if this is a problem with my configuration or a general EAC problem.
Go to the top of the page
+Quote Post
evereux
post Jan 23 2008, 12:58
Post #8





Group: Members
Posts: 907
Joined: 9-February 02
From: Cheshire, UK
Member No.: 1296



QUOTE (exec @ Jan 23 2008, 11:24) *
I can't bring EAC to write these ID3v2 tags, when the option Use ID3V2.4.9 tags instead of ID3V2.3.0 tags is enabled.

I just tested this and the same is true for me.


--------------------
daefeatures.co.uk
Go to the top of the page
+Quote Post
ALiENscApE
post Jan 23 2009, 23:59
Post #9





Group: Members
Posts: 49
Joined: 11-August 07
Member No.: 46138



QUOTE (greynol @ Dec 25 2007, 13:28) *
EAC will give you better genre support, the ability to place a leading zero for single digit track numbers and automatically specifies the ripping mode in the Encoded tag (when configured to create ID3v2 tags).


What is the benifit of having a leading zero for single digit track numbers?
Go to the top of the page
+Quote Post
greynol
post Jan 24 2009, 00:21
Post #10





Group: Super Moderator
Posts: 10338
Joined: 1-April 04
From: San Francisco
Member No.: 13167



In the context of this discussion it's somewhat irrelevant since Lame 3.98 will now tag whatever is given when using --tn rather than the older behavior of changing 03/12 to 3, for example.

...but to answer your question, my guess would be that there is none and that it's just a matter of personal preference.


--------------------
Your eyes cannot hear.
Go to the top of the page
+Quote Post
facesnorth
post Jan 30 2009, 08:26
Post #11





Group: Members
Posts: 3
Joined: 18-December 08
Member No.: 64614



QUOTE (ALiENscApE @ Jan 23 2009, 17:59) *
QUOTE (greynol @ Dec 25 2007, 13:28) *
EAC will give you better genre support, the ability to place a leading zero for single digit track numbers and automatically specifies the ripping mode in the Encoded tag (when configured to create ID3v2 tags).


What is the benifit of having a leading zero for single digit track numbers?



Just a noob, but I believe it's to make it easier to view the files in order when browsing folders. So track 10 would not come before track 2, for example.
Go to the top of the page
+Quote Post
greynol
post Aug 28 2012, 23:35
Post #12





Group: Super Moderator
Posts: 10338
Joined: 1-April 04
From: San Francisco
Member No.: 13167



I could not reproduce this bug and have changed the article. Perhaps those who have encountered the issue could be specific about how EAC was configured and what was used to test the files.

My bad for not attempting to verify the problem when the issue was first raised.

This post has been edited by greynol: Aug 28 2012, 23:36


--------------------
Your eyes cannot hear.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th December 2014 - 19:12