IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
CDex LAME 3.92 - output sample rate problem
Kawsar
post Jan 15 2003, 21:16
Post #1





Group: Members
Posts: 2
Joined: 5-January 03
Member No.: 4428



Hi,

I am using CDex 1.50 beta 9. When I was trying to encode with LAME 3.92 option "--alt-preset ABR" rate 64k the encoded file is always becoming sample rate of 32000. No matter what option I choose it does not change. I am trying to encode at 44.1K sampling rate. Is it a bug or I am missing something?

//Kawsar


--------------------
--Kawsar
Go to the top of the page
+Quote Post
DickD
post Jan 15 2003, 23:16
Post #2





Group: Members
Posts: 265
Joined: 12-January 03
Member No.: 4542



The LAME ABR settings are tuned for quality with a wide range of music to avoid artifacts where possible.

Because 64 kbps is a very low bitrate, MP3 will almost always have artifacts if using full bandwidth. LAME uses a lowpass filter to remove high frequencies which use up a lot of bits and concentrate on lower frequencies. Because the lowpass frequency chosen for ABR 64 kbps is less than 16 kHz, a sampling rate of 32 kHz (at least twice the highest frequency) is most efficient, so it resamples your data to 32 kHz.

I just tried one with LAME 3.92 on the MS-DOS command line, and I actually get 22.05 kHz sampling rate (low pass transition from 10758-11025 Hz), but there are higher bitrate settings that use 32 kHz.

If you insist on changing the resampling rate to 44.1 kHz (maybe your hardware player only supports this rate), you can use the command line switch --resample 44100, e.g.

lame --alt-preset 64 --resample 44100 filename.wav filename.mp3

But bear in mind that the bandwidth will be no better and the bitrate may not average out to 64kbps as well as it would using the unaltered alt-preset.

If you want better quality at 64 kbps, there are better formats than MP3 in this bitrate range.

Dick Darlington
Go to the top of the page
+Quote Post
Kawsar
post Jan 16 2003, 06:29
Post #3





Group: Members
Posts: 2
Joined: 5-January 03
Member No.: 4428



Thanks Dick for your detailed answer.

I just wish that I could have more option on my Sony Clie to play Ogg Vorbis or MP3Pro encoded files. Hope something will come out soon to handle these formats. Just crossing my fingers.

//Kawsar


--------------------
--Kawsar
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th December 2014 - 17:03