IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

20 Pages V  « < 2 3 4 5 6 > »   
Reply to this topicStart new topic
Running Foobar in Linux, Alien Cats crossbreeding with Penguins
bubbleguuum
post Jul 20 2007, 08:44
Post #76





Group: Developer
Posts: 1112
Joined: 13-November 05
Member No.: 25748



QUOTE (nbv4 @ Jul 20 2007, 06:37) *
we're talking about jack support, which is different than just "works well with foobar"


Launch winecfg in a console and check you don't have his message when goingin in the Audio tab:

fixme:jack:JACK_drvLoad error loading the jack library libjack.so, please install this library to use jack
Go to the top of the page
+Quote Post
Spirit_of_the_oc...
post Jul 20 2007, 10:24
Post #77





Group: Members
Posts: 583
Joined: 12-September 06
Member No.: 35092



If you upgrade to 9.41 there is just the message that the registered audio driver Jack couldn't be found.
I don't know how to fixed this. I searched with google but didn' find anything how to fix this...
Maybe the alsa wrapper in jack can help?
Go to the top of the page
+Quote Post
Yotsuya
post Jul 21 2007, 05:56
Post #78





Group: Members
Posts: 1535
Joined: 8-May 06
Member No.: 30546



When switching to the audio tab, the only errors winecfg is spitting out are:
QUOTE
fixme:wave:ALSA_AddCaptureDevice Add support for DSCapture
ALSA lib ../../../src/pcm/pcm_mmap.c:369:(snd_pcm_mmap) mmap failed: Invalid argument
fixme:wave:ALSA_AddCaptureDevice Add support for DSCapture
ALSA lib ../../../src/pcm/pcm_mmap.c:369:(snd_pcm_mmap) mmap failed: Invalid argument

JACK is not appearing as an available sound driver:

I am running wine v0.9.41 on kubuntu 7.04 (feisty fawn) x86_64.

To resolve the original error of the missing libjack I used:
CODE
sudo ln -s /usr/lib/libjack0.100.0.so.0 /usr/lib/wine/libjack.so


If you do not have a /usr/lib/libjack0.100.0.so.0 you might want to:
CODE
sudo apt-get install libjack0.100.0-0


For more information on getting Jack up and running you might find this tutorial helpful.

This post has been edited by Yotsuya: Jul 21 2007, 06:12


--------------------
http://www.ubuntu.com
Go to the top of the page
+Quote Post
nbv4
post Jul 21 2007, 18:59
Post #79





Group: Members
Posts: 186
Joined: 27-June 03
Member No.: 7420



QUOTE (bubbleguuum @ Jul 20 2007, 00:44) *
QUOTE (nbv4 @ Jul 20 2007, 06:37) *

we're talking about jack support, which is different than just "works well with foobar"


Launch winecfg in a console and check you don't have his message when goingin in the Audio tab:

fixme:jack:JACK_drvLoad error loading the jack library libjack.so, please install this library to use jack

all I get is:

CODE
nbv4@nbv4:~$ winecfg
fixme:wave:ALSA_AddCaptureDevice Add support for DSCapture
fixme:mixer:ALSA_MixerInit No master control found, disabling mixer
Go to the top of the page
+Quote Post
Spirit_of_the_oc...
post Jul 21 2007, 19:37
Post #80





Group: Members
Posts: 583
Joined: 12-September 06
Member No.: 35092



wine v0.9.41 doesn't seem to support jack but 0.9.40 is..
Go to the top of the page
+Quote Post
skamp
post Jul 29 2007, 12:39
Post #81





Group: Developer
Posts: 1450
Joined: 4-May 04
From: France
Member No.: 13875



The audio still goes into a short loop whenever I load a web page in firefox. I'm currently using wine 0.9.41 - there's a new version (0.9.42) out since two days ago, I'm waiting for Ubuntu Feisty packages to show up.


--------------------
See my profile for measurements, tools and recommendations.
Go to the top of the page
+Quote Post
Thanasis159
post Jul 29 2007, 21:27
Post #82





Group: Members
Posts: 15
Joined: 24-July 07
Member No.: 45606



I will try it... Hope it works!
Go to the top of the page
+Quote Post
nbv4
post Aug 2 2007, 00:44
Post #83





Group: Members
Posts: 186
Joined: 27-June 03
Member No.: 7420



QUOTE (skamp @ Jul 29 2007, 04:39) *
The audio still goes into a short loop whenever I load a web page in firefox. I'm currently using wine 0.9.41 - there's a new version (0.9.42) out since two days ago, I'm waiting for Ubuntu Feisty packages to show up.

Thats actually a Firefox problem, not really a wine/foobar problem. Firefox spikes CPU usage to 100% for a second or two when you load certain webpages. I guess wine could stand to handle that spike a little better, but if you were to use another browser, I bet you wouldn't have any "looping"
Go to the top of the page
+Quote Post
skamp
post Aug 2 2007, 11:57
Post #84





Group: Developer
Posts: 1450
Joined: 4-May 04
From: France
Member No.: 13875



nbv4: that's not the point. Different applications have different requirements. Audio playback must never skip, no matter the CPU usage. Whatever I do, with firefox or other apps, XMMS playback doesn't skip, loop or stutter. I can encode files to FLAC or WavPack while playing music with XMMS without the playback getting disturbed.

Maybe it's just a buffer issue, I have no idea (nor do I know how to configure that with wine). I tried changing foobar's buffer, it didn't solve the problem.
I upgraded to wine 0.9.42 btw, no improvement.


--------------------
See my profile for measurements, tools and recommendations.
Go to the top of the page
+Quote Post
fivre
post Aug 3 2007, 07:58
Post #85





Group: Members
Posts: 13
Joined: 7-July 05
Member No.: 23190



I'm not sure about stutter (music stutters when I run yes, but so does everything else) but everything I play has this annoying snow in the background. I assume this is wine's fault, but how can I fix it?
Go to the top of the page
+Quote Post
Yotsuya
post Aug 4 2007, 00:28
Post #86





Group: Members
Posts: 1535
Joined: 8-May 06
Member No.: 30546



fivre: I once encountered some background whitenoise and resolved it by making the output bitdepth of my foobar match the bitdepth of my wine settings.

Compare:
File> Preferences> Playback> Output> "Output data format"

With:
wincfg> "Audio" Tab> "Default Bits Per Sample"

You might also want to try changing "Default Sample Rate" from 48khz to 44.1Khz, or switching from ALSA to OSS.

---
On another note, wine 0.9.42 and still no JACK.
---

And for something totally different, I recently discovered a nice player for linux called gmusicbrowser. It has a customizable interface, supports ID3v2.4 custom tags, supports album art in the playlist, playlists grouped by album (with collapsable headers), and a whole slew of other stuff. The project is not as mature as foobar and it primarily for playback only (no conversion utils that I could find) but you might find it worth a try. I find it quite nice when I'm sick of wrestling with wine.


This post has been edited by Yotsuya: Aug 7 2007, 03:45


--------------------
http://www.ubuntu.com
Go to the top of the page
+Quote Post
fivre
post Aug 9 2007, 03:42
Post #87





Group: Members
Posts: 13
Joined: 7-July 05
Member No.: 23190



QUOTE (Yotsuya @ Aug 3 2007, 18:28) *
fivre: I once encountered some background whitenoise and resolved it by making the output bitdepth of my foobar match the bitdepth of my wine settings.

[Wine settings etc.]

Thanks, that helped a lot.

Still seems a bit off, but that's probably just me expecting it to be off.
Go to the top of the page
+Quote Post
skamp
post Aug 11 2007, 11:31
Post #88





Group: Developer
Posts: 1450
Joined: 4-May 04
From: France
Member No.: 13875



QUOTE (Yotsuya @ Aug 4 2007, 01:28) *
And for something totally different, I recently discovered a nice player for linux called gmusicbrowser.

Since it uses Gstreamer, I can only assume it doesn't have gapless playback. Aqualung does...


--------------------
See my profile for measurements, tools and recommendations.
Go to the top of the page
+Quote Post
Yotsuya
post Aug 11 2007, 14:18
Post #89





Group: Members
Posts: 1535
Joined: 8-May 06
Member No.: 30546



skamp: It can use mpeg321, gstreamer, or mplayer (or even icecast) for output. It is not restricted to gstreamer. I wish they had a proper forum for discussion and development though. Foobar is still a far more mature program but wine is such a headache.


--------------------
http://www.ubuntu.com
Go to the top of the page
+Quote Post
skamp
post Aug 11 2007, 15:23
Post #90





Group: Developer
Posts: 1450
Joined: 4-May 04
From: France
Member No.: 13875



QUOTE (Yotsuya @ Aug 11 2007, 15:18) *
It can use mpeg321, gstreamer, or mplayer (or even icecast) for output.

Neither of which supports gapless playback, if I'm not mistaken.


--------------------
See my profile for measurements, tools and recommendations.
Go to the top of the page
+Quote Post
Spirit_of_the_oc...
post Aug 21 2007, 11:24
Post #91





Group: Members
Posts: 583
Joined: 12-September 06
Member No.: 35092



I think I have made a mistake when updating to a version of wine later then .9.40.
Now I have the stutters again although using jack.
I regret having updated. So there is really a truth in

"NEVER CHANGE A RUNNING SYSTEM!"

Maybe I will make a complete new Feisty: I can't live without Foobar although Ubuntu has its own charm smile.gif
Go to the top of the page
+Quote Post
stampgevaar
post Aug 22 2007, 20:55
Post #92





Group: Members
Posts: 237
Joined: 9-September 06
Member No.: 34997



QUOTE (Yotsuya @ Aug 4 2007, 01:28) *
And for something totally different, I recently discovered a nice player for linux called gmusicbrowser. It has a customizable interface, supports ID3v2.4 custom tags, supports album art in the playlist, playlists grouped by album (with collapsable headers), and a whole slew of other stuff. The project is not as mature as foobar and it primarily for playback only (no conversion utils that I could find) but you might find it worth a try. I find it quite nice when I'm sick of wrestling with wine.


looks cool, is it also possible to customize your library like say the album list? And to use covers in your library (library filter)?
Go to the top of the page
+Quote Post
dkg
post Aug 27 2007, 09:00
Post #93





Group: Members
Posts: 9
Joined: 27-August 07
Member No.: 46539



gentoo-amd64, wine v0.9.38, foobar v.0.9.4.4, and lots of plugins. biggrin.gif

Go to the top of the page
+Quote Post
j8ee
post Aug 27 2007, 21:06
Post #94





Group: Members
Posts: 119
Joined: 31-January 02
From: Sweden, Gothenburg
Member No.: 1212



Is dragging menu toolbars working for anyone here? I can't move or re-order any of them whatever I try, and it's driving me nuts. Maybe I have to make a parallel installation in windows, and move the config file? Thinking of it, I should be able to just run foobar from the linux folder and make any changes I want... hmm... I'll try it and report back.

Other than that it seems like it's working flawlessly right away, no sound stuttering or graphical glitches.

Using Kubuntu Gutsy tribe 4.

This post has been edited by j8ee: Aug 27 2007, 21:07
Go to the top of the page
+Quote Post
skamp
post Aug 27 2007, 21:25
Post #95





Group: Developer
Posts: 1450
Joined: 4-May 04
From: France
Member No.: 13875



Try loading a web page in Firefox while listening to music on foobar2000. If the sound doesn't go into a loop, I'd really like to know more about your setup (I'm using Ubuntu Gutsy myself).


--------------------
See my profile for measurements, tools and recommendations.
Go to the top of the page
+Quote Post
nbv4
post Aug 31 2007, 04:05
Post #96





Group: Members
Posts: 186
Joined: 27-June 03
Member No.: 7420



QUOTE (j8ee @ Aug 27 2007, 13:06) *
Is dragging menu toolbars working for anyone here? I can't move or re-order any of them whatever I try, and it's driving me nuts. Maybe I have to make a parallel installation in windows, and move the config file? Thinking of it, I should be able to just run foobar from the linux folder and make any changes I want... hmm... I'll try it and report back.

Other than that it seems like it's working flawlessly right away, no sound stuttering or graphical glitches.

Using Kubuntu Gutsy tribe 4.

if you minimize the window, leave it for a few minutes, then click on the taskbar, does it come right up every time? That "bug" is by far the most annoying one of all. Theres a way around it by clicking on the systray icon, but that always messes things up by switching desktops.
Go to the top of the page
+Quote Post
Kavika
post Sep 5 2007, 03:54
Post #97





Group: Members
Posts: 1
Joined: 31-January 07
Member No.: 40199



QUOTE (skamp @ Aug 27 2007, 12:25) *
Try loading a web page in Firefox while listening to music on foobar2000. If the sound doesn't go into a loop, I'd really like to know more about your setup (I'm using Ubuntu Gutsy myself).


Did you try setting it to emulation mode instead of hardware mode? The original post seems to say that might fix sound issues. I am having the same problem, so I'll let you know if it fixes it when I get home and try it out.

Edit: Works like a charm! Tried all the settings ("Full" "Standard" "Basic" and "Emulation"), and only "Emulation" worked. Didn't check the "Driver Emulation" check box. Using an ASUS P5K ("Intel HDA" onboard sound) w/ a Core 2 Duo 6450 2.13ghz, 4GB RAM, GeForce 7900 on the latest proprietary driver off nVidia's website. Didn't try messing with buffer lengths, etc, since this seems to work perfectly, so far.

QUOTE
[*]ProjectM - This component doesn't load, something is missing and I do not know what
[*]Queuemanager - This component doesn't load, something is missing and I do not know what


Don't know if this has already been suggested, or if you already tried it. There's a tool for checking library dependencies that may be useful:
http://appdb.winehq.org/appview.php?iAppId=1668
http://appdb.winehq.org/appview.php?iVersionId=2257

This post has been edited by Kavika: Sep 5 2007, 08:32
Go to the top of the page
+Quote Post
skamp
post Sep 13 2007, 10:09
Post #98





Group: Developer
Posts: 1450
Joined: 4-May 04
From: France
Member No.: 13875



QUOTE (Kavika @ Sep 5 2007, 04:54) *
Edit: Works like a charm! Tried all the settings ("Full" "Standard" "Basic" and "Emulation"), and only "Emulation" worked. Didn't check the "Driver Emulation" check box. Using an ASUS P5K ("Intel HDA" onboard sound) w/ a Core 2 Duo 6450 2.13ghz, 4GB RAM, GeForce 7900 on the latest proprietary driver off nVidia's website. Didn't try messing with buffer lengths, etc, since this seems to work perfectly, so far.

Well, if foobar was using one core for playback, and firefox used the other core, obviously loading a web page in firefox wouldn't affect foobar. In any case your setup is orders of magnitude faster than mine, which doesn't mean there is no software issue with wine, only that your setup is too fast for the problem to surface.
Note that I have switched to Opera for browsing the web, and it's much faster on my setup than firefox.


--------------------
See my profile for measurements, tools and recommendations.
Go to the top of the page
+Quote Post
sveterv
post Sep 14 2007, 09:49
Post #99





Group: Members
Posts: 6
Joined: 8-February 02
Member No.: 1289



There is one thing which can resolve all your problems guys. I had the same problems as you with skipping Foobar2000 under wine, while doing CPU intensive tasks, well even those not really intensive skipped sound, like starting Firefox sad.gif

You need just to recompile your kernel, with CFS (Complete Fair Scheduler) patch. Here is the official link for patch:
http://people.redhat.com/mingo/cfs-scheduler/

It will be default CPU time scheduler in 2.6.23 kernel, until then you need to patch your source. It only changes the way, CPU time is distributed to all the running processes in your system. It can't hurt your system or something like this, and it's stable as a rock, as I sad it will be in next official kernel by default.

Now i can, compile kernel(!), run Firefox, listen music, run updatedb, and do many more things at one time without even 1 sec sound skipping, so i think this says all.

Cheers!
Go to the top of the page
+Quote Post
FredPT
post Sep 17 2007, 22:23
Post #100





Group: Members
Posts: 1
Joined: 11-September 07
Member No.: 46958



Hi there! This news about the CFS are great, but I guess I'll wait for the new kernel, it's less risky.

Anyway I'm having a very nice experience with wine+foobar2000 but I'm noticing some skipping when I resume playback from a pause, does anyone else noticed this?
Go to the top of the page
+Quote Post

20 Pages V  « < 2 3 4 5 6 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2014 - 15:40