IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Lame 3.98a9 error encoding
Fishman0919
post Dec 20 2006, 20:10
Post #1





Group: Members
Posts: 79
Joined: 18-December 03
Member No.: 10554



I was tring to convert wav's to mp3's with frontah using Lame 3.98a9 and the setting -V 2 --vbr-old and I got this error

"Assertion failed: thr[b] >= 0, file psymodel.c, line 670"


Edit: tried with -V 2 --vbr-new and got the same results

This post has been edited by Fishman0919: Dec 20 2006, 20:11
Go to the top of the page
+Quote Post
Junon
post Dec 20 2006, 20:22
Post #2





Group: Members
Posts: 520
Joined: 27-August 06
From: Germany
Member No.: 34518



QUOTE (Fishman0919 @ Dec 20 2006, 20:10) *
I was tring to convert wav's to mp3's with frontah using Lame 3.98a9 and the setting -V 2 --vbr-old and I got this error

"Assertion failed: thr[b] >= 0, file psymodel.c, line 670"


Edit: tried with -V 2 --vbr-new and got the same results


There's a link with a working version in another topic about this issue.

Edit: Muahahahahahaha! I was first!

This post has been edited by Junon: Dec 20 2006, 20:31
Go to the top of the page
+Quote Post
Firon
post Dec 20 2006, 20:26
Post #3





Group: Members
Posts: 830
Joined: 3-November 05
Member No.: 25526



http://www.hydrogenaudio.org/forums/index....&hl=3.98a9#

Edit: Damn. Beat while I was searching. tongue.gif

This post has been edited by Firon: Dec 20 2006, 20:26
Go to the top of the page
+Quote Post
Fishman0919
post Dec 20 2006, 20:34
Post #4





Group: Members
Posts: 79
Joined: 18-December 03
Member No.: 10554



Thx, sorry I'm at work and didn't have much time to search
Go to the top of the page
+Quote Post
db1989
post Dec 20 2006, 21:28
Post #5





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Rarewares has updated 3.98a9 compiles which may fix this.
Go to the top of the page
+Quote Post
john33
post Dec 20 2006, 21:36
Post #6


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3765
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



QUOTE (dv1989 @ Dec 20 2006, 21:28) *
Rarewares has updated 3.98a9 compiles which may fix this.

Nope, they don't! wink.gif I could probably 'fix' it by commenting out the offending 'assert', but I'm sure that would not really be the right thing to do. Hopefully, Robert will fix it in the CVS momentarily.


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
db1989
post Dec 20 2006, 21:50
Post #7





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Ah, sorry, John! I simply assumed that because I thought that they were re-uploaded after a day. blink.gif
Go to the top of the page
+Quote Post
john33
post Dec 20 2006, 22:05
Post #8


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3765
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



Well, I just tried commenting out the offending 'asserts' and although it completes encoding, '-V 2 --vbr-new' produces what is almost CBR at 319kbps!! blink.gif So, clearly something has been broken.


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
db1989
post Dec 20 2006, 22:06
Post #9





Group: Super Moderator
Posts: 5275
Joined: 23-June 06
Member No.: 32180



Haha, this is a pickle! biggrin.gif Well, let's hope that the good LAME developers figure something out soon. wink.gif
Go to the top of the page
+Quote Post
robert
post Dec 20 2006, 22:23
Post #10


LAME developer


Group: Developer
Posts: 789
Joined: 22-September 01
Member No.: 5



Well, I don't have newer sources than what's in CVS already. John33 are you sure you have latest sources? Did you make a clean rebuild?
Go to the top of the page
+Quote Post
john33
post Dec 21 2006, 00:00
Post #11


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3765
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



QUOTE (robert @ Dec 20 2006, 22:23) *
Well, I don't have newer sources than what's in CVS already. John33 are you sure you have latest sources? Did you make a clean rebuild?

Yep. Just double checked everything and building via the VC6 IDE and the VC8 IDE, both using ICL9.1 yields the same error message. unsure.gif


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
john33
post Dec 21 2006, 00:21
Post #12


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3765
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



Hmmm, a straight VC8 compile encodes cleanly, but the ICL version fails. I'll look at this more closely tomorrow.


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
Enig123
post Dec 21 2006, 03:19
Post #13





Group: Members
Posts: 209
Joined: 11-April 02
Member No.: 1749



Still the same error with latest CVS code, compiled by MinGW, no extra optimization.
Go to the top of the page
+Quote Post
robert
post Dec 21 2006, 03:30
Post #14


LAME developer


Group: Developer
Posts: 789
Joined: 22-September 01
Member No.: 5



10 minutes ago I checked in a bug fix, so you may try again later.
Go to the top of the page
+Quote Post
Enig123
post Dec 21 2006, 03:47
Post #15





Group: Members
Posts: 209
Joined: 11-April 02
Member No.: 1749



Alright.

Now it's OK.

BTW, how can I optimize compilation of lame with MinGW as compiler? Should I change Makefile options or do something else, like get a copy of nasm?
Go to the top of the page
+Quote Post
john33
post Dec 21 2006, 11:05
Post #16


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3765
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



QUOTE (robert @ Dec 21 2006, 03:30) *
10 minutes ago I checked in a bug fix, so you may try again later.

Thanks a lot Robert, all seems OK now. smile.gif

The only problem I have now is that Rarewares is down, so I can't upload!! crying.gif

If anyone is desperate, you can download alpha10 from: http://homepage.ntlworld.com/jfe1205/LAME/ until I can get back to Rarewares.


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
halb27
post Dec 21 2006, 11:10
Post #17





Group: Members
Posts: 2448
Joined: 9-October 05
From: Dormagen, Germany
Member No.: 25015



QUOTE (robert @ Dec 21 2006, 04:30) *
10 minutes ago I checked in a bug fix, so you may try again later.

As that will be alpha10 on Rarewares and as I tested the dll based alpha9 version from the link you provided:

Should I expect another behavior so that it's worth testing again? Or is it just a technical bug fix for the assertion error?


--------------------
lame3100m -V1 --insane-factor 0.75
Go to the top of the page
+Quote Post
robert
post Dec 21 2006, 13:25
Post #18


LAME developer


Group: Developer
Posts: 789
Joined: 22-September 01
Member No.: 5



It's more of a technical fix, you don't need to test the same samples again.
Go to the top of the page
+Quote Post
john33
post Dec 21 2006, 14:10
Post #19


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3765
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



Rarewares is back up and the files are now in their usual place. smile.gif


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 28th December 2014 - 22:07