IPB

Welcome Guest ( Log In | Register )

2 Pages V  < 1 2  
Reply to this topicStart new topic
foo_dsp_winamp, Winamp DSP Bridge
markanini
post Apr 26 2012, 00:11
Post #26





Group: Members
Posts: 550
Joined: 22-December 03
From: Malmö, Sweden
Member No.: 10615



That would be awesome but I can't but I can't help but wonder about floating point processing. Is that even possible?
Go to the top of the page
+Quote Post
mudlord
post Apr 27 2012, 05:43
Post #27





Group: Developer (Donating)
Posts: 805
Joined: 1-December 07
Member No.: 49165



Winamp DSP API doesn't do float, only ints.
Go to the top of the page
+Quote Post
markanini
post Jun 13 2012, 21:27
Post #28





Group: Members
Posts: 550
Joined: 22-December 03
From: Malmö, Sweden
Member No.: 10615



QUOTE (lvqcl @ Apr 25 2012, 16:17) *
(OTOH, it is possible to write a DSP plugin that will cancel this limiter...)

Any chance you could build that?
Go to the top of the page
+Quote Post
lvqcl
post Jun 14 2012, 16:04
Post #29





Group: Developer
Posts: 3336
Joined: 2-December 07
Member No.: 49183



QUOTE (markanini @ Jun 14 2012, 00:27) *
Any chance you could build that?

Here it is... foo_dsp_invhardlimit ver 0.0.1
Put it before foo_dsp_wnamp.
Go to the top of the page
+Quote Post
saviormoney
post May 5 2013, 23:01
Post #30





Group: Members
Posts: 7
Joined: 13-March 06
Member No.: 28435



So I was going to try to use this foobar plugin to attempt to load this vocal remover:

http://www.analogx.com/contents/download/A...er/Freeware.htm

however, it appears version 1.4.7 of this plugin no longer works with foobar2000.

Failed to load DLL: foo_dsp_winamp.dll
Reason: Wrong version number; this component appears to have been built with an outdated version of the foobar2000 SDK and needs to be recompiled with newer version in order to load; please contact the author of this component to obtain an updated version of this component.


Anyone have the source to this that they'd be willing to recompile or at least share?

Thank you,

saviormoney
Go to the top of the page
+Quote Post
lvqcl
post May 6 2013, 15:16
Post #31





Group: Developer
Posts: 3336
Joined: 2-December 07
Member No.: 49183



Works here. Component from post #21 and foobar2000 1.2.6
Go to the top of the page
+Quote Post
DJ_DOGGY
post May 23 2013, 13:13
Post #32





Group: Members
Posts: 11
Joined: 22-May 10
Member No.: 80833



Yeah , will it be a version that exclude the limiter to -3 db? In this way we will install only the plugin. Now we must install other things to cancel this?!
Go to the top of the page
+Quote Post

2 Pages V  < 1 2
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 29th July 2014 - 14:14