IPB

Welcome Guest ( Log In | Register )

3 Pages V  < 1 2 3 >  
Reply to this topicStart new topic
LAME 3.97 released
Demetris
post Sep 25 2006, 13:59
Post #26





Group: Members
Posts: 105
Joined: 12-January 06
Member No.: 27057



Thanks to the LAME developers, to all the testers and issue-reporters, and to those who compile for us!
Go to the top of the page
+Quote Post
ddrawley
post Sep 25 2006, 15:52
Post #27





Group: Members (Donating)
Posts: 351
Joined: 10-November 02
Member No.: 3749



Please ignore, my question was already answered.

This post has been edited by ddrawley: Sep 25 2006, 15:53
Go to the top of the page
+Quote Post
BinaryTB
post Sep 25 2006, 16:53
Post #28





Group: Members
Posts: 22
Joined: 7-July 05
From: Boston, MA
Member No.: 23188



I ask this every release, but how long until we stop needing the "lame.exe fixed for decoding through stdout" version? I mean, I guess the fix has been around for a while, but I don't understand why there is a separate compile every time there is a new version instead of just fixing the regular release version.
Go to the top of the page
+Quote Post
k.eight.a
post Sep 25 2006, 18:34
Post #29





Group: Members
Posts: 434
Joined: 31-October 03
From: Europe, CZ
Member No.: 9571



QUOTE (Spooon69 @ Sep 25 2006, 17:53) *
I ask this every release, but how long until we stop needing the "lame.exe fixed for decoding through stdout" version? I mean, I guess the fix has been around for a while, but I don't understand why there is a separate compile every time there is a new version instead of just fixing the regular release version.
I wonder about the same issue too... laugh.gif


--------------------
Sorry for my poor English, I'm trying to get better... ;)
"The greatest trick the Devil ever pulled, was convincing the world he didn't exist."
Go to the top of the page
+Quote Post
krmathis
post Sep 25 2006, 18:56
Post #30





Group: Members
Posts: 742
Joined: 27-May 02
From: Oslo, Norway
Member No.: 2133



LAME 3.97 for Mac OS X (Universal binary).
Feel free to host it on RareWares! wink.gif
Go to the top of the page
+Quote Post
john33
post Sep 25 2006, 19:29
Post #31


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3764
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



QUOTE (krmathis @ Sep 25 2006, 18:56) *
LAME 3.97 for Mac OS X (Universal binary).
Feel free to host it on RareWares! wink.gif

Now at Rarewares, thanks a lot. smile.gif


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
krmathis
post Sep 25 2006, 19:58
Post #32





Group: Members
Posts: 742
Joined: 27-May 02
From: Oslo, Norway
Member No.: 2133



QUOTE (john33 @ Sep 25 2006, 20:29) *
Now at Rarewares, thanks a lot. smile.gif

My pleasure!
Go to the top of the page
+Quote Post
Martin H
post Sep 25 2006, 22:59
Post #33





Group: Members
Posts: 857
Joined: 5-March 05
From: Denmark
Member No.: 20365



QUOTE (k.eight.a @ Sep 25 2006, 19:34) *
QUOTE (Spooon69 @ Sep 25 2006, 17:53) *
I ask this every release, but how long until we stop needing the "lame.exe fixed for decoding through stdout" version? I mean, I guess the fix has been around for a while, but I don't understand why there is a separate compile every time there is a new version instead of just fixing the regular release version.
I wonder about the same issue too... laugh.gif

The fix for decoding MP3s gaplessly ie. modifying the decoder to also remove the trailing padding, and for decoding through stdout has been added to CVS and are included in the latest LAME v3.98 alpha ie. LAME v3.98a6.

This post has been edited by Martin H: Sep 25 2006, 23:58
Go to the top of the page
+Quote Post
gameplaya15143
post Sep 25 2006, 23:38
Post #34





Group: Members
Posts: 484
Joined: 8-January 06
From: Earth
Member No.: 26978



QUOTE (probedb @ Sep 25 2006, 08:44) *
Woo hoo, and I was going to reencode all my FLAC files so here's hoping dbpowerAMP gets sorted with 3.97 soon!!
You can replace lame_enc.dll in illustrate/dbpoweramp/compression/lame/ with the new version. Or you can use the generic cli plugin and use lame.exe.

I'll be getting 3.97 final going with dbpoweramp myself later on.

Thanks to the devs!


--------------------
Vorbis-q0-lowpass99
lame3.93.1-q5-V9-k-nspsytune
Go to the top of the page
+Quote Post
Mgz
post Sep 26 2006, 04:49
Post #35





Group: Members
Posts: 155
Joined: 11-December 02
From: Alberta
Member No.: 4049



those winamp 5.25 guy better make an update quick then biggrin.gif

they just add lame 3.97beta something a week ago or so biggrin.gif


--------------------
still LAME 3.96.1 --preset extreme -q 0 -V 0 -m s at least until 2005.
Go to the top of the page
+Quote Post
spoon
post Sep 26 2006, 08:02
Post #36


dBpowerAMP developer


Group: Developer (Donating)
Posts: 2758
Joined: 24-March 02
Member No.: 1615



The R12 alpha will get 3.97 (non beta) early next week.


--------------------
Spoon http://www.dbpoweramp.com
Go to the top of the page
+Quote Post
Maurits
post Sep 26 2006, 09:47
Post #37





Group: Members
Posts: 413
Joined: 30-September 05
From: London, Europe
Member No.: 24805



QUOTE (john33 @ Sep 25 2006, 19:29) *
QUOTE (krmathis @ Sep 25 2006, 18:56) *

LAME 3.97 for Mac OS X (Universal binary).
Feel free to host it on RareWares! wink.gif

Now at Rarewares, thanks a lot. smile.gif

Thanks krmathis and john33!

By the way, it deserves to be mentioned in the Wiki as well: http://wiki.hydrogenaudio.org/index.php?ti...and_source_code
Go to the top of the page
+Quote Post
probedb
post Sep 26 2006, 10:01
Post #38





Group: Members
Posts: 1321
Joined: 6-September 04
Member No.: 16817



QUOTE (gameplaya15143 @ Sep 25 2006, 23:38) *
QUOTE (probedb @ Sep 25 2006, 08:44) *
Woo hoo, and I was going to reencode all my FLAC files so here's hoping dbpowerAMP gets sorted with 3.97 soon!!
You can replace lame_enc.dll in illustrate/dbpoweramp/compression/lame/ with the new version. Or you can use the generic cli plugin and use lame.exe.

I'll be getting 3.97 final going with dbpoweramp myself later on.


Excellent, thanks for this I shall give it a go smile.gif
Go to the top of the page
+Quote Post
krmathis
post Sep 26 2006, 15:51
Post #39





Group: Members
Posts: 742
Joined: 27-May 02
From: Oslo, Norway
Member No.: 2133



QUOTE (Maurits @ Sep 26 2006, 10:47) *
Thanks krmathis and john33!

You are most welcome!

QUOTE
By the way, it deserves to be mentioned in the Wiki as well: wiki.hydrogenaudio.org

Then edit the Wiki yourself, and add the information you want in there... wink.gif
Go to the top of the page
+Quote Post
DrO
post Sep 26 2006, 18:49
Post #40





Group: Members
Posts: 77
Joined: 15-April 04
Member No.: 13511



QUOTE (Mgz @ Sep 26 2006, 04:49) *
those winamp 5.25 guy better make an update quick then biggrin.gif

they just add lame 3.97beta something a week ago or so biggrin.gif

that's not quite true since the recent lame builds have been in the 5.25betas for most of the ~2month public beta run and the final version is already in internal builds so not something to worry about i think, heh wink.gif

-daz
Go to the top of the page
+Quote Post
ZinCh
post Sep 28 2006, 11:36
Post #41





Group: Members
Posts: 171
Joined: 28-September 06
Member No.: 35705



thanks for your work!

can you also add *NIX version to rarewares ? (plus freebsd , linux , other compliation ?)
Go to the top of the page
+Quote Post
Alex B
post Sep 30 2006, 22:14
Post #42





Group: Members
Posts: 1303
Joined: 14-September 05
From: Helsinki, Finland
Member No.: 24472



Is there any particular reason why lame.exe in the Rarewares 3.97 bundle is now 508 KB. In the 3.97b3 package it was only 263 KB.

I guess it is not compressed similarly, but what is the benefit of the change?


Edit: fixed the size 512 KB -> 508 KB

This post has been edited by Alex B: Sep 30 2006, 22:23


--------------------
http://listening-tests.freetzi.com
Go to the top of the page
+Quote Post
jmartis
post Sep 30 2006, 22:21
Post #43





Group: Members
Posts: 381
Joined: 9-April 06
From: Czech Republic
Member No.: 29311



probably a noob question too, but are there any improvements from 3.97b3 > 3.97 final or is 3.97 final basically the same as 3.97b3?
Go to the top of the page
+Quote Post
DrO
post Sep 30 2006, 22:26
Post #44





Group: Members
Posts: 77
Joined: 15-April 04
Member No.: 13511



Alex B: i believe the upx compression was removed since despite using more space on disk, it's better on the system when loaded into memory when it's run (can't find the few posts where it was described off hand)

jmartis: it should be the same as 3.97b3 (think it was mentioned at the start of the thread)

-daz
Go to the top of the page
+Quote Post
Alex B
post Sep 30 2006, 22:40
Post #45





Group: Members
Posts: 1303
Joined: 14-September 05
From: Helsinki, Finland
Member No.: 24472



I think I found the answer. It wasn't far away.

QUOTE (john33 @ Aug 22 2006, 17:39) *
Actually, this appears to have been a problem with compressing VC8/ICL9.1 compiles with UPX. It is easily reproducable simply by compressing and decompressing. The compressed version fails, and then decompressing it produces a version that works!!

Looks like I either abandon UPX, or test each time I compress - tedious. wink.gif

Looks like he abandoned UPX. rolleyes.gif


--------------------
http://listening-tests.freetzi.com
Go to the top of the page
+Quote Post
john33
post Oct 2 2006, 13:21
Post #46


xcLame and OggDropXPd Developer


Group: Developer
Posts: 3764
Joined: 30-September 01
From: Bracknell, UK
Member No.: 111



QUOTE (Alex B @ Sep 30 2006, 22:40) *
I think I found the answer. It wasn't far away.

Looks like he abandoned UPX. rolleyes.gif

Yep!! wink.gif


--------------------
John
----------------------------------------------------------------
My compiles and utilities are at http://www.rarewares.org/
Go to the top of the page
+Quote Post
xmixahlx
post Oct 2 2006, 17:30
Post #47





Group: Members
Posts: 1394
Joined: 20-December 01
From: seattle
Member No.: 693



fresh lame compiles have been added to RareWares/Debian:

lame, lame-3.97, lame-cvs


later


--------------------
RareWares/Debian :: http://www.rarewares.org/debian.html
Go to the top of the page
+Quote Post
Bourne
post Oct 4 2006, 21:17
Post #48





Group: Banned
Posts: 735
Joined: 19-March 06
Member No.: 28599



I have just upgraded to foobar 0.9.4 and lame final 3.97. Converting FLAC files to mp3 now returns error code 1. Back to the good ole versions of foobar (0.9.1) and lame (3.97b2).

This post has been edited by Bourne: Oct 4 2006, 21:19
Go to the top of the page
+Quote Post
Sunhillow
post Oct 4 2006, 21:29
Post #49





Group: Members (Donating)
Posts: 483
Joined: 13-October 01
From: Stuttgart
Member No.: 286



Better change only 1 parameter at a time, so you can see which change produces the fault
Go to the top of the page
+Quote Post
Bourne
post Oct 4 2006, 21:35
Post #50





Group: Banned
Posts: 735
Joined: 19-March 06
Member No.: 28599



the parameters are the foobar2k ones default... and yes, I tried that in the command line...
i suppose it's just broken?

it's a funny thing though... it didn't happen initially... I got to convert about 3 albums from FLAC to MP3.
it's just that 2 days after I upgraded the lame.exe in foobar2k it just couldn't do it anymore...

This post has been edited by Bourne: Oct 4 2006, 21:43
Go to the top of the page
+Quote Post

3 Pages V  < 1 2 3 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st December 2014 - 23:04