IPB

Welcome Guest ( Log In | Register )

15 Pages V  < 1 2 3 4 5 > »   
Reply to this topicStart new topic
Updated in_mad Winamp MAD MP3 input plugin
MoSPDude
post Aug 4 2006, 17:46
Post #51





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



My bad with the MediaMonkey / DSP problem, I'd updated all the other code for the new buffer except the DSP processing section! Sorry, I'll put it up ASAP, just going to look into the pcutmp3 problem more.

EDIT: I've kind of "patched" the pcutmp3 problem, but I'm not happy with it, if anyone knows more about the libmad decoding delays and why,

LAME mp3s have 3 * 576 + 529 samples off the start when the tag only specifies 576 (by default in LAME encoder.h) from the beginning.
pmp3cut mp3s have (tag value) + 1151 + 529 samples off the start where (tag value) is specified.

Thanks in advanced

This post has been edited by MoSPDude: Aug 4 2006, 18:51
Go to the top of the page
+Quote Post
MoSPDude
post Aug 4 2006, 19:07
Post #52





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



Ok, I've uploaded an update to the usual.

Please if anyone has any extra information regarding the LAME gapless behaviour, I'd appreciate it.

Thanks

This post has been edited by MoSPDude: Aug 4 2006, 19:08
Go to the top of the page
+Quote Post
Big_Berny
post Aug 4 2006, 19:14
Post #53





Group: Members
Posts: 242
Joined: 9-February 03
Member No.: 4921



Well, I don't know the reason but 1151 is 576*2-1.

So:
Lame: 3*576+529
pmp3cut: tagvalue+2*576-1+529

It would be interesting to know what happens when you change the value in lame... Because maybe the "lame-formula" is tagvalue+2*576+529. Then we have only one sample left! wink.gif

Just some stupid ideas of a mathematician withoud any mp3-delay-knowledge. smile.gif
Big_Berny
Go to the top of the page
+Quote Post
MoSPDude
post Aug 4 2006, 19:20
Post #54





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



QUOTE (Big_Berny @ Aug 4 2006, 19:14) *
Well, I don't know the reason but 1151 is 576*2-1.

So:
Lame: 3*576+529
pmp3cut: tagvalue+2*576-1+529

It would be interesting to know what happens when you change the value in lame... Because maybe the "lame-formula" is tagvalue+2*576+529. Then we have only one sample left! wink.gif

Just some stupid ideas of a mathematician withoud any mp3-delay-knowledge. smile.gif
Big_Berny


You know, I might just go for that.....
I think the 529 is purely a libmad delay... as you said, just that 1 sample!

I'll just do another build, and upload another copy with that for ppl to test. I'll post again once its up.
Big_Berny, have you tested MediaMonkey with the build thats up at the moment?
Go to the top of the page
+Quote Post
Big_Berny
post Aug 4 2006, 19:27
Post #55





Group: Members
Posts: 242
Joined: 9-February 03
Member No.: 4921



Maybe a Lame developer can give more informations?

And yes, the MAD-plugin works with MediaMonkey now, thanks! biggrin.gif

Big_Berny

This post has been edited by Big_Berny: Aug 4 2006, 19:28
Go to the top of the page
+Quote Post
MoSPDude
post Aug 4 2006, 19:32
Post #56





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



I've put up the version, ignoring the 1 sample, and it sounds ok with pcutmp3 files - thanks Big_Berny for that fresh view, think I'd been looking at it for too long!! If odyssey could confirm its ok, that'd be great!

I'm going to get back finishing the ID3v2 tag editor now, then perhaps begin APEv2 tags.

Any other bugs etc, feel free to post and help!

Thanks biggrin.gif
Go to the top of the page
+Quote Post
odyssey
post Aug 5 2006, 00:19
Post #57





Group: Members
Posts: 2296
Joined: 18-May 03
From: Denmark
Member No.: 6695



QUOTE (MoSPDude @ Aug 4 2006, 20:32) *
I've put up the version, ignoring the 1 sample, and it sounds ok with pcutmp3 files - thanks Big_Berny for that fresh view, think I'd been looking at it for too long!! If odyssey could confirm its ok, that'd be great!

It works great now biggrin.gif (Please disregard the PM i sent you, I appearently did not update to the latest release)


--------------------
Can't wait for a HD-AAC encoder :P
Go to the top of the page
+Quote Post
MoSPDude
post Aug 5 2006, 01:38
Post #58





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



Another update has been uploaded, I think I've finished the look and basic behaviour of the ID3v2 tag editor. Opinions wanted! tongue.gif

I'll look into recursive tags, APEv2 tags and other suggestions now.

Thanks to all for your comments

EDIT: I've just had to re-upload, I'd left debug messages in still!

EDIT 2: Another minor update, fixed bug reading in ID3v1 to v2 tags in new editor

This post has been edited by MoSPDude: Aug 5 2006, 02:53
Go to the top of the page
+Quote Post
MoSPDude
post Aug 5 2006, 10:47
Post #59





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



Another update uploaded, this time for odyssey to test tongue.gif

In Winamp advanced title formatting, you can now read Helium, any TXXX key/value and ID3v2 text frames! It also scans recursively through the tag for multiple frames.

Just add for example, %#Helium Featured Artist% or %COMM% to the winamp preferences.

This post has been edited by MoSPDude: Aug 5 2006, 10:49
Go to the top of the page
+Quote Post
MedO
post Aug 5 2006, 11:08
Post #60





Group: Members
Posts: 341
Joined: 24-August 05
Member No.: 24095



Wow, great work. Just another question:
What is the behaviour when LAME rg-Tags and other rg-tags are present together? Which one will be preferred?
Go to the top of the page
+Quote Post
MoSPDude
post Aug 5 2006, 12:11
Post #61





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



QUOTE (MedO @ Aug 5 2006, 11:08) *
Wow, great work. Just another question:
What is the behaviour when LAME rg-Tags and other rg-tags are present together? Which one will be preferred?


The order of preference is foobar TXXX tags, the RVA2 tag, then the LAME tag.
Go to the top of the page
+Quote Post
MoSPDude
post Aug 5 2006, 12:38
Post #62





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



DON'T WRITE UPDATED ID3v2 TAGS!!

There appears to be a MAJOR bug that libid3tag written id3v2.4 tags, can't be read by anything else!!

I'll fix it ASAP. crying.gif
Go to the top of the page
+Quote Post
odyssey
post Aug 5 2006, 14:13
Post #63





Group: Members
Posts: 2296
Joined: 18-May 03
From: Denmark
Member No.: 6695



QUOTE (MoSPDude @ Aug 5 2006, 11:47) *
In Winamp advanced title formatting, you can now read Helium, any TXXX key/value and ID3v2 text frames! It also scans recursively through the tag for multiple frames.

Just add for example, %#Helium Featured Artist% or %COMM% to the winamp preferences.

Doesn't seem to work for me. Also I have not been able to find ANY information about this anywhere! I even tried the latest Beta 5.25

This post has been edited by odyssey: Aug 5 2006, 14:28


--------------------
Can't wait for a HD-AAC encoder :P
Go to the top of the page
+Quote Post
MoSPDude
post Aug 5 2006, 14:55
Post #64





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



QUOTE (odyssey @ Aug 5 2006, 14:13) *
QUOTE (MoSPDude @ Aug 5 2006, 11:47) *

In Winamp advanced title formatting, you can now read Helium, any TXXX key/value and ID3v2 text frames! It also scans recursively through the tag for multiple frames.

Just add for example, %#Helium Featured Artist% or %COMM% to the winamp preferences.

Doesn't seem to work for me. Also I have not been able to find ANY information about this anywhere! I even tried the latest Beta 5.25


First, make sure you download the latest release, I've been putting up smaller minor releases.

You need to have Advanced Title Formatting enabled, the feature is a bit of hack. I'm using Winamp 5.24.
If you goto Winamp Preferences, under General Preferences select Titles. Then ensure, Use the advanced title formatting is checked on, and the format string I'm using is,

[%artist%$if2( %#Helium Featured Artist%,) - ]$if2(%title%,$filepart(%filename%))

and it seems to work on all the files I put the tags on.

Winamp passes all the tags contained within the %..% to in_mad, then in_mad finds the tag (artist, title, #Helium Featured Artist etc.) and reports if its there or not. If you can read C, look at "in_mad.c" and "tags.c" - for an idea of how to work it.

I'll add it eventually to the basic formatting.

I'm having a big problem with libid3tag writing tags that nothing else understands, so please bear with me.

Thanks for all help

This post has been edited by MoSPDude: Aug 5 2006, 14:59
Go to the top of the page
+Quote Post
MoSPDude
post Aug 5 2006, 15:09
Post #65





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



The problem does appear to be a long libid3tag problem, and the common solution is to patch libid3tag so it writes ID3v2.3 tags instead of v2.4.

For now, I'll follow the same solution.

An update will be available shortly.
Go to the top of the page
+Quote Post
odyssey
post Aug 5 2006, 15:36
Post #66





Group: Members
Posts: 2296
Joined: 18-May 03
From: Denmark
Member No.: 6695



Edit: I REALLY need to learn to read before posting tongue.gif

This post has been edited by odyssey: Aug 5 2006, 15:38


--------------------
Can't wait for a HD-AAC encoder :P
Go to the top of the page
+Quote Post
MoSPDude
post Aug 5 2006, 16:46
Post #67





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



Does anyone use iTunes?? Can someone please see if iTunes reads the tags written by in_mad correctly?

The patch that audacity applied to write id3v2.3 tags, stops libid3tag reading the tags in. I have no idea why...
Go to the top of the page
+Quote Post
bubka
post Aug 5 2006, 16:48
Post #68





Group: Members
Posts: 239
Joined: 21-July 02
Member No.: 2692



anyway to fix the visualization so that it's not all maxed out? I have both RG (radio) and clipping enabled. Also have id3v1 show by default. Thanks! i think the 24bit output adds quite a bit extra... keep up the work!


--------------------
Chaintech AV-710
Go to the top of the page
+Quote Post
MoSPDude
post Aug 5 2006, 20:41
Post #69





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



I'm having a fair bit of trouble regarding ID3v2.3 and v2.4 tags, it seems like a lottery if they get read correctly by Winamp, Helium or a few others. Disabling CRC sometimes works, and it appears fields are getting scrambled.

I'll upload a new version once I've solved it.
Go to the top of the page
+Quote Post
MoSPDude
post Aug 5 2006, 21:28
Post #70





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



Eureka!! libid3tag breaks the rules. I'll fix it up, and get a new release up - I've got to undo all the work on adding id3v2.3 tags! Unless you want an option to write either id3v2.3 or id3v2.4 tags??
Go to the top of the page
+Quote Post
MoSPDude
post Aug 6 2006, 01:03
Post #71





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



I've finally uploaded another update. ID3v2.4 tags are now written properly, on all files I tested - and can be read properly by other taggers too.

@bubka, what do you mean by visualisation maxed out? Please can I have details of what visualisation etc. I think I will add a tag select box - probably once I've looked into APE tags. I'm also thinking of adding a preamp option for mp3s without replaygain info as suggested by bladecgn.

@hecatomber, I don't know about last.fm but I'll look into it eventually.
Go to the top of the page
+Quote Post
MoSPDude
post Aug 6 2006, 15:00
Post #72





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



Yet another update, APEv2 tags are now read. If mp3gain undo information is detected, then replaygain is disabled. The preference for replaygain data is APE tag, id3 tag then the lame tag. APE tag writing is not yet supported.

Download from the usual http://www.zen23652.zen.co.uk/in_mad.zip
Go to the top of the page
+Quote Post
MedO
post Aug 6 2006, 17:38
Post #73





Group: Members
Posts: 341
Joined: 24-August 05
Member No.: 24095



QUOTE (MoSPDude @ Aug 6 2006, 16:00) *
If mp3gain undo information is detected, then replaygain is disabled.


This is not necessary IMO, because mp3gain adjusts the replaygain information in the APE tags when it changes a file. So if the RG tags are present before mp3gain is run, they are adjusted, and if they were created after mp3gain changed the files they are correct as well. So as long as you make sure only APE-tags are read when mp3gain undo information is present, everything should work fine.

Since APE-tags are the preferred RG-source anyway you don't have to worry at all. If mp3gain doesn't adjust the RG info because tag writing is disabled, then there will be no undo info in the tags either.

Hope that made some kind of sense. biggrin.gif

This post has been edited by MedO: Aug 6 2006, 17:39
Go to the top of the page
+Quote Post
MoSPDude
post Aug 6 2006, 18:01
Post #74





Group: Members
Posts: 175
Joined: 24-July 06
From: Sheffield, UK
Member No.: 33249



Ah right, I'll make the necessary changes. I think the config box is in need of an overhaul, then I can add tag preference options etc.

Anyone found any bugs in the APE tag reading, or ID3v2 tag read/writing? The latter has been giving me some grief.

Thanks,
Craig smile.gif
Go to the top of the page
+Quote Post
odyssey
post Aug 7 2006, 10:02
Post #75





Group: Members
Posts: 2296
Joined: 18-May 03
From: Denmark
Member No.: 6695



QUOTE (MoSPDude @ Aug 5 2006, 21:41) *
it seems like a lottery if they get read correctly by Winamp, Helium or a few others.

I suspect something in Winamp is correcting it... Maybe Nullsoft in_mp3? I tried playing a file i've updated, which was not recognized the first time, but afterwards I had no problems.

Btw, is this still an error or did you correct it by writing only ID3v2.3 tags ?


--------------------
Can't wait for a HD-AAC encoder :P
Go to the top of the page
+Quote Post

15 Pages V  < 1 2 3 4 5 > » 
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 1st October 2014 - 22:20